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Preface

Preface
Why a ‘Getting Started for Design’ Manual ?

12d Model is supplied with a comprehensive on-line Reference manual which describes the function of
each menu option in detail. It is a Reference manual however and makes no attempt to describe how to use
12d for production surveying and civil engineering work.

The Getting Started for Design manual is designed to show you how to work with the context sensitive
help system, and then as the first section of Training, help you start to learn how to use /24 to achieve
typical civil engineering tasks. The Getting Started for Design manual uses examples where possible to
clarify usage. It complements rather than replaces the Reference manual. In general, information in the
Reference manual will not be duplicated here.

The Getting Started for Design manual is available as a printed manual and as a PDF file on the /2d Model
11 Installation DVD.

Training Material

The training tutorials assumes that a series of files are already on your hard disk. These tutorial files are
automatically installed from the DVD during installation of the 72d Model software.

Getting Started for Surveying

There is also a Getting Started for Surveying which has the first seven chapters in common with the
Getting Started for Design manual (context sensitive help and basic modelling) but then diverts to cover
topics from the direction of a Surveyor whereas the Getting Started for Design manual continues on with
alignment design techniques.

The Getting Started for Surveying manual is available as a printed manual and as a PDF file on the on the
12d Model 11 Installation DVD.

Using the Practise and Small Versions of 12d Model
IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11

The Practise version of 72d Model is limited to a maximum of 5,000 points. Following the procedures as
stated in the Training Manual may create projects with more than 5,000 points.

Where appropriate, the text will suggest how to vary the input for each instruction so that the example
feature can be completed within the limits of the 12d Model Practise version.

The number of points used at any time in the Practise and small versions can be displayed by the option
Projects => Check base points

The easiest way to reduce the current point count is to delete any unwanted models with
Models => Delete

The installed icon on your desktop for running the practise version of 12d with these training files is

labelled 12d 11 Practise.

Please Note: Projects created by Practise versions of 12d Model cannot be accessed by Release versions
of 12d Model and vice-versa.






Installing 12d Model

The 12d Model 11 Installation DVD can be used to install the Release and Practise versions of
12d Model 11.

IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11

The Practise version is limited to a maximum of 5,000 points and creates projects that cannot be
accessed by the Release versions of 12d Model and vice-versa. However the Practise version
can be used free of charge by 12d Solutions customers and registered Practise Users.

Installing the Release Version for Sites Not Running 12d Model 9 or 12d Model 10

For a new installation of the Release version of 712d Model 11, the user is provided with
(a) one 12d Model dongle
(b) one 12d Model 11 Installation DVD

(c) an email with the 712d Model 11 authorization file nodes. 12d11n attached, or a folder with the
12d Model 11 authorization file nodes.12d11n or nodes.4d in it.

Please check that you have all three items before commencing the installation.

The notes and video for a new install of the Release version of 12d Model 10 are on the
12d Model 11 Installation DVD or can be downloaded from the 12d web site www. 12d.com
under the Updates area.

Installing the Release Version for Sites Already Running 12d Model 9 or 12d
Model 10

Existing 12d Model 9 or 12d Model 10 users already have a dongle and so are only provided with
(a) one 12d Model 11 Installation DVD

(b) an email with the 12d Model 11 authorization file nodes.12d11n attached, or a folder with the
12d Model 11 authorization file nodes.12d11n or nodes.4d in it.

For existing 712d Model 9 and 10 users with a Wibu dongle, your existing dongle can be used
with 712d Model 11. If 12d Model 11 is already running on your computer, please uninstall it
before installing a new version of 712d Model 11.

For existing 712d Model 9 and 10 users with a Hardlock dongle, your existing dongle can NOT be
used with 712d Model 11. Please contact your 72d Model 11 Reseller to obtain a new dongle.

The notes and video for a new install of the Release version of 12d Model 11 are on the
12d Model 11 Installation DVD or can be downloaded from the 12d web site www. 12d.com
under the Updates area.

Installing the Practise Version:
IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11
To install a Practise version of 12d Model 11, all that is needed is:
one 12d Model 11 Installation DVD
or 12d Model 11 Practise downloaded from www.12d.com

The Practise version must be Registered with 712D Solutions once it is installed on a computer. A
new Registration is required for each computer that the Practise version is run on.

The notes and video for installing the practise version of 12d Model 11 are on the 72d Model 11
Installation DVD or can be downloaded from the 12d web site www. 12d.com under the 712d
Model 11 Practise area.
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Chapter 2 Before You Begin the Training

2.1

2.2

2.3

Before You Begin the Training

Installing the Training Files

If you have installed Training from the /2d Model Installation DVD, then the Training folder will have
been automatically created for you but where the files reside on the disk depends on whether you installed
the Release version or the Practise version of 12d Model.

The Training manual dialogue assumes that the working folder (i.e. shortcut) of your 72d Model 11 or
12d Model 11 Practise icon is set to

¢:\12d\11.00 for the Release version of 12d Model
and
¢:\12 Model 11 Practise for the Practise version of 12d Model

The training files can be place in any sub-folder on your hard disk but for convenience in this manual, it is
assumed that the training files are installed in

c:\12d\11.00\Training
Subfolders

c:\12d\11.00\Training\design

c:\12d\11.00\Training\survey

have been created and they contain all the required material needed for the Getting Started for Design and
Getting Started for Surveying manuals.

Some of the material is common to both manuals and these files are in the folder

c:\12d\11.00\Training\design

12d Icons on your Desktop

It is recommended that you use the 72d Model 11 icon for the Release version or 12d Model 11 Practise
icon for the Practise version whilst initially working with this training manual. The reason for this is that
the icon points directly to the folder that containing the Training folder.

Using the Practise Version
IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11
Remember that the Practise version of 12d Model is limited to a maximum of 5,000 points.

Following the procedures as stated in the Training Manual may create projects with more than 5,000
points. Where appropriate, the text will suggest how to vary the input for each instruction so that the
example feature can be completed within the limits of the 72d Model Practise version.
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2.4

2.5

Overview of 12d File and Folder Structures

Before you begin using 12d, it is useful to understand how 12d uses the file and folder structure under
Windows.

12d recognises long filenames up to 256 characters so you are not limited to the old DOS convention of 8.3
filenames.

The 12d software and its support files are installed on your hard disk, the program itself is installed into the
folder c:\Program Files\12d or c:\Program Files (x86)\12d, and various subfolders below. The training
data and user areas, are installed into the folder c:\12d\11.00 and subfolders below.

When the software was installed, the 72d Model 11 program icon is setup to point to the folder
c:\12d\11.00.

The files required for the Getting Started for Design and Getting Started for Surveying courses have been
set up in a folder c:\12d\11.00\Training.

As each 12d Model project you work on will have different files, it is strongly recommended that you
keep each project in a separate subfolder. This can be anywhere on your hard disk or network. For
convenience, you may prefer to keep them all under one major folder e.g. c:\12djobs.

In the general case for production work however, if you were about to start work on a new project by the
name ‘Highway’, you would like it to be in a new folder under say 12djobs i.e. c:\12djobs\Highway. This
is simply done from within 72d Model where a folder of the same name as the project is automatically
created with the project inside it.

Either numeric or alpha characters and spaces can be used in 12d Model project names so you may prefer
to use your job name as the project name. Also 12d project names are nof case sensitive so ‘Highway’ is
seen as the same name as ‘highway’.

Why Keep Projects in Separate Folders

12d can have more than one project within the one Windows folder. For example, projects under
‘Highway’ might be ‘Stage 1’ and ‘Stage 2’ or ‘Fred’ and ‘Bill’. Each project has its own data and
configuration setup which controls the number of views, which models are on display etc.

However although most internal 12d project files are kept separate another projects internal files, all input
and output files, mtffiles, chains, plots and reports go into the folder containing the project and are not
held inside the project itself. Hence to prevent projects interfering with each other, it is best to create a
separate folder and create each project in its own folder.

For example, if the Highway project has two stages, create the project Stage 1 in the folder Highway\Stage
1 and the project Stage 2 in the folder Highway\Stage 2

Once inside 12d, from within any one project, it is possible to import any or all data from another project
so there is some flexibility on a major job to move/copy survey or design data between stages if staging is
used and then have multiple users perform parallel development. Model and tin sharing could later be used
to subsequently assemble staged project data at the completion of a major job. Within any one project,
model names must be unique so some planning is necessary if parallel development streams are
subsequently to be reassembled. Models can be renamed at any time. Models are discussed in See Chapter
4.11 (on page 55).

Provided no 12d user is currently accessing a particular project, the project (and the folder containing it)
can be copied, renamed, moved and deleted from within 712d Model.

WARNING - information inside the project itself should not be manipulated except from within
12d Model since this may corrupt the project and data could be lost. For example, model names can only
be renamed from within 72d Model.

If you need to manually place any files on disk for a project (e.g. survey files from a total station or CAD
files to get data into 72d Model, it is recommended that you place them in the folder containing the
project. that way all the data and the project are in the one folder.
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2.6

File Backup Procedures

To ensure that you can retrieve any job or project at any time from backup procedures, it is important that
a complete ‘set’ of files is taken whenever backup is created. To backup the files associated with the
‘Highway’, you would typically backup all files and sub-folders in and below

c:\12djobs\Highway

There are configuration files used that may be used in the Highway job, that are supplied by 12d Solutions
and are automatically installed from the 72d Model Installation DVD. These files are in

c:\Program Files\12d\12dmodel\11.00\set_ups
c:\Program Files\12d\12dmodel\11.00\library

or when 32-bit 72d Model has been installed on 64-bit Window,

c:\Program Files (x86)\12d\12dmodel\11.00\set_ups
c:\Program Files (x86) \12d\12dmodel\11.00\library

There are other user configurable files that 12d may use and require to fully recreate all steps of a project.
They are not supplied on the 12d Model Installation DVD. These files are typically in

c:\12d\11.00\user

c:\12d\11.00\user _lib
These folders may contain files that have been configured specifically for your site e.g. your corporate
standard mapping, template and plot parameter files, your particular Total Station survey macros and any
user defined macros etc. In general, such files are not project specific, however because these files are user

configurable they may be changed at any time and hence particular project specific versions of them may
be needed as part of the complete file set of a project.

In the above case, the folders shown are for 72d Model 11. As implied, the files in these folders will never
be changed automatically by the installation process when you reinstall a later version of 12d.

The above paths are indicative only. It is possible that folders have been setup at different places for your
site. For more information on exactly where all library and user folders are located, refer to the section
43.1 Folder Structure Installed by 12d Model in the 12d Model Reference Manual and 12d Model
Context Sensitive Help, and for information on the environment variables

USER 4D

USER LIB 4D

SET UPS 4D

LIB 4D

that control where the various files are, see 8.6.3 env.4d and 43.4 Environment Variables in the 12d
Model Reference Manual and 12d Model Context Sensitive Help






12d Model Help

Position of option on menu:

Help =>12d Model

All the information in the 72d Model Reference manual is also available as electronic Help
accessed from within 72d Model (also know as the 12d Model Context Sensitive Help).

The entire 12d Model Help manual can be accessed by selecting 72d Model on the Help menu
item on the main 72d Model menu.

Help

&l

12d Model

) 12d Model help

12d Macro Manual

12d on the Web
About 12d Model
Email info to 12d

Dongles

Check for updates
Systern Information

Microsoft 7

» |links to web site www.12d.com.

dongle testing panel

4

12d macro programming language help

12d Model modules authorized, dongle number
email details of your 12d Model to 12d Solutions

check for newer versions of 12d Model
brings up Microsoft’s System Information panel
For Windows 7 links to the WinHIp32.exe

Clicking on 12d Model brings up Help Topics: 12d Model Reference

Help Topics: 12d Model REference

Pl X

Contents |index | Find |

Click a book, and then click Open. Or click another tab, such as Index.

-4 120 Model Reference kanual
@ 1 Preface
@ 2 Inztallation of 12d Model 11 Releaze Yerzion
@ 3 Inztallation of 12d Model 10 Practice Yerzion
@ 4T oal: and Concepts

@ 5 Starting Up

@ 6 12d Model Help

@ 7 Menus on Wiews

@ 3 Project

@ 9 Fie

@ 10 aDAC

@ 11 Edi

@ 12 View

@ 12 Models
@ 14 Stings

m

Open |

Prirt ... Cancel

L

The panel Help Topics: 12d is actually using Microsoft’'s WinHIp system and it allows you to look
at the overall structure of the 12d Model Help and access any part of it. More information on


http://www.12d.com

12d Model

using the tabs Contents, Index and Find will follow in the next section.

Alternatively, individual topics for a panel or menu can be invoked by pressing the F1 key
whenever the focus is on the menu or panel, or by clicking on the Help button on any 72d Model
panel (see [F1 Key). This is the context sensitive nature of the 12d Model Help.

For some options, there is also additional help files and videos. This is denoted by a * after Help
on the Help button. That is Help* (see Extra Help).

It is also possible to have a Help button and F1 key available for 72d Model PLs (macro)
programs written by 12d Solutions or by Users. Please see the 12d Model Programming
Language manual for more information on this feature.

Note: The 12d Model Reference manual is available in pdf on the 72d Model installation DVD,
or on the 12d web site www.12d.com.

More information on the Help system is given in the sections:

_Contents

Index

_Find

Panel Help Button
F1 Key
Navigating in Help
Extra Help
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Contents

The Contents tab allows you to look at the overall structure of the 12d Model Help and access
any part of it.

Help Topics: 12d Model REference @I&J

Contents | index | Find |

Click a boalk, and then click Open. Or click another tab, such as Index.

3120 Model Reference Manual
@ 1 Preface
@ 2 Inztallation of 12d Model 11 Releasze Werzion
@ 3 Inzstallation of 12d Model 10 Practice Werzion
@ 4T oolz and Concepts

@ B Starting Up

@ £ 12d Model Help

@ T Menuz on Views

@ 3 Project

@ 3 Fie

@ 10 ADAC

@ 11 Edi

@ 12 View

@ 12 Models
@ 14 Stings 1N

Open | Print ... Cancel

e, A

Warning - only fopics in the Contents can be viewed in Help so any folders in Contents folders
must be expanded until topics are displayed. Topics can be easily identified because they have a
question mark beside them indicating that Help is available and can be viewed.

m

For example, double clicking on Tools and Concepts expands the next level of Tools and
Contents.
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Help Topics: 12d

Contents |index | Find |

Click a topic, and then click Display. Or click another tab, such as Index.

|:L’,1] 3 Tool: and Concepts »
@ The Mouse

2 The Keybnarcl‘\
topics are identified

bya?

folders must be expanded
to see the fopics

Picking Strings

#N € and Ch HE Typed Input Box
Tentative Typed Inputs

Picking Wertex [ds [Point Mumbersz)
Shaps

Lo g o) [0 ] [-9) [2) e

Ewprezsions in Panel Figldz

Special Panel Fizlds

@ Meazures
@ Texst Units "

Dizplay | Prirt ... Cancel

and topics are The Mouse, The Keyboard etc.

Double clicking on the topic Picking Strings will then display the topic.
The Contents then disappear leaving Help open at the selected topic.

File Edit Bookmark Options Help

anlents| 1nde:¢| | Print | 4 | » |

Picking Strings
In many 12d Model options, the useris required to "pick” the stringto be used inthe &
option, orto get information about a string.

After any option requiring a pick is selected, a message regarding the function of the
mouse buttons is written to the screen message area.
<option> [picks][fasf][menu]
There are two picking method available in 12d Model:
(@) fast pick where the pick and the accept occur as one operation
and
b) tentative picks with a separate pick and accept mechanism

'fast pick' will documented first followed by the tentative pick! (pick and accepf)
method.

Fast Pick

Totast pick a string, simply mowve the cursar near the string and click MB or type
<enter>. The nearest string to the cursor satistying the snap conditions is selected. hd
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Double clicking on Contents on the top of the Help will bring the Contents listing back up.

Continue to _Index or return to 3 12d Model Help.

Index
The Index tab searches through all entries in the Index of the Help.

As the first few characters of the required entry are typed in, the matching index entries are
displayed.

Help Topics: 12d

Contents  Index ]Find ]

1 Type the first few letters of the word you're looking for.

[t

2 Click the index entry you want, and then click Display.

three state tick box Y

three states
tick, marks
tick. mark s
tadpoles
TICK_DRa&W_CROSS_4D
ticks
uzer symboals
tif
tiff
time_format
i
tin analysiz
tin aspect
tin azpect inguire
tin boundary b

Display | Cancel

Double clicking on the displayed entries will go to the topic in the Help containing the selected
index entry. If more than one topic includes the index entry, then the list of topics is displayed.

If the index has sub-indices, they can be searched by first typing in the main index followed by a
comma, then a space and the first few characters of the sub-index.

Continue to _Find or return to 3 12d Model Help.
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Find
The most powerful searching method for the Help system is Find.
Simply click on the Find tab to search for words or phrases that may be contained in a Help topic.

If Find is being invoked for the first time, the Find Setup Wizard runs to create an index of every
word in the Help.

Find enables you to search for specific words and
phrases in help topics, instead of searching for
information by categony.

Before you can use Find, Windows must first create a list
(or database), which cortains every word from your help
fileis).

To create this list now click Mext.

* Minimize database size fecommended)
" Maximize search capabilties

" Customize search capabilties

e || e cse|

From then on, selecting the Find tab goes straight to the Find screen.
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Help Topics: 12d

Currtents] Indexx  Find

1 Type the word|s) you want to find

| j Clear
2 Select some matching words to namow your search Options...

3 Click a topic. then click Display

ACAD Plot b ap File
Add
Add
Add

&dd j

|'I?53 Topics Found | | All words, Begin, Auto, Pause |

Diigplay | | Cancel |

Continue to _Panel Help Button or return to 3 12d Model Help.
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Panel Help Button

Every panel has a Help button which when selected goes to the topic describing that panel.

K @ Colour Height Range for Tin EI =] \

Tin [

Range file |

Clean faces model beforehand

| 4
N /

The default 72d Model Help is all in one Winhlip file but a method for displaying additional help
information exists so 12d Solutions, 12d Distributors and Users can supply additional (extra)
Help information.

Help button to go
directly to the Help
topic for the panel.

aNaEE]

If there is extra help available for an option, then Help* will appear instead of Help on the panel
button.

an N

If there is any extra help documentation for the panel,
the Help button will be replaced with a Help *
k The * indicates that there is extra help available. J

Information on how the extra help is set up is given in the section Extra Help.
Continue to _F1 Key or return to 3 12d Model Help.
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F1 Key

Another method of invoking Help is by using the F1 key as follows:

when a menu or panel is on the screen and has focus (the menu or panel title area will be

highlighted), or the cursor is over an item on a toolbar, pressing F1 will bring up the help for that
menu, panel or toolbar item.

Warning - some of the items on the Strings menu automatically start up a string select and

change the focus from the panel to a View. This means that pressing F1 will bring up the Help for
the View and not the Help for the panel.

To get Help for such a panel, click on the panel to bring the focus back to the panel before
pressing F1. The top of the panel will highlight showing that it has focus.

Continue to Navigating in Help or return to 3 12d Model Help.

F1 Ke Page 25
= = <7 X
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Navigating in Help
Once at a topic in the Help, the << and >> buttons at the top of the Help topic will go to the
previous and next Help topics respectively.

Individual Help topics can be printed by clicking Print at the top of the Help page.

print the )
current topic go back one topic g0 to next topic

File Edit Bookmark Optionsg Help
Enntents| Index | | Erint | £4 | B |
Drape
.S
Position of option on menu:  Tins =>Drape =>Drape
The drape operation is simply sectioning along a string.
Draping is a wery useful method for attaching a z-value for strings defined in plan only.
For example, cadastral infarmation often has anly (x4 co-ordinates. The drape
operation could be used to apply 2+values to the cadastral information, for example,
z~values fram the natural surface tin. The draped cadastral information would then sit an
the natural surface and could be used effectively in perspective views as well as plan
views 1o delineate properties etc.
Instead of simply producing a section along a string. drape can also be usedio
produce a face for every segment of the string by draping the segment anta the tin and
forming a face by perpendicularly connecting the end points of the segment and the
draped segment. For example, if the strings represented the tops of buildings. the
created faces would be the sides of the buildings down to the terrain.
The data to be draped can be selected in three ways - an individual string can be
selected and draped. all the strings in a model can be draped. or all the strings ina
view can be draped.
On selecting drape, the drape panelis displayed.
W

Because it is difficult to print large sections of Microsoft's Help system, a PDF file of the entire
12d Model Reference Manual has been created and can be used to print out large sections of
the manual.

The 12d Model Reference Manual PDF file is on the 12d Model 11 Installation DVD in the folder
Documentation\Reference Manual.

Continue to _Extra Help or return to 3 12d Model Help.
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Extra Help

The default context sensitive 72d Model Help is all in one help file supplied by 72d Solutions but
a method for displaying additional help information exists so 12d Solutions, 12d Distributors and
Users can supply additional (extra) Help information. This extra information can also be supplied
by 712d Model PLs (macros) written by 12d Solutions or Users.

How to Set Up Extra Help

Any extra help for an inbuilt panel (that is, one not created by a macro) is placed in a folder with

“w

the same name as the dump name for the panel without the ending after the “.” (to get the dump
name, see Dumping a Panel, Creating a Screen Layout File or Default File in 12d Help or the
12d Model Reference manual).

For macros, created by Users or 12d Solutions, there can only be the same Help button for any
panels created by the macro and the extra help for the macro is placed in a folder with the same
name as the macro without the ending "4do" after the “.” and with any blanks or non
alphanumeric characters replaced by a underscore ("_"). For example, the extra help files for the
macro called "testing help (3) system.4do" go in a folder called testing_help_ 3 system. Note
there is an underscore for the blanks and the "(" and ")" in the macro name.

The extra help files for an in built panel or macro can have any name and can be a pdf, wmy, avi,
txt efc.

For example, for the panel Project Tree brought up by selecting Project =>Tree, the extra
documentation would be in a folder called Project_Tree.

The folder of extra help for a panel, is then placed in any one of the three places:
(a) inthe Help folder in the 712d Model installation area: For example, for version 11
c:\Program Files\12d\12d Model\11.00\Help
c:\Program Files (x86)\12d\12d Model\11.00\Help

(b) in a folder called Help inside the Set_ups folder in the 72d Model installation area. For example
c:\Program Files\12d\12d Model\11.00\Set_ups\Help
c:\Program Files (x86)\12d\12d Model\11.00\Set_ups\Help

or

(¢c) in a folder called Help inside the User folder in the 12d User area. For example
c:\12d\11.00\User\Help

For an inbuilt panel an macro, each of these areas is searched and if any extra help is found, it is
listed with the full path to each extra help file.

If there is any extra help for a inbuilt panel or macro, the Help button on the panel will be replaced
with a Help * button. The * indicates that there is extra help available.

When you click on the Help * button, you will get a list of all the extra help files for that inbuilt
panel or macro with the full pathname to the extra help. Clicking on the file name will bring up that
extra help.

For example,
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-

B Project Tree = 2

= Project "Stagel”

7- Models

-Tins

-Templates
-Functions

Views

-Mame mappings

i Plotters

-Survey data collectors

* indicates extra help

is available
-Colours

-Linestyles

Symbols

- Textstyles

- Textstyle data favorites
-Sheet sizes

Finish y

L

# ' Help Informaticn for El;lﬂ

standard 12d Model Help

@ ChProgram Files\12d\12dmodel@.00helphl2d.hlp —

C\126\9.00\user\help\Project_Tree\CAD_TEXT_SYMBOLSwmy  ~g——————— cXtra Help in User\Help
Ch12d\9.000Nuser\helph\Project_Tree\User_supplied_Porject_treewmy /

Z:\Program Files'\12d\12dmodel.00help'\Project_Tree\ CAD_LINES_POLYS.wmv

ChProgram Files\12d\12dmodel3.00helpiProject_Tree\ CAD_TEXT_SYMBOLS.wmv extra Help in Help

C:\Program Files\12d\12dmodel\9.00\help\Project_Tree\EASY_FIND.wmv

C\Program Files\12d\12dmodel9.00\help\Project_Tree\Tag_Treewmyv

Ch\Program Files\l12d\12dmodeld.00set_ups\helpiProject_Tree\CAD_TEXT_SYMBOLS.wm

ChProgram Files\12d\12dmodel9.000set_upsihelphProject_Tree\Help_in_Set_ups_Help.wmv

@ [ @ (E E E (E E (E

C\Program Files\12d\12dmodel\8.00Nset_upstihelp'Project_Tree\Tag_Treewmy o — extra Help in Set_Ups\Help

Finish

Users Own Extra Help Files

Note that users can also have their own extra help files and the files are simply placed in the
correctly named folder under User\Help.
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4 Basic Operations

4.1 The Mouse

12d works best with a three button mouse (preferable a wheel mouse). 12d will work with a (Microsoft)
two button mouse but the lack of the middle button means that you have extra mouse clicks to perform.

All 12d Documentation uses the following notation for mouse functions.

LB = left mouse button - used for picking screen items, menus etc.
MB = middle mouse button - used to accept the highlighted item
RB = right mouse button - used to pop up a list of alternatives

VB

The left button is the ‘Select’ button — typically used to select graphic items or text. The middle button (or
wheel) is the ‘Accept’ button, used to confirm a selection. The right button is the ‘Menu’ button. It is
context sensitive and often displays a list of alternatives available at that instant.

With a two button mouse you achieve this functionality by clicking the right mouse button to pop up the
‘Pick Operations’ menu and then clicking LB on Accept or by simply pressing the <Enter> key

The term ‘clicking’ a button means pressing it down and releasing it again. The position of the mouse is
taken at the time the button is released. In this tutorial manual, items that are selected by a mouse click are
in bold.

As we get more experienced, we will also introduce the term ‘dragging’ the mouse for some advanced 12d
operations. We do this by pressing down a button and whilst still holding it down, moving the mouse so
that the screen cursor moves. Once a definite distance has been achieved, just a millimetre or two is
sufficient, release the button. 12d notes the vector you defined and can use this information to detect the
direction in which you dragged the mouse.

Finally, we will use the term ‘double clicking’. This is where we press the button twice in quick
succession. This is often used for short-cuts.
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4.2 Starting Up - The Project Selection panel

If you installed 12d Model from the 12d Model Installation DVD, then a 12d Model 11 icon will have been

created on your desktop. The 712d Model front screen will then appear.

Click LB on New button at the bottom of the panel to bring up the Open/Create panel with the New tab

selected.

7@ 12d Model 11.0C1a RC4 (nt.x86) - Open / Create (o= |[=

-Open MNew I

Folder name  [C:\12¢411.00\Training\design\getting started basic
Project name |STAGE1

Create working jilder?
CA12d\11.000Tralning'\design\getting started basic\STAGE 1\STAGE_1.project

Description

7
/By clicking the LB on the folder icon, navigate to the folder
C:\12d\11.00\Training\design\getting started basic

Type in STAGE [ in to Project name

Leaving the Create working folder? check box ticked will create a new
folder of the same name (the Working Folder) and then create the
Qroject folder inside the Working Folder.

Advanced

| Folder <C:\12d\11.00\Training\design\getting started basic» exists

| MNew | [Recent Pru:njer_ts| | MNodes | | Quit | | Help

Click LB on the folder icon at the end of the Folder name field and browse to:
C:\12d\11.0\Training\design\getting started basic.

Type STAGE 1 into the Project name field and tick on Create working folder.

Then click LB on the New button.

Then a folder with the same name as Project name is created (called the Working Folder), and a new

project called Project name is created inside the Working Folder.

Note

It is important to select names that are meaningful to your job as you may have several projects associated

with a large or complex job.

Once a project is selected, the graphics screen will display, with the Setup Project Details panel open. Fill

in the panel with the relevant required details

Page 30
e = == > = 7 —Z
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:ﬁ' 12d Model 5M 11.0C1a RC4 (ntx86) - Project "C:\12d\11.00\Training\designigetting started basic\STAGE 1\STAGE1" -
Project File Edit View Models Strings Cad  Tins  Survey Design Drafting Plot  Report  Utilities

| @Hbase Ellcyan EH @ll @H L
RHEMNEUEHHNDBEDEEMEM FHEADO GdEae D

+, :ﬁ Setup Project Details o || B ER
‘()(:4 Property Value =
< .| Project Number 12345 B -
O‘ Drawing Number labd
[ Site Address 1 BROWN ROAD abd
R -
Ll -

s |~ —
f’ 4 Job Title e
'y Client Name RR DEVELOPMENTS abd
\f\, Customer Name ]
i) ger Narme e
=, Surveyor Mame NEB abq
D, Designer Mame PD labd
4 Checker Name ]

L - 5
5 -
] Click on Set to save the b
<, details and Finish to BH .
2 | [Drawing Number close the panel.

x'. MNext Drawing number
o \
m, | |
2, [ set | [Load| Finish
.

/ RULES FOR ENTERING DATA INTO PANELS \

Important: The cursor must be locked into the appropriate data entry field when typing data into a 12d panel.
Often this will happen automatically. If you cannot see the cursor flashing in the data field in which you want
to enter data, use the mouse to position the cursor anywhere over the data field and click the LB to lock the
cursor into the field before typing any data. Terminate the data entry sequence by pressing the <Enter> key.

If you make a mistake, you can always select the erroneous entry by double clicking over it with the mouse
LB. The text should then appear highlighted. As you retype it, the old entry is deleted.

When filling in data in any 12d panel, it is not essential to terminate the entry of data by pressing <Enter>. You
can use the <Tab> and <BackTab> keys to move from field to field. You can also use the mouse to move
between fields.

If you do press <Enter> to terminate the entry of data into a field, 12d will immediately validate the data in that
Qeld and if required, write an error message. /
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4.3 The Initial Screen Layout

The default background colour for a view is black because black is the best colour for reducing eye strain
and for distinguishing colours displayed in a view.

To make the Getting Started manuals easier to print on in-house printers, many of our illustrations have a
white background colour.

The names we use for the various parts of the screen are shown on the diagram below. Your screen may not
appear exactly as shown as most components on the screen can be moved or turned off by user
configuration options, or you have a different screen resolution.

/DI'Op down Main Menu bar CAD control bar Screen maximise, minimise \

and delete buttons
‘Tﬁ‘ 12d Modek\ﬂa RC4 (ntx86) - Project "C:\12d\ll.OO\Tra\mr:?{gn\gaﬁmg started basic\STAGE 1\STAGE1" - Client "12D Solutions - Lee" o |[@2] &)

Project File Edit View Meodels Strings Cad Tins Surfey Design  Drafting Plot Report Utilities User Window Help

[ [] [bese [ [=en |l EIE = =l el @™ M (A & I
@Iﬂ@lﬂlﬂlﬂl@@[f FAEZOO GElasab@ v P oHERsaaaBE A !

Plan SURVEY
Plan DESIGN

Snaps tool bar

Auto

Recalc =
»
Edit func »

Edit data

B sectionLs View type and name U
4 Section X5 Recalc all

7 Perspeg Opencl 30 View title area — == toer?

T — Edit chain »

[ Plan1 > | = B Run chain ¥

(=R ENEAISIEIEIE)

View maximise, minimise
CAD tool bar and delete buttons

m

View button area
Recalc panel

Screen message box

Output Window View coordinates box

view workbook tabs

Iz 4

CAP||NUM)|[SCRL]

/

Note that the View in the image with the white background has a title and it is Plan 1. This says that it is a
Plan view with the name 1. The View names must be unique.

Qutput Window Background tasks

/errssosmeas[arnsro@BLEnINONAS

Each View can be Minimised, Maximised or Closed.

The Plan View 1 can be maximised by clicking LB on the square button in the top right hand corner of the
view menu.
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Minimise / Maximise
| "

i@

Close

This then takes up the entire viewing area. Alternatively, you can double click LB on the plan view title
area to maximise the view (The blue area to the left of the View Minimise button).

To reduce it back to its original size you can hit the restore icon.

o D S
- &8 X

Restore icon

The Recalc panel is used to quickly rerun design calculations and will be discussed later. We will move the
panel down to the bottom left of the screen by holding LB down over the menu title are Recalc and then
moving the cursor to bottom left hand corner of the screen and then releasing LB wen the Recalc menu is

where we want it to be.

The view should then look as shown below.

7 12d Model 5M 11.0C1a RCA (nt.486) - Project "CAL2d\11 D0\ Training\design\getting started basic\STAGE 1\STAGE1" - [Plan1] [=&@]=]
Project File Edit View Models Strings Cad Tins Survey Design Drafting Plot Report Utilities User Window Help 8%
| [0 =se [=[oen | ] E Ela:@n 1 U

e2]r) DRIDERAEM EEADO GaBeesca [ [ cEEEs@ssEE 20 L
EE@

Recale (B
Auto >
Edit func »
Edit data
Recalc 3

SARMBAFOBASEARINDONAF

Recalc all
User 3

Edit chain
Run chain

& survey | R pesicn | ELs s |0 B 4 b

CAP|NUM||SCRL|

B FHEFONEEES

. [ Output Window Background tasks
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4.4 How to Find Your Way Around 12d Menus

12d options are run by a number of methods. The Drop Down Main Menu system from the bar running
across the top of the screen is the main way we access 12d programs.

Project File Edit View Models 5Strings Cad  Tins  Survey Design  Drafting Plot Report  Utilities  User Window Help

In addition to the Drop Down Main menu system, there is a floating 72d Model menu that can be pinned.
This is found at Projects=>12d Model menu.

Project | File Edit View 12d Model (B
|= [ Projects ] Projects »
[E Recent projects b File -
Open Edit 3
& T View 3
El EwW
Models ]
x:a 12d Synergy b Strings b
7 Check base points Cad »
O, Detai » :
’ e click on 12d Model Menu s g
[ Management » . .
brings up a pinable menu
- Restart Survey +
| Save Design r
& Tree Drafting  »
Plots ]
7 Utilities » reoorte b
{j: Delete E-FI-D- :
o Utilities 2
m | 12dModel 8 User 4
- User » Help . d
) Save  Exit
45, |12d Model Menu
&.J Exait
A b

12d has a unique graphical user interface (GUI) involving hundreds of menu items. These are logically
grouped by function in a Walk Right and Tear Off menu system.

Walk Right menus are menus designed such that if you move the mouse cursor right on a menu item
containing a right arrow, a further menu will pop up, usually on the right hand side.

Tear Off menus means that a menu can be torn off it’s parent menu and relocated elsewhere on the screen
for clarity of operation. In general, it is possible to have multiple copies of the same Tear Off menu on the
screen at one time.

Notice that the order of items left-to-right on the Drop Down Main Menu bar is the same as the top-to-
bottom order on the Walk Right 72d Model menu. You can select menu items from either one of these
sources — the end result is the same.

The Drop Down menu bar conforms to normal Microsoft standards so it can be dragged and placed at any
of the four sides of your desktop. It is probably most usable left at the top of your desktop.

The following comments apply to ALL menus. To move any menu around on the screen, you drag it by
depressing the LB in the View Title area at the top of the menu, anywhere other than over the X in the top
right hand corner. With the button still depressed, move the mouse to the desired location and release the
button to repin the menu. The same procedures also apply when moving panels and views. When doing
this just make sure that LB is clicked in the general heading area and not on a View button.
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To ease the learning and usage process, a menu description system has been adopted in this manual that
describes where to look to achieve a specific function. For instance, to import an AutoCAD DXF file of
point and line data into 12d, you Walk Right on the 12d Model menu or from the Drop Down Main Menu
bar, through two submenus and select DWG/DXEF. This instruction is documented as...

File =>Data Input =>DWG/DXF/DXB

To display submenus from the Walk Right, you do not need to use the mouse buttons. Simply position the
mouse cursor over the 72d Model menu and once File I/0 is highlighted, slide the mouse right over the
arrow and the File I/O menu will pop up. Slide further right on the Data input menu item and the Data Input
menu will pop up.

Your screen should appear as follows

12d Model &
Projects  »
File [
Edit y File/O =]
View ¥ Datainput W
Models  » Datacutput o Datalnput =)
Strings ¥ Layouts W 12d >
Cad W ADAC » 2dPDF
Tins ¥ Digitizer ¥ ArcView SHP

GIS N XYyZ 3
Survey o Label Map files § BCC Epson
Design ¥ Map files ¥ Civilcad
Drafting  # Rangefiles » DEM
Plots b Screen dump DGN 3
Reports ¥ Templates M DWG/DXF/DXB
Utilities  » Textstyleinput | FBX
User ¥ Edit file Genio
Help y User ¥ Geccomp
w Keays

Land¥ML F

MapInfo MID/MIF
OBJ

Point clouds 4
SDR Map

TOT

TP Setout

TP Stakeout strings
Old 4

Alternatively, you can use the Drop Down menu bar to get to the same point ...

To get to this same point using the pull down system, you need to click LB on [File] on the Drop Down
menu bar and then proceed as before on the walk rights as shown below.
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Project | File | Edit View Models Strings Cad  Tins  Sun
= [File YO ] _ lc}’a”=D|_
| Data input >| [ Data Input ] l
Data output * =
@ Layouts p » 1 '
2d PDF
ADAC | ArcView sHP
Digitizer * i .
Gl ’ BCC Epson
Label Map files * Civilcad
Map files * DEM
Range files * DGN .
Y DWG/DXF/DXE
Templates * Genio
Textstyle input Frren
Edit file Keays
User | LandxmL
Point clouds b
MapInfo MID/MIF
SDR Map
TOT
TP Setout
TP Stakeout strings
Old >
User 4

Regardless of which menu selection method you used, place the cursor over the words DWG/DXF/DXB
and click the left mouse button (LB) once. The Read DWG/DXF Data panel will appear.
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'B Read DWG/DXF Data E=R(=R =

File |

(S| mi[ey

Mull level value [-099

Default lineweight [0.25

Spline approximation |12

MNames [layer for name
Images ignore

Blocks |to symbols
Block attributes ignore

Only create visible symbols
Translate 3DFaces to Faces
Use12d Acad colour numbers
Create 2d/3d polys from ctrl points
Head to tail points/lines

Only load visible layers

Load paper space

Load xref files

moreEr o Eld

| Read | | Finish | | Help |

The panel is placed on the screen at the location
where the mouse cursor was when LB was clicked.

Once the panel is selected, the Walk Right menu system should collapse and be removed from the screen.
If you move and repin any of the menus however, they will not collapse automatically.

If a menu is in the way, you can move it as already described. Any menu can be removed by clicking LB

on the X button in the top right hand corner.

You would normally now start entering data into the panel. At this time, we will not proceed further with
this panel. Shut down the panel by clicking LB on the | x| in the top right hand corner or clicking LB on

Finish at the base of the panel.
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4.5 Toolbars and Controlbars

See

Chapter 4.5.1 CAD Toolbar and CAD Contolbar
Chapter 4.5.2 CAD Text Toolbar and Text Controlbar
Chapter 4.5.3 Symbol Controlbar

Chapter 4.5.4 Search Toolbar

Chapter 4.5.5 Snaps Toolbar

4.5.1 CAD Toolbar and CAD Contolbar

In 712d Model there are CAD options which are available under both the CAD menu and on the CAD
Toolbar on the left hand side of the 72d Model screen.

The CAD options create various elements using a number of methods. These options make use of Tool
bars and Control bars. Tool bars just have icons on them but Control bars have icons and also controls
such as a model box on them. The method groupings are shown on the toolbars (e.g. Points, Lines etc.).

The user can select an icon on the tool bar and a Flyout for all options of the grouping are displayed. This
can be done by selecting the appropriate group symbol by holding down the left mouse button on the icon.
This shows all the different options for that grouping in a flyout panel. Whilst still holding down the left
mouse button, the user can move along the flyout toolbar to the appropriate option.

-

:ilj 12d Model 5M 11.0C1a RC4 (nt.x86) - Project "C:A\12dV11.000Training'\design\getting started basic\STAGE I\STAGE1" - [Plan1]
Project File Edit View Models Strings Cad Tins  Survey Design Drafting Plot Report  Utilities User Window Help

| (1) [oose [ [oyen El H]E ElnE] S| &
EENEEEHDEIDENEM EEADD GygWaesca [

BN =RE N\

CAD Controlbar
~——( CAD toolbar

b

b

Y

N

N

b

b

b

N

[

[

Y

CAD String
flyout toolbar

QUPBL Ay AN LR ALY 0

Auto 3
Edit func »
Edit data

Recalc 3

N b

b

LA UEHSTANRONONX &

Recalc all

The elements created from the CAD options will have attributes as defined by the Cad Control Bar. This
control bar is placed on the top left hand side of the screen under the Main Menu control bar on the
creation of a project
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|ba§e |C}faﬂ Dl |1 E| @l @

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

I— @ name box

name of string. If a valid name already exists in names.4d, the [N] button can be used to bring up a
choice box of available names. On selection of a valid name, the rest of the values in the control bar
will be filled out. e.g. colour, linetype etc.

model box
Il:nase J

this field can be recognised by the model icon button on the right hand side of the field. The user can
select an existing model by selecting the model icon. If a new model is to be used, the user simply types
the model name into the field.

Eo—

base names.4d names

base existing models

colour box red standard 12d colours

this field can be recognised by the colour icon button on the right hand side of the field. The user can
select a 12d standard colour model by selecting the colour icon, typing in a a colour name of number,
or even typing in he RGB of a colour in the format rgh (red_integer,greeen_integer,blue_integer).

| b

this field allows a height or z value to be assigned to the created elements. If a valid value exists, this
value will be applied to the created element. This is regardless if the z value was specified in an XYZ
box.

height input Measures menu

If no value is specified, the level will be interpolated where possible. A value of null can be entered into
the height field as well so that created points will be given a null height value.

Il— == linetype box 1 valid linestyles

this field can be recognised by the linestyle icon button on the right hand side of the field. The user can
select a valid linestyle by selecting the linestyle icon

[ =

this field allows the user to type in a line weight for the cad item created

weight box

ZI tinablility box no, yes, points

yes

the Tinable field sets whether:

yes - the vertices and segments are tinable (used in triangulations)
no - not tinable (not used in triangulations)
points - only the vertices (points) are tinable.same as

button same as
i

the same as (or eye dropper) allows the user to select an existing element which will be used to define
all the cad control bar values.
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The CAD options are available from the CAD toolbar or from the CAD menu.

Cad | Tins  Survey |

[Cad]

Y

b

Dimensicn 3
Leader 3

Table 3

SR

5

Multipick
Point

[

I/I

CAD menu

Intersection

b

Line

N

Circle
Arc
CAD Toolbar Polvgen
Text
Symbol
Hole

Fill

[

N

9

Image
Medify
Vertex

b

[

Nlsd e DEHESTNANT

Segment

5

String
Edit
Delete
Acad

N

.S
b

3
3
3
3
3
3
3
3
3
3
3
3
3
3
3
3
3
3
3
3

Regression

When options are chosen from the CAD Toolbar, help messages are written to the Screen Message Box at
the bottom of the 72d Model screen.

Although there is no panel or menu involved with the CAD toolbar options, if the F1 key is pressed whilst
the cursor is over an item on a toolbar, the context sensitive help will be called.

Alternatively all the CAD options are documented under each of the walk-right menus of the C4AD menu.
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4.5.2 CAD Text Toolbar and Text Controlbar

The various Text options are:

BT @ME B

f C CAD =>Text menu )
( Text Controlbar }

(CAD Text Toolbar ) [ Cad Text]
L Edit
ape Create
Delete
b Label perp. offset
dlﬁi aE{ abe Commands ]

¥

Text can occur as a text string, on vertices of a 4d string, and on vertices and segments of a super string.
Each type of text has

(a) avertex (these are displayed when Vertices are toggled on in a plan view)

(b) ajustification point, a rotation

(c) an offset

(d) araise value.

The vertex and justification point only coincide if the offset and raise values are both zero.
All text on a 4d string must have the same height, colour, angle, offset and raise.

Each part of the text on a super string vertex segment can be independently modified depending on the
settings for the super string.

For text options, the created elements will have attributes as defined by the Text Control Bar. This control
bar is placed at the top right of the screen under the main menu control bar on the creation of a project

@ [T A

The fields and buttons used in this control bar have the following functions.
Field Description Type Defaults Pop-Up
ﬂ Textstyle data box

On pressing the button a list of available textdata with predefined names read from the
texstyle_names.4d file are displayed.

Page 41
e = > L7
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Select Textdata =

Arial1 centre -
Arial 2 centre
Catchment Label
Dimension 2.5
Dimension 3.5

Grid Text

1501 centre

150 2 centre

Label Easting

Label Morthing

Label Point Mo

SAlgn Data

SAlgn Header

SAlgn Title

Text 1.5mm

Text 10mm

Text 2.5mm

Text 3.5mm

Text 5.0mm

Text 7.0mm

Text Box1.5mm

Text Box 2.5mm

Text Box 3.5mm

Text Box 5.0mm

Text Box 7.0mm
Text Whiteout 1.5mm
Text Whiteout 2.5mm
Text Whiteout 3.5mm
Text Whiteout 5.0mm
Text Whiteout 7.0mm

m

| Select

[Edit]
[Sameas]
[Clear]

If you require a different textsyle, the user can edit the current settings by selecting the /Edit] button to
bring up the Textstyle Data panel. This allows for definition of textstyle, units, height offset raise etc.

:a: Textstyle Data EI &=l @

Favorites |

Text style [1

Text units |w0r|d
Height (u} |10
Offset (u) |c|

) (@[« i = (4]

[

Raize (u) |g Ihl-;l
Justify |b0ttom—leﬂ: IEI
Angle k]= z
Slant h‘ SE
X factor [L \El';l
Weight [ Izl
Underline | IEI
Strikecut | EI
Italic | EI
| =]
I
| Set | |Sameas| | Clear | | Finish | [ Help ]
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Il ﬂ textstyle box 1 available textstyles

the user can select an existing textstyle by selecting the textstyle icon or entering a value into the input
box to the left of the button.

IF .\ﬁi text height box 10

the user can measure a height by selecting the text height icon or entering a value into the input box to
the left of the button. The value units are defaulted to world units. This can be changed in the Textstyle
Data box
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4.5.3 Symbol Controlbar

The Symbol Controlbar is normally at the top right of the 72d Model screen.

Symbol Control toolbar ———— |

R P

Users can define their own symbols to draw at vertices of super strings. The definition of symbols are
stored in a file called symbols.4d.

The fields and buttons used in this control bar have the following functions.

Field Description

2

On pressing the Symbol data button a panel appears

Select Symbol Data

Type Defaults Pop-Up
Symbol data box
=] If you require a different

[Edit]
[Sameas]
[Clear]

symbol, the user can edit the
current settings by selecting the
[Edit] button to bring up the
Symbol Information panel
(shown below).

The current symbol can be

Symbol Information

selected from the Symbols list
and the colour, size and rotation
can be manually set

Favorites @

Symbel Select Choi

Size [ @ ) p
Rotation [3° i |2 12D LMARK

=12d
Offsetx o 23 12d Standards |
Offsety [0 N | [ 21 12d_Standards

J |5 12d_standards

(s (omem) (@

=) Alignment Styles
@ ) Cadastral

@ |5 Communications
®H = DTM

[ |2 Dimension

@ | Drainage

|3 Drainage BCC

[ [2) Earthworks

|2 Electricity

@ Frerney

[ Select

[Edit]
[Sameas]

Alternatively the size and rotation (anti clockwise) can be entered manually into the boxes in

the Control bar \ \

[Pvim @|5 ﬂhﬁ"ﬁi
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4.5.4 Search Toolbar

The Search bar is normally at the top right of the 72d Model screen.

)
-

| 1+

By simply typing text into the Search Bar, the option searches for matches of the typed text amongst the
full path names of all the options on the menus, and then lists the menu items and the position of the

menu that contains the menu item.

For example, typing in volu will bring up the list shown below.

2

|\rolu|

[

(R [0 g pr e
Balanced volumes (Design-»Volumes- > Exact)
Between heights (Design-»Velumes-» Exact)
Cut/fill text in poly (Design->Volumes)
empty (Design->Veolumes-»End Area->User) =
empty (Design->Volumes-»Exact-» User)
empty (Design->Velumes-»User)
Grid cell (Design-»Volumes)
Rernowval calcs (Design-=»Volumes- > Exact)
Sections to height (Design->Volumes->End Ar
Sections to sections (Design-»>Volurmes->End 4
Stockpile (Design->Volumes)
Storage calcs (Design-»Volumes-» Exact)
String tin to height (Design->Volurmes->End A
String tin to tin (Design->Veolumes-»End Area)
Tin to height (Design->Yolumes->End Area)
Tin to height (Design->Volurmes-» Exact)
Tin to height 2 (Design-»Velumes-» Exact)
Tin to ht curve (Design-»Velumes-» Exact)
Tin to sections (Design-=Volumes-»End Area) _
Tin to tin (Design->Yolumes->End Area)
Tin to tin (Design->Volumes-» Exact)
Tin to tin 2 (Design->Volumes-> Exact)
Tin to tin ht range (Design->Volumes)
Trimesh volume (Cad-=» Leader)

o

n

Typing volu in the Search Bar

List of matches for volu

in the full path to the name
of the option on a menu,
and the position in brackets
of the menu that contains
the text volu.

Clicking on any item
in the list brings up the
panel for the option

Double clicking on an item in the list brings up the panel for that item.

Note that case is ignored when searching for matches.

4.5.5 Snaps Toolbar

The Snaps Toolbar is normally at the top right hand corner of the 12d Model screen.

Snaps toolbar

el () (%) (6] (el (1) () (5) (@) (o) [ (&) (@) ()

Snaps are used when picking strings - see Chapter 7.4 *Snap Settings’.
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4.6 Status Bar

The Status Bar is an optional part of your desktop. It appears at the base of your desktop. The Status Bar
contains the Screen Message Box and the View Coordinates Box. It is strongly recommended that you
keep it turned ON.

If desired, the Status Bar may be turned OFF at any time.

From the View drop down menu bar, click LB on View, untick the Status Bar checkbox. To turn it back
ON, repeat the selection but this time tick the checkbox.

View | Models  Strings Cad T

Mew »

Toolbars

Status Bar |

| [views: !

4.7 Screen Message Box

The Screen Message Box contains messages that help you interact with the 12d menus. For instance, when
importing a DWG/DXF/DXB file as shown previously, you have to select a file name to read. Let us
investigate the messages 12d gives us to help us with this simple operation.

If the DWG/DXF/DXB Data panel is not already showing, select it again as shown previously.

Click in the ‘File’ name entry data field. Observe that the following response appears in the Screen
Message Box

“1

i
‘[
File [Caret] [Same as] [Menu] select a button
| Output Window |

You interpret this help message as follows. 12d is asking you to supply a file name. The three sets of
square brackets [ | correspond to your response via the three mouse buttons, LB, MB and RB.

The LB message ‘Caret’ indicates the position of the cursor if you want to type an answer using the
keyboard.

To type an answer, you must first make sure that the cursor is locked onto the field you wish to modify.
The cursor must appear as a flashing vertical bar before 12d will accept any data from the keyboard.

You can reposition the caret anywhere in the existing word by using the LB. You could then edit it by using
the <Backspace> key.

Alternatively you can use the <Delete> key to delete the character to the right of the cursor or the Arrow
keys to move within the word.

The <Home> and <End> keys take you to either end of the existing entry.

To delete the entire entry, double click anywhere in the text to highlight it. Then press the <Delete> key to
erase the entry, or just start typing to replace it.

The MB message ‘Same As’ indicates that you can point at any existing item on your desktop. This would
not normally be used for a file name.
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The RB message ‘Menu’ puts up a menu. At this time, no items are available. If another filename was
copied to the windows clipboard then the ‘Paste” would be highlighted.

Or finally, you can click LB on the folder icon to locate the required file

The Screen Message Box area changes dynamically with the position of the cursor on the screen so watch
it closely for helpful messages.

4.8 View Coordinates Box

Note the location of the View Coordinates Box at the bottom right of the desktop (the right hand side of the
Status Bar).

This box displays the X-Y coordinates of the cursor when in a Plan view and Chainage-Height-X
coordinate-Y coordinate when in a Section view.

1 [
x=-450 y=-139 CAP|| NUM|(SCRL
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4.9 The Output Window

The Output Window appears as a tab at the bottom left of the screen and flashes if there are any messages
that need to be reviewed.

Y. Bsurvev | oesion | LS |Bxs |Fe Bt

hl:- <Pick point to changes [picks][I[Menu] no selection made - try again x=-134 y=-205
A, | Qutput Windew Background tasks

By default the Output Window is in Auto-Hide mode and when you move your cursor over the Output
Window tab, the Output Window appears.

Output Window

. Loading Project
ot - OpenGL Vendor is <NVIDIA Corporation>
- OpenGL Renderer is {Quadro FX 1800M/PCle/SSE2>

an
==« |~ OpenGL Yersion is <3.3.0>
il:. 4 | m
A, | Qutput Windew Background tasks
Auto-Hide mode can be turned off by moving over the Output Window and pressing RB to bring up the
Output Window menu. Click on Auto-Hide to remove the tick and Auto-Hide is no longer on.
‘ Output Window
a. ----! Startup
Loading Project Floating
OpenGL Yendor is NVIDIA Cor, Docking
- penGL Renderer is <Quadro
= - OpenGL Version is <3.3.0> Tabbed Document
AN Auto Hide
A, | Output Window Background ta Hide
Clear Window
Copy to clipboard
Find
Filter 4
Convert to Window
Deselect current
Options 4
When Auto-Hide is turned off, the Output Window stays open permanently.
The Output Window menu includes the options:
Clear - clears the Output Window,
Copy to clipboard - copy any selected text in the Output Window to the Clipboard.
Hide - removes the Output Window.
Float - makes the Output Window a floating window that can be docked on any of the sides of the
12d Model screen.
Convert to window - turns the Output Window into a normal Window which then appears on your desktop.
It may be moved by clicking LB in the Output Window heading area, then dragging the cursor to another
part of your desktop and releasing the LB to pin it down.
Page 48
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When the Output Window is a normal Window or a floating window, then clicking on x at the top right of
the window will remove the Output Window.

The Output Window can be made taller or shorter by moving the bar at the top of the Output Window.

The Output Window can be turned off by Hide but also unticking the Output Window on the Window Main
Menu will remove the Output Window.

Once the Output Window is removed, the only way to turn it back on is to click on Output Window on the
Window Main Menu.
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4.10 Introduction to Views

There are three types available in 72d Model - Plan, Section, Perspective - and some subtypes. For
example Perspective and Perspective OpenGL are both Perspective Views and most Perspective operations
work identically on them.

It is possible to have multiple Plan, Section and Perspective views on the desktop at one time, each
showing different information. There is no limit to the number of views you may create.

Each View has a View type icon and a must have a unique name such as SURVEY or 2 etc. The names
can be any number of characters that must be either alphanumeric of spaces although for uniqueness upper
and lower alphabetic characters are considered to be the same thing. View names will automatically have
any leading or trailing spaces removed.

Plan DESIGM Section LS @ Perspective OpenGL 3D

BrE | EEERRE

The name appears in the View Title Area. This is the heading at the top of each view.

Just below the name is the View Button Area which contains the most common View buttons (i.c. a
subset of the complete list of view options). The View buttons appears horizontally after the view name.
The View Button Area appears automatically with each view as the view is created and each view type
has different view buttons that reflect it’s characteristics.

The View Name defaults to a number but can be over typed with any alphanumerics. The View Name
must be unique for the project.

For example, the View Buttons shown on a Plan view called Survey to map to ADAC are:

K 4] Plan Survey to map to ADAC View Title area \
@E@@@@@@@@@ View Button area
N
enu Fit Previous | Refresh | Clone
Add Pan
Remove Zoonslhrink Toggle Plot Properties

k Plan View Buttons /

Each view also has its own menu (the view menu) which can be brought up by clicking the LB on the view
button called Menu.

The View menus can also be brought up in another special way:

if you click the RB in the View Button Area or the View Title Area, you will also get the View menu to
pop up. Clicking RB again in the View Button Area or the View Title Area will remove the view menu.

So by using the RB, view menus can be accessed even if the Menu item is not visible in the View Button
Area.

The View menu contains options available for that particular view type. It is a superset of the buttons that
appear on the horizontal View Button Area. If the View is made very small or moved off the right hand
side of the desktop, the various buttons on the horizontal View Button Area will not be selectable as they
will not be visible. In such case, you have to use the RB in the View Button Area to get access to the
various View menu items.

Hence there are four menu systems in 12d, one for each view type (Plan, Section and Perspective) and an
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overall Main Menu.
Views may be created, resized, overlapped, moved, minimised, maximised and deleted.

When you create a new view, 12d will automatically supply it an ascending number for reference purposes
e.g. Section 2. This automatic name can be changed to any other unique view name.

To make Menus and Panels easy to see they will always be displayed on top of any views.

4.10.1 Basic View Operations

We will now practice some basic View operations
To create a new View, we can use the Views =>New or the Views =>Create option.

For example to create a new Plan view, select Views =>New =>Plan from the main menu to create a plan
view with the next view number.

Alternatively, you can use Views =>Create =>Plan View. Pick Create with the LB after first supplying a
View name or accepting the ‘number’ supplied by 12d as the View name.

r N

e

. . LY 2

@, Mew Plan View = || B | ER

View name | 2 | B |

| Create | | Finish | | Help |
7. 12d Model 5M 11.0€1b RC1 (nt86) - Project "C:A12d\11 00\ Training\design\getting started basic\STAGE 1\lee\lee” - Client "12D Solutions - Lee" =N iR
Project File Edit View Models Stings Cad Tins Suvey Design Drafting Plot Report Utilities User Window Help
I [ [ase Elcs Ll [FalT & = [Fllz): T DENZHE] I e =
DUEEENDEENEOEM FEALD G@#Ha® @ P »HAERwa@LfaBE PORARCOERUF 9y
;‘ [E3] Plan SURVEY o |[® | = ]
/‘ E [&2] Plan DESIGN = |[@ == W Recale (B
{Q. E & section LS = [=E[= 1 ?;:’mm :
Ef E A section X5 === W ;i‘:::“ R
Z. E Perspective OpenGL 3D = ] Recalc all
r; User v
' E [ Plan1 =
AR e e E e S e Edit chain »
SRR EEERERBR KNS O Run chain »
=)
£
D.
% la
&,
&
.,
Q.
£ 9
'y
m,
A,
=,
£,
a.
.,
ut,
Y,
i
a.
A,
= [E] B |Es o B [H2 av
Cap|[NUM]SCRL
Output Windo Background tasks

Important note: Each view name must be unique.
Once the View is on display, the following operations can be performed from the View Button Area.

To MOVE a View to a new location on your desktop, depress the LB in the View Title Area — the area on
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the top of the view showing the words Plan 2. Whilst you still have the mouse button depressed, drag the
mouse and you will see the View move. Pin the View again by releasing the LB.

To RESIZE a View, use the standard Windows features to change the size of the View. Place the cursor
near any corner or midside of the existing plan view and when the drag arrows popup, depress and hold
down the LB and drag the mouse to see the Window size change. Pin the new location of the corner by
releasing the LB.

A DISPLAY a view ON TOP of all the other views, click on any visible part of the view except in the
view drawing area (the black part of the view). Or by clicking on the View tab for that view in the View

tabs area at the bottom of the view display area.

DESIGN

current view on to

View tabs — > <urve BTG NIEE

To MAXIMISE a view, click on the Maximise button on the top right corner of the view. The view will
then take the entire view display area and no other view will be visible.

“fl. 12d Model SM11.0C1b RC 1 (ntx@6) - Project "C:\12d\11.00\Training\design\getting started basic\STAGE 1\lee\lee” - [Plan 2] = Eem |
Project File Edit View Models Strings Cad Tins Survey Design Drafting Plot Report  Utilities User Window Help -8 x
| @ o SleT— | — B 8 O@®Er @@

BEHMNEEHDEEREREM READLO GdEa®@ A oEE: R

Recalc 8
Auto 3
Edit func
Edit data
Recalc

o

SAN@F QBRSNS NKONON X >

o

Recalc all
User 3

Edit chain
Run chain »

o

B survey | B pesien |EFLs |Exs |E3o ; 4 b

CAP|[NUM||St

FOSEEES

Qutput Window Background tasks

If a view is maximised then clicking on any other View tab will bring that view to the TOP and hence it
will become the MAXIMISED view.

When a view is maximised, the three buttons that normally appear in the top right hand corner now appear
at the right hand side of the Main Menu area. Click on the Restore button to UNMAXIMISE the view.
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= | B e

/ buttons for the Maximised View

Window Help
T HiEr T M
DEHE: A

Restore (unmaximise) the view

To MINIMISE a view, click on the Minimise button on the top right corner of the view. The view will be
reduced to just an icon at the bottom of the View Display Area. To RESTORE the minimised view,
simply click on the Restore button on the view icon or click on the View tab of the minimised view.

Minimised VieWS\qa;
r

Clicking on its Restore button
or its View Tab will
Restore a minimised view

&, | Output Window Background tasks

To DELETE a View just click LB on the X button in the top right hand corner of the view.

A Yes-No Confirmation panel will then appear and select Yes to delete the view.

Plan2 ==

Click LB on Yes to confirm the action

[=] Plan 2
Bl =l

View "2" (B
Models  »
Settings »
Redraw

Fit
Previous

Zoom 3
Pan 4
Litilities  »
Clone

Properties
( Delete )

For the purpose of the tutorial, delete all the existing views EXCEPT Plan View 1 and maximise it to
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leave just large Plan View called 1 on the desktop.

In the following chapters we will create and demonstrate the use of all the different view types, and how

the various views are linked together.

4. 12d Model 5 11.0C1a RCA (nt(86) - Project "C:\12d\11,00\Training\desigr\getting started basic\STAGE 1\STAGE 1" - [Plan 1]
Project File Edit View Models Strings Ced Tins Survey Design Drafting Plot Report Utiities User Window Help

EIED | EEn =l = FHd:®@r M F

(E=3 EoE =3
-8 x

I .

PORVQIONF N R !

ARODON

ARfedg QEESEAND

E

0

Background tasks

HEDrEEHS

s

=2 For Help, press F1
&, [Output Window

(CAP| NUMY|SCRL]
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4.11 Introduction to Models

Models are a 12d concept and basically a model represents a repository for data. Each point or line that is
created or imported into 12d is put into a model. A model is similar to the layering concept AutoCAD, or
levels in Microstation

By adding models to, or removing models from, a view, it is possible to change the amount of information
that is displayed on a view. And it is possible to have different models on display in different views.

There is no limit to the number of models used in any one 12d Project.

If you want multiple copies of a certain line (i.e. string), it is possible to copy the line from one model to
another. The lines can then be displayed independently. If both models were on at once, the information
will appear as one line instead of two since the strings are coincident. It is possible to selectively snap to
and edit either line in such a case.

At any time, individual models can be Renamed, Duplicated, Cleaned (removes all points and lines but
the name of the model is retained) or Deleted.

By default, any deleted models will be stored in a Trash Bin as a back up. Models in the Trash Bin can be
restored at a later time. An example of this will be shown later in the manual.

It is possible to copy models between projects (See Models=>Utilities=>Copy Project Models) or to
Share Models from another project into you project so that you have the latest copy of the shared model.
These are more advanced features of 12d that we will not look at in this manual.
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4.12 Introduction to Strings

12d is very much a ‘strings’ rather than ‘points’ based system.
In it’s simplest form, a string can be just a single vertex (point), or a line between two ore more vertices.

A string may be made up of many vertices, joined by straight line segments or arc or transition segments.

/ @ denotes a string vertex neighbours of A \
previous vertex next vertex
vertex to vertex A to vertex A

index 2

S e e
/‘\'iv:éte?(x3 \ / last vertex

first vertex . N
string links or segments

vertex index 1
Vertices forming a string J

Strings vary in complexity from 2d (x,y and constant z value) to multidimensional, and an alignment string
that has both horizontal and vertical geometry independently defined.

In general, as well as x, y and z values, strings have properties such as string name, string type, string
colour, line style, and chainage.

Strings also have a point/line property that can be set such that they appear as disconnected points or
connected lines.

From a design point of view, strings are much more useful than points.
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4.13 Introduction to Panels

A panel is the means of supplying all the information required for a 12d Model option.

Once a panel appears on the desktop, you can use the mouse or the Tab and BackTab keys (denoted by
<Tab> and <Back tab>) to position the cursor over any data field. Remember, when typing data from the
keyboard, the cursor must be flashing in the data field for characters to be accepted.

When supplying data to a 12d panel, you do not need to terminate the entry of data into a field by pressing
the Enter key (<Enter>). For instance, you can use <Tab> and <BackTab> or the mouse to move to
another field after entering data. If you do press <Enter> to terminate the entry of data into a field, 12d will
immediately validate the data in that field and supply an error message if appropriate.

When validating supplied or previously entered data (i.e. where you do not need to change the data in a
field), it is not necessary to place the cursor in the data field. Just press <Enter> to pass through each field
in the panel in turn.

When typing data into a field, please observe that the Delete key (<Delete>) deletes a single character to
the right of the cursor. The Backspace key is also active. If you need to delete multiple characters, drag the
LB across the characters to highlight them (or double click over a word) and press <Delete> to delete them
or start typing to replace them.

In general, 12d has been setup so that data can be selected from lists rather than typed from the keyboard.
When entering data into a field, if there is a list of alternatives already known to 12d, pressing the LB on
the icon at the end of the field will display the list.

To practice this, bring up the Read xyzs Data panel - from the Main menu, click LB on

File I/O =>Data Input =>xyz =>xyzs

Select Colour

i Readxyzs Data

File

File to read

Default line colour

Default point colour

LUse super strings

(=] O =]
Many files I

u =
-

-
r—

[yellow

Default model for data I;l

&

| Read |

| Finish | [ Help |

Click LBona
colour icon to
bring up the list
of colours

black
blue
brown
cyan

dark blue
dark green
dark red
green
grey
magenta
off yellow
orange

hite
ellow

| Select

[View ceolour]
[Edit]
[Sameas]
[Browse]

Set the Default line colour in the above panel to dark green by clicking LB on the colour icon (the icon to
the right of the word red in the fourth data field). A list of available colours will pop up. Use the mouse to
click LB on dark green and then process it by clicking LB on the Select button at the base of the panel.

Alternatives: You can double click LB on dark green to short-cut this sequence. You could also have used
the down arrow key to work your way down through the list to highlight the word dark green and then
pressed < Enter>.

In a manner similar to the colour panel field just discussed, most panel fields have a pop-up list of choices
available and the list is activated by clicking on the icon at the right hand end of the panel field. Some
times there will be a special icon such as the colour icon in the previous example or the file box icon at the
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end of the File to read field.

vH Read xy z s Data E [=] @

File Many files File icon

File to read || I£|
E
r / Colour icon
Default line colour cyan I:l

Default point colour yellow |:| Model icon
Default model for data |;| /

Lse super strings

l—@ - View icon

| <\
| ————— Message area

[ Read | [ Finish | Help

Some of the more common icons we will see are:

/_J file/folder &

~

63

tin textstyle info

line weight

== model ==  choice

colour when B view
none selected

7= line style %l polygon w4 symbol
Note that there is a Message Area at the base of the panel (just above the Read button in the Read xyzs
Data panel).

= colour

Il

[

Each panel has its own message area to help you interact with 12d. If 12d does not appear to be working
the way you think it should, you will often get helpful information in the Panel Message area. Look in the
Screen Message Box as well as it may also be updated when interacting with panels.

If a panel is in the way, you can move it as stated above. Any panel can be removed (shut down) by
clicking LB on the X button in the top right hand corner or by clicking on the Finish button.

If you want to keep a panel that is already filled in such that you can refer to it later, you may decide to
temporarily minimise it by clicking LB on the ‘-° button. It can later be maximised again by clicking LB
on the ‘overlapping windows’ button (where the ‘- used to be).

As we don’t wish to proceed further with this panel click LB on Finish or click LB on the X button in the
top right hand corner of the panel.
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5 Starting the Tutorial

Before starting your tutorial, it is assumed that your overall desktop layout is as shown at the end of

Chapter 4.10.1 Basic View Operations, i.e. one large Plan view on display called 1.

g, 12d Model 5h 11.0C1a RC4 (nt.x86) - Project "C:\12d\11.00\Training\design\getting started basic\STAGE 1\STAGE 1" - [Plan 1] foa ==
Project File Edit View Models Stings Cad Tins Survey Design Drafting Plot Report Utilities User Window Help -ax
\ (i oz [ faen Ll B = S 2] 72 e v e F BRI R [

BENeEHDEUDEMEM EEADLO Ghlia®nn@ A 2ORRVEVFHSKURI

SANLFF DARSENRNONON A >

.1

Background tesks

REFONAEES

i

=, For Help, press F1

Output Window

CAP||NUM)||SCRL

5.1 Importing Point Data into 12d

The easiest way to understand the use of Models and Panels is to import some data into 12d and see by

example.

Point and Line data can be imported into 12d from a variety of sources. For the purposes of the tutorial, we
will use the simplest of these - a simple text file containing point number, X, y and z coordinates along with
a code and string number.

We will begin by reading in a Points file called ‘DETAIL SURVEY.csv’.
This file lies in the folder C:\12d\11.00\Training\design\getting started basic

1,42518.
2,42535.
3,42556.
4,42572
5, 42592
6,42606.
7,42612.
g,42410.
9,42419.
10, 42433
11, 42446
12, 42460
13, 42474

g73,36865.
£3Z,36859.
394,36847.
. 709, 36345,
277, 36345,
093,36845.

368,71.
242, 69,
968, 69.
796, 67.
967, 65.
526, 64.

533,DR, 1
505,DR, 1
349,DR, 1
75,DR, 1
579,DR, 1
§18,DR, 1

6,36847.949,64.739,DR, 1
27,36954.217,72.574, DR, 2

677,36955.067,71.904, DR, 2
.789,36954.863,70.552, DR, 2
.673,36955.149, §9.777, DR, 2
.181,36955.254, 68.955, DR, 2
.806,36955.092, 66.24, DR, 2

The format is one point per line containing a point number, X, y and z coordinate, string name and string
number all separated by commas.
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To read in the file, click LB on File =>Data Input =>x y z =>x y z general from the Main menu.

"B Read XY Z General Files =] = (==

Parameters

Parameterfile || |;| E

Files | Basic ] Format] Mapfile] Fencing |

12d gives you the ability to fill in this
— panel once and then save the setup to
7] i

a parameter file. This allows you, on
subsequent occasions, to call up the
parameter file and then you only need
select the data file to be read.

File Many files

File to read |£|

To make things easier we have already
created a parameter file and stored it
in Getting Started Basic folder.

Click on the folder icon at the end of
the Parameter file field.

Folder *xyf ]

[ | Help |

4 1 }

| Select

[Lio] D A blank folder panel will pop up, but we will browse for
[ser L] ’ the parameter file

[Browse]
[Browse reset]
[Browse 12d Synergy]
13

[12d Synergy] .

Relatve] ™ Click LB on [Browse]

(Open] _ . .

[Open with] Click LB on the getting started basic to move back to the
S getting started basic folder

[Ansi format] (System codepage)
[UTF-& format] (System codepage)
[Explore]

[Delete file]

[Emaill

:ﬂ: Select a file to open

” . v Computer » ) » » 1100 » Training » design » ing started basic » »
AT, | Comp OS(C) » 12d » 1100 » T g » desig g g d b STAGE1
Organize « New folder
il Libraries *  Name G Date modified Type Size
| Documents . - ) i .
= i STAGE_1.project 26/11/2014 9:40 PM  File folder
L s

Note that if vou have created the training projectin a
folder different to the one shown here then vou will
have to navigate to the required folder
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I:ﬁ: Select a file to open
- | )« O5(C) » 12d » 1100 » Training » design » getting started basic » ~ | *4 || Seorchg
o
Organize + MNew folder §= - E
‘v Favorites i MName : Date modified Type Size
BE Deskiop . STAGE1L 26/11/2014 9:42...  File folder
& Downloads 3] PtNo, XY, Z,5tr, StriNo.aogf 23/10/2014 4:04...  X¥F File 2KB
12| Recent Places
. 12d_Easter Eggs
. User_Lib .
- Double click on the file
. User
| ntx86 OR
| Click LB on the file then click LB on /Open]
) W11 exes
. V11 Installs
V11 Noen S
File name: Files (*.xyf)
Open ] l Can
('8 Read X Y Z General Files eSS
Parameters
Parameter file ,K,Y,ZVStr,StrNc-.:qfﬂ
Files lBasic l Formatl Mapfilel Fenci
File Advanced []
File to read
<Click LB on Read icon to load the parameters >
i Read X Y Z General Files [ /
Using the folder icon browse to the same folder that held
IRl _ the parameter file (C:\12d\11.00\Training\design\getting
Parameterfile | X v,7 Str,StrNoyf started basic) and locate the file DETAIL SURVEY.csv.
Files ] Basic | Format | Mapfile | Fencing | /|| | You will have to change the File type display to All files
= %k ok
File Advanced (\)
File to read DETAIL SURVEY.CSV] [
~ [Files (".dat) v
Files (*.dat)
Page 61
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:ﬁx‘ Select a file to open

@Uv| ;e 12d » 1100 » Training » design » getting started basic » - | 5¢| | Search getting started basic B |
Organize = Mew folder §== « i I@l
, 10,00 & Mame : Date modified Type Size =
, 1100 .
. STAGE1 26/11/2014 9:42...  File folder
| courses ) i .
e 7] Al Long Sections.tbf 111/20121:21 ...  TBFFile 98 KB (=
Al %] Chapter_16.12da 21/11/2014 7:22... 12DAFile 1,825 KB
, 12d_ADAC i A= .
o m = Chapter_17.12da 10/05/2009 %:41... 12DA File 846 KB
z e5|grl| b || Cross Sections.xplotppf 111/20121:21 .| File (**) 16 KB
| getting started : s y :
P & Cross Sections.xplotppf.ppf 111/20121:21 ...  PPFFile 10 KB
. %] DETAIL SURVEY.12da 9/11/2014 5:19 ... 12DAFile 235 KB
| STAGE 1.pt ot e i _ S
E DETAIL SURVEY.CSV 1/11/20121:21 ...  Microsoft Efcel C... 102 KB |
LJSUNEY ] GETTIMNG STARTED.rapfile 9/11/201411:09... MAPFILE Ffle 15 KB
" . | LogoJPG 1/11/20121:21 ... JPEG imag SM4EKBE T
. User_Lib - | n | »
File name: DETAIL SURVEY.CSV - [Fnes(tj -
CClick LB on Open>\> [ Open ] ’ Cancel ]
Select the Basic tab . ; .
You will notice that the panel is
mostly filled in from the parameter
i Read X Y Z General Files = % file (such as red and yellow).
However, you still need to set the
Parameters

Parameter file ,K.Y,ZStr,StrND.xyf

default text field

Files Basic lFormatl Mapﬁlel Fencing] L.
i - Select the choice icon then select any
Default line colour red of the text style
Default point colour yellow [:]
Default text styl
- style [-_S‘elect Textdata @
Skip column headers
Join all Arial 1 centre
Use string attributes in joining iﬂg%a:ll-‘?c;ﬁ;t:
Keep leading/trailing spaces for attributes 150 2 centre
Create missing attributes i:g: aae?der
Default model for data [ SAlgn Title
l
4| 1 3
[ Select
| [Edit]
[Sameas]
[Clear]

God) [ () o
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Select the Format tab
The format for the file values are already set up by the xyf file.

No user entry is needed for this tab

Files I Basic  Format |Mapfi|e| Fencingl

Input mode Delirmiter @
Delimiter comma"," @

Column number in file

Information Type Column #

1 |point id 1
2 |xcoord 2
3 |y coord 3
4 |z coord 4

LY string name 5

& | string number

Attribute Mode | Name | Type | Column #

[ choice ok

Select the Mapfile tab

A user defined Map File uses the code found in the data file to set the parameters for the strings including
the model name, linestyle, colour and more.

The path name of the Map File GETTING STARTED.mapfile has also been set up by the xyf file.
"GETTING STARTED.mapfile" already exists in C:\12d\11.00\Training\design\getting started basic.

A model prefix "survey *'"" (note that there is a space after the word survey) is used to group the survey
models together after the map file has set the model names. This will help keep the survey data separate
from the design. Using lower case for the word will send the models to the bottom of the listing

Parameters

Parameter file |-,K,Y,Z,Str,5trl\|o.xyl’
Files | Basic | Format Mapfile | Fencingl

Map file [C:\12d\11.00\Trainir

Pre*postfix for models [survey *

We’ll have a look at the Map File so that you are aware of how it works and what the Map File is doing.
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To open the map file

5 Read XY Z General Files = -i&-l
Parameters .
Paramete e [ XV Z 5t Setlarnt ] Select the folder icon then select
[Open]
Files ] Basic ] Format Mapfile l Fencing]
Map file |G STARTED.mapfile [_;older < mapile ot &
Pre*postfix for models survey
GETTING STARTED.mapfile /
4| 1 F
[ seids
- [Lib] »
[ choice ok [User Lib] 8
[Browse]
orouse f
[Open]
[Open with]
[Edit file]
[Unicode format]

. Map File Create/Edit == Rl ===
Map file [C:\12d\11.00\Train

[=- Map File
.. Header

- Basic A tree structure is used to access the

- Fills sections within the Map File
- Symbols

.. Tinable

.. Vertex Text Data

- Segment Text Data
- Pipes

.. Boundaries

e [F
[lud iy o}

The Basic node sets the model,
colour and more. It is shown in the
next image.

- Visualization
- Attributes

T
)

[l
[}

[ Finished reading file

Finish
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. Map File Create/Edit = ===
Map file [CA12dV11.00\Train
=~ Map File Key Att | Name | Model Colour Point Line | Linestyle | Weight | Comment | Group | Active | » E

. Header Key E
NEE TOPO BANKBOTTOM | orange || line BB
- Fills 2|ca TOPO CHANGE GRADE | orange line CG = [Z
& ?’"’”:F'S 3R ROAD CROWN grey line RC B
-l Inaple —— = —
g S 4|oR TOPO DRAIN CL cyan Ifne BDRN =
. Segment Text Data 5|pTMBDY TOPO TIN BDY red [ tine 1
- Pipes 6 |ES ROAD PAVEMENT EDGE | grey line 1
. Boundaries 7 |sEC SEWER PIPE brown . line 1
- Visualization N TOPO SURFACE LEVEL | orange point 0
- Attributes alsTh SLRVEY STH red B nnint n S

[ Finished reading file

Finish

Click LB on Finish to exit the mapping file

Now that we’ve had a look at the Map file, we’ll read the data in using the Read X Y Z General panel

wfl. Read X ¥ Z General Files o] @ |

Parameters
Parameter file JEYUZ, St StrNo sy
Files | Basic ] Format] Mapfile] Fencing |

File Many files [

File to read DETAIL SURVEV.CSV

[ File «C\12d7\11.00\Training'\designgetting started basic\PtMo,

On the Read X Y Z General panel, click on Read to import the data file.

You will notice that a new Plan view called 2 view has been created and the models containing the data
read in have automatically been added to the view. This is the default action when reading data in.
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75112 Model SM 11.0C1a RCA (nta86) - Project "CALZA\1100 trted basc\STAGE TSTAGEL" - Cient 12D Solutions - Lee” o= Een 5|
Project File Edt View Moddls Stings Cad Tins Suvey Design Diofting Plot Report Ulities User Window Hep

[EIED = R = Mo @B @Mx 9 & (R -
DO Q&m0 @ B3 (/3 A0 B8 BN H P

g
e
o
B
H

i

SEEES

o B 2] v

Maximise Plan view 2 and the screen should look like:

“#l. 12d Model SM1L0CLa RC4 (nta@6) - Project "C:\12d\11.00\Training\design\getting started basic\STAGE 1\STAGE 1" - [Plan 2]
Project File Edit View Models Stings Cad Tins Survey Design Drafting Plot Report Utilties User Window Help

[En

= 7 ) T ) 2 = - >
e mo@E P 29RROERF DX

i

4

SEEES

. | Output Window

Page 66

n x
¥ Loading Project -
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5.2

Plan View Operations

Now that we have some data, we can begin to look at some more of the Plan view features of 12d.

Menu

Bring up the Plan view Menu.

I:::::I Adding/Removing models [

In the Plan View Button Area, you will observe a ‘“+” and ‘-*. This is a shorthand technique for turning
models on and off.

Click on the ‘-’ sign button with LB. A list of available models to remove from the view pops up. Pick
‘survey VEG TREE’ and click LB on ‘Select’. You will observe the tree symbols in model ‘survey VEG
TREE’ are removed from the view. The ‘+° works in a similar way to add models to the View. Practice
adding and removing models from the view with the + and -. Remember, the models are not being deleted
with the -, merely removed from the current View. Turn back on the tree model survey VEG TREE.

@

After multiple pans and zooms, you sometimes wish to return to a point where all of your data appears in
the view. This is equivalent to an AutoCAD Zoom-Extents. Click on Fit with LB to see all of your data.

,__ﬁ': # Dynamic Pan
il

This facility allows you to move the centre of the view but retain the current zoom factor. Click on Pan
with LB. You then press down LB on a point in the View and then drag the mouse. The data in the view
will move with the mouse until LB is released.

L,E Zoom

Select Zoom (to Zoom In) from the Plan View Button area with LB. Click LB on two diagonal points of a
rectangle and then click LB once anywhere in the plan view. The information will appear enlarged based
on the size of the rectangle.

MB Wheel Zoom

If your mouse has a wheel as part of the middle button, then it can be used to dynamically zoom in or out.
Simply click LB in the plan view at the point you want to zoom about and then roll the wheel forward to
zoom in and backwards to zoom out.

@ Shrink

This is equivalent to Zoom Out. It works just like Zoom but in reverse.

Previous

If you click LB on Previous, the view will appear as it was prior to the Zoom. 12d always keeps the details
of the previous view setting available so that you can return to it quickly. Only one level of previous view
settings is kept.

% Toggle

There are multiple items under the Toggle Pop Up menu. At this time, we will try only one of them. Select
Grid with the LB. A rectangular grid should appear. If you click LB on Toggle =>Grid again, the Grid
will be removed from the display.

The appearance of the grid can be changed by clicking LB on the Menu button in the View Button Area
and click LB on Settings =>Grid. You can change any of the settings in the panel. Try changing the grid
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spacing from 100 to 10 in both x and y directions and click LB on Set. You will notice that the Grid can be
turned on and off from either the panel settings or the Toggle =>Grid switch. Click LB on Finish to
terminate the panel.

'3.",._{- Refresh

All the information on the view will be redrawn. This can also be achieved by clicking MB anywhere in
the View Title Area or anywhere in the View Button Area except over the *+’ or ’-’ buttons.

ﬁ Plot

Bring up the Plan view Plot Menu. This has options to generate a quick plot of what is on the screen, plot plot frames
and drainage plan plots

E Clone

Creates a copy of the view.

=

Properties

Brings up the Plan View Properties panel for this view.

If we clicking on the Fit icon @\ on Plan 2, then we will get.

*fi 12d Model 5M11.0C1a RC4 (nt.x@6) - Preject "C:\12d\11.00\Training\design\getting started basic\STAGE 1\STAGE 1" - [Plan 2] = 2=
Project File Edit View Models Strings Cad Tins Survey Design Drafting Plot Report Utilities User Window Help _a@x
[ @] [base [ [eyan mI H]E = E M) E nERERE R e L
FOxEEHDEEDEREMW  HEADLD Gdla@ b — D RORROOAF NI
+, | (B2

®,

/.

Q.

-
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53

Birds-Eye Views and Throwing Between Views
To introduce some new concepts in 12d, we will need both of the Plan views on the screen at once.

First we’ll un-maximise Plan 2 by clicking on the Restore icon for the current maximised View (there can
only be one maximised view).

= || =] ER
N O
[ (] B [ .
PRROOAF S KU DI L

Restore the maximised view to its
previous un-maximised state

Now resize and move the views around so that Plan 1 is on the left and takes up half the area and Plan 2 is
on the right and only takes up around 2/3 of the area.

From the main menu, click LB on Views=>New=>Plan and place a small view about 50mm square in the
top right hand corner of your desktop. This will create View ‘Plan 2°. See Chapter 4.10.1 for full details on
how to create and resize Views.

In the View Plan 1, use the + view button to turn on all of the models. Do a Fit to both views.

EfPian1 o |[= = Plan2

b ]

Note: the quickest method of adding all the models on one view to another view is to user the option
View =>Models transfer.

From the Plan 2 View Button area, click LB on Zoom & and click a point in the lower left corner of the
View Plan 2. Before selecting the second point of the Zoom rectangle, move the cursor into the other View
i.e. Plan 1.

Notice that the second point of the Zoom rectangle is being taken from the second view and the view box
is drawing in both views.

Select the second point of the Zoom rectangle in either View, and take it at the bottom left hand corner of
the data.

After selecting the second point of the Zoom rectangle, you will notice the prompt Select destination view
- RB to cancel in the Screen Message Box



12d Model Getting Started and Training Manual

2 qb
YView Zoom> [Select][Dynamic][Cancel] Select 2nd comer of box - RB to cancel, D toggles dynamic ) |x=42758.992 y-36801.923 [[cap]num][scRe]|
S

12d is prompting you to select the View you want zoomed. That is, the view that you want to zoom
rectangle to take up the entire view.

Click LB in View Plan 1. The zooming will then take effect in View Plan 1.

. ‘PlanZ
YR

E5] Plan1

FERNEEREEXEER]

Notice that using this technique, it is possible to achieve a birds-eye effect where the smaller View displays
the complete model whilst the larger working view is zoomed to an extent where it displays only the detail
that you are currently working on. You would typically define all of your zoom rectangles in View Plan 2
but have the zoomed details updated in View Plan 1.
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You can even do this with different models turned on in each view. For example, in the birds-eye view, you
would typically only turn on sufficient detail to enable you to zoom on known features.

To see this, click LB over the = button on View Plan 2 and remove the model Survey TOPO SURFACE
LEVEL. This will make the large scale details much easier to see on view Plan 1 and still have the full
level of detail on the zoomed in view, Plan 2.

[ ian1 =@ | ke ==

ERIR SIS CYCYEAICIEY Y ] } B rlEYa@xKREE

Please practice zooming and throwing between Views as it is a powerful concept in 12d.

After completing this exercise, delete View Plan 2 as it is no longer needed by using a second way to delete
a View.

Click LB on the Menu button in the View Button Area of Plan 2 OR click RB anywhere in the View
Button Area of Plan 2, to bring up the View Menu for the view.
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[ Plan 2

q_@f@ﬂ@]
iew

Models »
Settings »
Redraw

Fit

Previous

Zoom 3
Pan r
Utilities  »
Clone
Properties
Delete

| Do you want to delete the view ?

Then maximise Plan 1 and do a Fit.

FEANEREEXE

=H
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Rolling Middle Mouse Button to Zoom In and Out
The Zoom option was introduce so you could zoom in on a selected area.
Another method of zooming in and zooming out is to use when your mouse has a Roller Middle Button.

First click any button in the view to highlight the view (get focus on the view), rolling the middle button
forward will zoom in about the position that you clicked inside the view to get focus.

Rolling the middle button backwards will zoom out about the position that you clicked inside the view to
get focus.
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5.5  Deleting a Model

As we now wish to look at an alternative (and preferred) way of importing data into 12d, we will delete the
existing models as they will be recreated in the following option.

From the Main menu, click with LB on Models=>Delete=>Delete all models.

B Delete AlModels = | & [

Permanently delete? B

[Delete | [ Finish | [ Help | Delete Mode! =

i ) 1 You are about to delete 14 Models from the project
Click LB on Delete -

~ These can be retrieved from the trash bin at a later date

Delete from the project ?

Click LB on Yes to confirm

When Permanently delete? is NOT ticked on and models are deleted, they are sent to the Trash Bin in
case they need to be restored at a later stage.

When there are models in the Trash Bin, a Trash Bin icon appears at the bottom right of the 12d screen

s

To access the deleted models, double click LB on the icon or select Project =>Management =>Trash Bin

#fl. Trash Bin [o] @ |EE
Select | Type | Mame Deleted By | Time | Restore As |
1| | model survey ROAD CROWN lig 23/10/2014 18:21
2| | model  survey ROAD PAVEMENT EDGE lig 23/10/2014 18:21
3] | | model  survey SEWER PIPE lig 23/10/2014 18:21
4 | | model  survey SURVEY STN lig 23/10/2014 18:21
5 | model survey TOPOBANKBOTTOM lig 23/10/2014 18:21
5 | model survey TOPOBANKTOP lig 23/10/2014 18:21
7] | 'model survey TOPO CHANGE GRADE lig 23/10/2014 18:21
g | model survey TOPO DRAIN CL lig 23/10/2014 18:21
) | 'model survey TOPOSURFACELEVEL lig 23/10/2014 18:21
10| | model  survey TOPOTIM BDY lig 23/10/2014 18:21
11| | | model  survey TOPO WATER EDGE lig 23/10/2014 18:21
17| | model  surveyVEG TREE lig 23/10/2014 18:21
13| | | model  survey WATER PIPE lig 23/10/2014 18:21
F |— model  unknown lig 23/10/2014 22:57
15| [
|
Restore Delete Refresh Finish Help

To restore models, click LB in the Select column next to the models that you want to restore to turn on
ticks for the models, then click LB on the button Restore.

To permanently delete models in the Trash Bin, click LB in the Select column next to the models that
you want to permanently delete to turn on ticks for the models, then click LB on the button Delete.

To permanently delete all the models in the Trash Bin (like emptying the Windows Recycle Bin), turn on
ticks in all the rows in the Select column by clicking LB then RB over the top of the Select column to
bring up the Column operations menu.
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5.6

5.7

Irash Bin

J[S Column 1 @

1 Toggle

! RC
3 SE
4 s
5 TC
6 model | survey TC

Click LB on Set to turn on all the ticks and then click LB on the Delete button.

Warning 23

“warhing! Deleting these elements will permanently remove them!
'ou will not be able to restore them if pou continue!

Are you sure vou wizh to delete them?

ez | ‘ Mo

Click LB on the Yes button to confirm permanently deleting all the selected models.

Redraw - Fixing up a Modified or Erroneous View

Whenever data is removed from a View e.g. turning off the display of a model, the view does not
automatically get refreshed. 12d typically removes a model by overdrawing the information using the
background colour, usually black. This operation can leave the view looking speckled and unclear.

You can force the view to refresh by clicking LB on the Refresh button { , or click MB in the View
Button Area anywhere other than over the ‘1 or ‘=* view buttons. The whole View will be repainted to
display the corrected information.

It is also possible that some of the menus may at times become corrupted. Windows is a very complex
multitasking environment and the menus are stored in memory which is being updated continuously. If you
ever get parts of your desktop that don’t look correct, you can force your entire 12d screen area (all menus,
views etc.) to be refreshed by holding the Ctrl and R keys down together (<Ctrl>+R).

Alternatively you can refresh just any one Menu by clicking MB in the Menu Title Area.

View Tabs

There is a tab for each view on a bar just above the Status Bar at the bottom of your 12d screen. If you have
the Output Window in the default position (the tab at the bottom left of your desktop), the tabs bar is
displayed just above the Output Window.

The View Tab has the icon for the view type and then the view name beside it.

View type  (View name )

Each tab corresponds to a 12d View.

| output Windaw

To bring a 12d view to the top of all other views and to set the view as your active view, just click LB on
the appropriate View Tab, or click LB in the view title area of the view.
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5.8

5.9

5.10

Note that when a view is active, the View title highlights in blue.

View title area

Plan1

When there is more than one view tab, the order of the View tabs can be changed by holding LB down on
the View tab whose order you want to modify and then moving the cursor to the left or right until you
reach the position that you want the selected view tab to be in.

Saving a Project
The current changes to the Project you are working on are only stored in memory.

To make the changes permanent and update your files on disk you need to Save the Project. This can be
done at any time by clicking LB on Save from the Projects Menu (Project =>Save), or by holding the Ctrl
and S keys down together (<Ctrl>+S).

12d will also pop up a panel reminding you Do you want to save the project?

a‘ﬁ: Save Project Reminder

| Do you want to save the project 7

5
| Yes | |Cancel|

Click on Yes with LB to force a Save to occur.

The timing at which this message appears is set from the Defaults panel brought up by the menu item
Project =>Management =>Defaults. The time in minutes is set in the ficld Save Interval (min) under the
System Settings tab.

The default is every 15 minutes. Set the time interval to zero to turn this feature off altogether.

If you ever crash out of 12d due to a power failure for instance, any changes since your last Save operation
will be lost.

Exit
To terminate a 12d Model session, click LB on Exit on the Project menu (Project =>Exit).

If you try to Exit 12d after changes have been made to your Project, 12d will remind you of the changes by
prompting you for a further Save operation.

Starting 12d When Projects Already Exist

When 12d Model is started and projects already exist and have been opened in 12d, the most recent
projects will be listed on the left hand side of the 12d Model Front Screen.

78, 12d Model 11.0C1a RC4 (nt&6) - Open a Recent Project =l ==

12d Model

Path

e T T
1

D:\12d_ADACVADAC Data\Demo\Desigr Design Data 41
D:\12d_ADAC\ADAC Data\Demo\Survey Survey Data 41 1 1111

B &) 63 (] () ] (=]

Mo description set

Name Version Databas »
version

- Recent projects list

Double clicking on a project in the Recent Projects list will open the project.
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Also when you are in 12d Model, the walk right menu Project =>Recent projects will also list the recent
projects and clicking on a project in the list will exit the existing project (asking if a Save is wanted) and
opens the selected project.

When you return to an existing project, the appearance of the views and toolbars on the screen will be just
as you last left them.
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Basic Modelling

6.1 Alternative Data Entry

We will now repeat the process of importing data into 12d but this time we will use a 12d Archive file.

This option is the more common way of transferring data from Surveyor to Designer when both parties use
12d. The Archive format will often include all of the strings with the correct model, colour and other
properties so that no mapping is required. Also a tin (triangulation) can be included in this file format so
that the Designer has no need to create a new tin from the survey data. In this instance we will assume the
coding is correct but the models are different so that mapping is required. Also a tin is not included.

We will import the file DETAIL SURVEY.12da. To read in the file, click LB on
File =>Data Input =>12d =>12d archive data from the Main menu.

=l o]

Many files []

la‘ﬁl Read 12d Solutions Archive Data

Files

[sic\DETAIL SURVEY.12da [

File to read

Pre"postfix for models [synvey *

@

Use pre*postfix for tins
Use map file model when pt/line changes

Allow Finclude to be used

O0OdO

Convert 2d,3d 4d, poly,face interface to super

|fini5hed reading ascii data

Read

4J

Help

Click LB on the File to read folder icon then browse
back up to the folder
C:\12d\11.00\Training\design\getting started basic

Double click LB on the file DETAIL SURVEY.12da
and the file name will be piped into the field File to
read

A map file is not required.

A model prefix "survey *" is again typed in to group
the survey models away from the future design models.

Click on Read to read the data into 12d Model.

Again a new view Plan 2 is created with the models read in automatically added to it.

Transfer the models from View 2 to View 1 by using the option View =>Model transfer.

Delete Plan 2 to just leave the one view, Plan 1

[E] Plan1
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6.2

Another great way to read in an existing 12da file into an existing project is to use Drag and Drop.

To Drag and Drop, in Windows Explorer, press LB down whilst over the file DETAIL SURVEY.12da and
then move the cursor over the 12d screen area and then release LB.

A Read 12d Solutions Archive Data panel with the full path name to the file DETAIL SURVEY.12da
automatically entered into the File to read field.

Saving a Model Listing to a File for Future Use

The current thirteen models on the view are exactly the models that are used to create the natural surface
tin. We will now see how to record these models in a form that can be used in the future to restore those
same models to another view.

To make the list, we first click on the Plan 1 view tab to make Plan View 1 the focus. The heading in view
Plan 1 should appear coloured bright blue and if there were others views, will be brought to the forefront.

From the Main menu click LB on View =>Models Save/Restore

1" View (Save / Restore Models) |£|_‘éj

save \ Remrel Type in the file name SURVEY.
Pressing <Enter> will add the

File name to Save SURVEY.wml I;l extension .vml
Viewto s % — . o
1ew 1o save 1 |§| Click LB on the view icon then select

Sawve view 1

Click LB on Save
Click LB on Finish to exit the panel

| File <SURVEY.wml> will be created

Finish

This file can be read at any future time by use of the Restore tab on the View (Save/Restore Models)
panel. This will add the models in the vml file to any view.
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6.3

Triangulation

We will now use this point and line information to create a 3d surface or TIN (Triangulated Irregular
Network).

One of the concepts in 12d is that a TIN can be created from a single model, a single view (and all the
models on that view are used) or a model list.

In general, you will use Views to create models since you can control which models are on display in a
View.

It is important to understand that when creating a TIN from a View, only those strings in models added to
the View will be used in creating the TIN and only then if the strings have been set to tinable.

For instance, if you were forming a TIN representing the natural surface, you could only leave models that
represented underground surfaces on the view used to create the TIN, if such data is non tinable (i.c. not
used in a triangulation).

When using a mapping file to read in data, strings can be flagged as being tinable (and Breaklines) or non
tinable. Only tinable strings are used in the triangulation.

Breaklines are used to pick up the topographical features accurately.
When forming triangles, 12d ensures that every straight segment in the breakline is the side of a triangle.

In this exercise we are assuming that the survey strings have already been checked for errors (See the
Getting Started for Surveying manual on methods for checking the data).

[ Plan1 [ ==z
&=l

For the purposes of the tutorial, please ensure that all models in view Plan 1 are on display prior to
creating the TIN. Plan 1 should look as shown above.
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From the Main menu, click LB on Tins =>Create =>Triangulate data

-:ﬁ: Triangulate a Data Source [= || =

General | Data ] Nullingl

Retriangulate function [TIN GROUMND
Mew tin name [GROUND
Tin colour [green D
Tin style [1 o
Model for tin |tin GROUIND

Additional settings

Preserve strings Remove bubbles [l
Weed tin [] Triangle data [l
Cell method [7] Colour by triangle data [

]

Create many

B

| ok - no Tin <GROUND> exists

[Triangulate]

| Finish | | Help |

Fill in the first tab of the panel as shown.

The Triangulation function option is used to construct
a function which, when recalculated, will run a
retriangulation on the tin. Place the cursor in the data
field with the LB and type in TIN GROUND

Each TIN requires a name. Position the cursor in the
New tin name field and type in GROUND. If you press
<Enter>, this name will also be used to fill in the Model
for tin field but with the prefix "tin " (see panel). The
TIN name is subsequently used to refer to this specific
TIN.

Position the cursor in the Model for Tin field and type in
the suffix ",1" after the name so that the model is added
to the view 1, and hence displayed, as soon as the TIN is
created.

There is no problem if you don’t add the ",1"because
you can always add the model containing the tin to a
view at any time.

i Triangulate a Data Source E‘_léj

General Data }Nullingl

Data to triangulate

e & L

View

|

# ' Triangulate a Data Source Iil_léj

General] Data  Mulling l
Apply nulling  [7]
Angle ls=— 2
Length 100 L
Combined angle  |50*= 2
Combined length [20 |

INBDY->DTMBDY [

Mull polygon

[ "survey TOPQ TIN EDV->DTMEDY" selected
[ zmin 51.837 zmax 78.003
[ Finish | |

[Triangulate] Help ]

Click on the Data tab.

As we wish to triangulate all the data in plan view 1 and
leave the tinabitily to determine which data to use, click
LB on the view icon. Selﬂl from the list.

Click on the Nulling tab.

There are two options here, you can set the parameters to
null the external triangles, and/or you can use a polygon to
null all triangles outside this polygon.

The DTMBDY string will be used as the boundary for the
tin.

Click LB on the Null polygon string icon then click LB on
the DTMBDY string followed by clicking middle button
(MB) to accept the string.

(We will cover selecting strings in Chapter 7 String
Picking Concepts.)

Click LB on Triangulate to create the TIN. There will be a
short delay and then your TIN will be created and displayed
as shown in the next picture.

Click LB on Finish to terminate the panel.
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[=)=]=]

i Plan1

&

ERRIEY YRt E =

If you didn’t use the ",1" after the model name in the Model for tin, now add the model tin GROUND to

the view. View 1 should now look like:

o

Page 83
S —

is clipped at the selected Null polygon ensuring only the surveyed data is included.

Tin names must be unique in the project.
5. Deleting a model DOES NOT delete any tins in the model. Tins are deleted with Tins ->Delete

Note that the TIN

Now that we have a TIN we can display the TIN data in a variety of ways.

Important Notes

2. A tin can only be displayed on a view by adding a model that contains the tin to a view.
3. A tin can be in more than one model. Or even in no model.

4. More than one tin can be in the one model.

1.
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6.4  Tin inquire
) From the Main menu, click LB on Tins =>Inquire to bring up the Tin Inquire
Tin Inquire panel.
Aspect
Colour

Depth from height
Depth from string
Depth between tins
Height

Slope

Crop onto tin in 3d
Drop tin te tin in 3d
Tins on a view

User L

Click LB in the menu title area (where it says Tin Inquire), move the menu and
Pin it with the LB. This operation is necessary to stop the menu from being
automatically removed after the first menu pick.

Click LB on Aspect, and the Tin Aspect Inquire panel will pop up.

- Move the cursor over the 7in icon button at right end
of the Tin field and use the LB to pop up a list of
Tins. Double click LB on GROUND. Then click LB
in the menu title area (where it says Tin Aspect
Inquire), move the panel to a clear area of your
screen and pin it with the LB.

l‘:ll'ﬁnhspect]nquire || [=] [ﬁ]
Tin [GROUND

[ aspect=63°41'41,69" x=42553.787 y=36861.14(

y. Do not Click on the Finish button in the panel.

Notice that as you move your cursor over the tin, the aspect is being displayed in the panel message area.

Repeat this procedure with both the Height and Slope menu items.

Pl A
A
LA AN
— eI S e
En In :t uire ] SO, ‘ﬂﬁg‘ﬁﬁ
spe e S .
g Wnkpnie (=] o &3]
Depth from height Tin |GROUND

Depth from string
Depth between tins
Height

Slope

Drop onte tin in 3d
Drop tin to tin in 3d
Tins on a view

User 4

[aspect=12475234.91" x=42583.935 y=37015.3(
e LA AR G y
1| 7. Tin Height Inquire Bl

Tin [GROUND

| z=05.056 x=42583.935 y=37015303 tin=GROI

y

[ el it BT

:ﬁ" Tin Slope Inquire

By i Ve

Tin |GROUND

4

SN
Jorii| [slope=5.545%, 1vin 18,035, 3°102533", x=
KT/
f;’, ?.\'-.-_'\
|
Y

L |
Once all three panels are on the screen, move the cursor anywhere over the TIN and observe what happens.

When the cursor is positioned over any one triangle, the three point coordinates of the triangle are being
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used to linearly interpolate on the fly to calculate the exact x,y,z coordinates of the cursor. Also the aspect
and slope of the triangle is shown in the respective panels.

We’ll now look at one option that combines all three, as well as Tin colour, and does not even need a Tin
to be set.

On the Tin Inquire panel, click on Tins on a View (Tins =>Inquire =>Tins on a view) to bring up the
Tins on View Inquire panel.

Now move the cursor around the view and any tins under the cursor will be dynamically listed in the panel
and at the (x,y) position of the cursor, display the height of the tin, and the triangle colour, slope and
aspect.

Colour Slope Aspect
GROUND green . 3°39'34.9¢ 139°06'59.3;

| x=42605.038 y=26988.170

Finish|

Click LB on Finish on all four panels to put them away.

Also click LB on X on the Tin Inquire menu to shut it down.

We will now look at the various ways information in TINs can be viewed.
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6.5 Fast Contours

We now want to remove all of the models from the View except tin GROUND. From the View menu (in
the View Button area), click LB on the - sign to pop up the Models to Remove panel.

Models to Remove "1"

survey ROAD CROWN

survey ROAD PAVEMENT EDGE
survey SEWER PIPE

survey SURVEY STN

survey TOPO BANK BOTTOM
survey TOPO BANK TOP
survey TOPO CHANGE GRADE

survey TOPO DRAIN CL
survey TOPQ SURFACE LEVEL
survey TOPO TIN BDY

survey TOPO WATER EDGE
survey VEG TREE

survey WATER PIPE

tin GROUND

Click LB in the panel title area (over the words Models to
Remove), move the panel and repin it with LB so that it
doesn’t collapse after each selection.

Now click the LB on the first survey model. Drag the mouse
down the list to highlight all the survey models and click on
Select. Alternatively, you could double click LB on each
model in turn except tin GROUND. Click LB on X to shut
down the panel.

Select

Plan1

ST
L
o

17

%
3§
%)

| Linestyles [on]

| Vertex indices [off]
21 Z walues [off]
“" String names [off]

/| Arc centres [off]
Tin contours [off]

{ Tin flow [off]

Ay
ﬁi i

=
i Ar"é
b

0,

o

[

.JL

iy,
[
Wad s
R

S

E5 PAn-diEn=nE /Now from the View buttons,

click LB on the Toggle
Culling [off] button to bring up the Toggle
Text [on] menu.

Then click LB on Tin
contours. You should see the
following red and green
contour lines appear.

Sewer [off]
String text [on]
Vertices [off]

r\* v *r v ¥

Attributes [off]

Tin edges [off]

Tin solid [off]

Grid [off]

Rasters [off]

Clouds [off]

Vertex/Segment UID's [off] »
Paint id's [off] 3

AN T ST
i f‘*'*-?é

g
lu'r oy
-
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[ Plan ERE0
HEeEEaWE X R E

G’lan 1 Menu button.

If you click Toggle =>Tin contours again, the View will revert to the green triangle display.

The appearance of the contours can be changed by clicking LB on the Plan 1 Menu button in the View
Button Area. Click LB on Settings =>Tins =>Contours and the following panel will pop up.

(B3 Tirt Draw Contours foP T = [ | You can change any of the settings in the panel

including colour. Click LB on the colour icon

e 1 at the right end of the contour colour field to

Draw triangles contours see a popup list of available colours. Select a

Cont inc L colour by double clicking on it with LB.

Cont ref 0 Try changing the contour increment (spacing)

Cont colour ed from 1 to 5 and the bold increment from 5 to

Bold inc 5 25. Click LB on Set to activate the changes.

Bold colour green You will notice that the East contours can be
turned on and off from either the Draw

| triangles contours tick box setting in the

f panel, or the Toggle=>Tin Contours switch.

At the completion of experimenting it is suggested that you put the settings back to their default values (as
above) at this time.

Click LB on Finish to terminate the panel. Your new settings will remain in effect indefinitely until
changed.
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6.6

Fast Flow Arrows

It is recommended that you turn on the drainage models for this exercise. From the View menu (in the
View Button area), click LB on the ‘+° sign button and double click LB on survey TOPO BANK
BOTTOM, survey TOPO BANK TOP and survey TOPO DRAIN CL. Make sure that the tin
GROUND model is also still turned on. The easiest way to confirm this is to click LB on the ‘-* sign
button in the View Button Area and look at the list of the models that could be turned off. Click LB on the
X button to terminate the list.

Now from the Toggle button, click LB on Toggle =>Tin contours to turn OFF the contours and then
Toggle =>Tin edges. The purpose of this is to outline each triangle.

Then click LB on Toggle =>Tin flow. You should now see an arrow appear at the centre of each triangle
representing the direction of water flow.

Try zooming in on a section of the model for a closer look. When you have finished zooming, click on Fit
to again fill the View window.

2] Plan1
EEIRIEYCECYEYFA I EY =Y [
v

The appearance of the flow arrows can be changed by clicking LB on the Plan 1 Menu button in the View
Button Area. Click LB on Settings =>Tins =>Flow Arrows and the following panel will pop up.

# ' Tin Draw Flow Arrows for View Iil_lﬂ—hJ

You can change the size of the arrow

View L (= heads and their colour. Click LB on the
Draw triangles flow colour icon for the Colour for arrows
field to popup a list of available colours.
A length : C g
e fro Select one by double clicking LB.
Colour for arrows |dark green

Try changing the arrow length from 10 to
| 5 world coordinates (in this case metres).

L 4

Click LB on Set to activate the changes. You will notice that the Flow arrows can be turned on and off
from either the Draw triangles flow tick box setting in the panel or the Toggle =>Tin Flow switch.

Click LB on Finish to terminate the panel. Your new settings will remain in effect for this view until
changed.

Click both Toggle =>Tin edges and Toggle =>Tin flow again and the View will revert to the green
triangle display.
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6.7 Perspective View
We will now look at the perspective view facilities in 12d to examine the surface we created above.

Create a new perspective view. Click LB on Views =>New =>Perspective from the Main menu and a new
view pops up. Alternatively by selecting Views =>Create =>Perspective view from the Main menu, a

panel pops up.
#fl. New Perspective View EI = @ If necessary, put the cursor in the View
View name | 2 E] name field, backspace over the existing
| entry (or use the Delete key) and type 2.
Click LB on Create.
[ Create ] [ Finish ] [ Help ]
y:

Note the new view is created immediately and is placed over the top of your existing windows. If a view is
maximised then it will be unminimised when a new view is created.

You can use the standard windows features to Tile the views. For example, on the Main Menu select
Window =>Tile Vertical.

Your overall screen layout should now look something like this.

5l 12d Model 5M 11.0CLb RC 1 (nt86) - Project "C:\12d\11 00\ Training\design\getting started basic\STAGE 1\STAGE 1" - Client "12D Solutions - Lee” =n =R
Project File Edit View Models Strings Cad Tins Survey Design Drafting Plot Report  Utilities User Window Help

| [ [base [ [green L g @I & SErERSIE (T [ =
FUHEEHOEDEREM FHEADO: G 0E e @ PORVBLOT [l
] Plan 1 o fF= ] | E Perspective 2 [==f=]
EREOCEORE R PrArrllEerEeReNERE

SANEF DEBSHFAROD0ONX &

a [l

o |

) Q&

L. 5}

&, B |2 | q4 b
m

= [[cap]Mum][scRu ]

5

“ |Output Window | |Backgroum| tasks

Note that the highlighted view is placed on the left by Tile Vertical.
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The view buttons on a Perspective view are

[7] Perspective 3
BFrAERRAEEEEEIEXKERE o
| Clone
Fit Pan | Shrink Eye Joy Refresh Properties
Remove Previous Walk
Add Zoom Plan Camerapyjve  plot
Menu Toggle  Obit

6.8

we now need to add the TIN to the perspective view. In the View Button Area of Perspective OpenGL 2,
click LB on the ‘+¢ sign button and double click LB on tin GROUND. Click LB on the Fit icon.

Note that Zoom using the Zoom option and rolling the middle mouse button both work in a Perspective

view.

So after your Fit, zoom in so that the tin almost fills view 2.

Perspective 2

[ 5w

BRIRICYSIEICYEYFI NP RS

Pan and Zoom in Perspective Views

Pan and Zoom both work for a Perspective View.

Trying Zooming in and panning around.
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6.9

Joy Panel

The Joy View panel (short for Joystick) provides a quick way of orientating your eye in relation to your
data when manipulating a Perspective view.

The Joy View panel is accessed from the View Buttons Area. Click LB on the Joy button in the View
Button Area of Perspective 2 and the Joy View panel appears.

+8l. Joy View E=R[EoR (=
. Try clicking LB on In and Out icons
View |2
Move eye |
Mode |5tep a a

and observe what is happening. You eye is moving
inwards or outwards from the data.

Hz angular step  [15°

Vtangularstep fi5°
Also try Up, Down, Left and Right. icon

2|

Distance [100 (& ﬂ ﬂ

Finish

] ][] (<] (]

If you get lost or zoom in too far, you can always start again by clicking LB on Fit in the View Button
Area.

The angular step between each up or down step defaults to 15 degrees. You can change this if you want
smaller increments by entering a new value in the Angular Step field.

Similarly, the Distance changed on each In/Out movement defaults to 100 (metres in our case as all data is
in metres).

The easiest way to reset a view so that you can see all of the data is to click LB on Fit from the View
Button Area.
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6.10  Orbit
The Orbit is another way to orient your eye in relation to your data when manipulating a Perspective view.

The Orbit option is accessed from the View Buttons Area. Click LB on the Orbit button in the View
Button Area of Perspective OpenGL 2.

By holding LB down and moving your cursor around you will see the effect Orbit has.

The centre of the Orbit is displayed on view 2 as a white circle.

[7] Perspective 2 N\e— Orbl@@@

i Centre of the Orbit

A message with the instructions for Orbit is also written to the Screen Message Area.

< Perspective Camera> [Orbit][Pan][Swivel] w,a,sd - pan, et - pick eye [ target, f - fit, esc - cancel
So try holding MB down and moving your cursor around and then holding RB down and moving your
cursor around.
Notice there are also key commands w, a, s, d and f. Plus <Esc> to terminate Orbit.

If you had created a Perspective OpenGL view instead of a Perspective view, you will also see a set of

Page 92
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coordinate axes displayed in the bottom left hand corner to indicate the positive X, Y and Z directions.

ﬁ Perspective OpenGL 2
P P

M O (oo

Centre of the Orbit

You can use either a Perspective 2 or a Perspective OpenGl 2 in the training and if there is any major

difference then it will be pointed out.
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6.11 Plan Camera

The Camera button links the Perspective view to all the unminimised Plan views (we’ll refer to them as
just the Plan views).

The Camera (Eye point) and Target point for the current perspective settings of the Perspective view are
displayed as icons in the unminimised Plan view and moving the Camera and Target icons around in a Plan
view controls the perspective settings for the linked Perspective view.

Click LB on the Camera button in the View Button Area of Perspective OpenGL 2 and the Plan Camera
panel appears. This panel displays which Perspective view the Plan Camera is running for and the colour
of the Camera and Target icons.

Select the colour magenta in the Colour field to display the camera and target, and then select Set.

Important note - leave the Plan Camera panel up because the option terminates when the panel is
finished.

The camera and target that define the perspective view are now shown in all visible Plan views. You may
have to zoom out to see them both.

[ Plan1 3 Plan camers ==l leopencL2  Camera o |[= =
__________ View [z (@) &S S [X) ) ||||||£
Colour [magenta |i|
[valid colour

| Set |  |Finish]  |Help|

target

; .

Holding down LB on either the Camera or Target icons and moving them around in a Plan view
dynamically changes the settings for the Perspective view.

camera

Page 94
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Move both the camera and the target around in the view to see how the Perspective view is linked to the
Plan views.

Notice that if you have the Plan Camera panel up with the camera and target icons showing and then
perform any operation on the Perspective view to change the perspective settings, then the camera and
target icons will move to reflect the new perspective settings. For example, using Fit, Zoom, Pan or Orbit.

However after the other operations are completed, you will need to select the Set button again on the Plan
Camera panel to be able to select and move the Camera and Target icons around.

When the Plan Camera panel is finished, the Camera and target icons are removed form the Plan views.

Note

If you have more than one Perspective view then you can have a set of Camera and Target icons for each of
Perspective view and each set will be displayed on all visible Plan views. To avoid confusion between the
Camera-Target sets, use a different colour for each set.

Although the Camera and Target icon sets are all visible, only one of them is can be active (and hence can
be moved around) at the one time. To make set active, click on the Set button on the Plan Camera panel
for that Camera-Target set.
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6.12

Fast Meshes in Perspective view

We will now see how to quickly display the TIN in mesh form.

From the Perspective View menu, click LB on Toggle =>Tin mesh. You should see a coarse rectangular

grid of red and green mesh lines appear.

-

B " Tin Draw Mesh for View

View

2

Draw triangles mesh

Mesh x |1[|=
Mesh y |1|:|=
Bold x Roo  [af
Boldy |1|;]|:|=

Mesh colour

dark green
dark red

Bold colour

[ values set

T ——

The appearance of the mesh can be improved by reducing the mesh spacing.

Change the settings to those shown in the
panel. Change the mesh spacing from 100 to
10 in both x and y directions and bold x and
y spacing from 1000 to 100. Click LB on
Set to activate the settings.

You will notice that the Mesh can be turned
ON and OFF from either the Draw triangles
mesh tick box in the panel or from the View
menu via the Toggle =>Tin Mesh switch.

Click LB on the Menu button in the View Button Area of the Perspective OpenGL 2 view and then click
LB on Settings => Tins =>Mesh. The following panel will pop up.
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Click LB on Finish to terminate the Mesh settings panel.
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The effect of the creeks superimposed on the TIN (shown above) is created by turning on the Drainage

models. Click LB on the + sign button in the View Button Area and double click LB on survey TOPO

BANK BOTTOM, survey TOPO BANK TOP and survey TOPO DRAIN CL.

Note that 12d always displays the models in the order that they are turned on with the + and - buttons. Thus

to get the effect of survey DRAIN CL (and any other models) superimposed on your TIN, you first turn all

models off, then turn the TIN on first and then any other models to be superimposed last.

The drawing order on a view can also be modified by using the option from the View Menu

Models =>Model order

Model

3 |survey TOPO BANK BOTTOM

1 |survey TOPO DRAIM CL

2 |survey TOPO BANK TOP

4 [tin GROUND

Auto update view

[

Updat:

o

 —
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Note that the Models walk right menu has a number of useful options, too many to have as button in the
View Button Area.

Model Ops "1" ]
Models k
Add model r
Add all models

-

Remove model
Remove all models
Add tin models k
Remove tin models *
Add tagged models [
Remove tagged models *

Model order
Models to front *
Models to back *
Calc extents

For example Models =>Remove all models is a fast way to turn all models off.

The perspective view orientation will stay as it is unless changed by further Joy or equivalent perspective
view operations.

Toggle off the tin mesh via Toggle =>Tin Mesh.




Chapter 6 Basic Modelling

6.13

Fast Contours in Perspective Views
Sometimes it is useful to display contours in perspective views.

You do this using the Toggle button like we did for the Plan view - simply click LB on Toggle =>Tin
Contours.

PerspectfverenGLZ E'@
BEERNEE® a0 K e E

The contour spacing and colours of the Perspective view can be changed just as we did before in the Plan
view. This time however you would click LB on the Menu button in the View Button Area of the
Perspective Open GL 2 view.

As before then click LB on Settings =>Tins =>Contours. See 6.5 Fast Contours _on page 86. for more
details.

Click Toggle =>Tin contours again to revert to the green triangles display.
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6.14  Shaded Views

It is also useful to view a perspective as a colour shaded view.

In a shaded view, the angle that each triangle makes with the sun (a point light source at infinity) is used to
define a different shade of green. The angle of the Sun can be varied but 45 degrees (the default) gives the
maximum contrast.

To quickly shade all the TINs on the perspective view, simply click LB on Toggle =>Shade.

To access the Shade View panel to modify the shade settings, click LB on the Menu button in the View
Button Area of ‘Perspective OpenGL 2 and then click LB on Settings =>Shade.

B ' Shade View = Clicking LB in the Shade tins tick box will toggle on and
. e ——— off the shading. A tick indicates the shade is activated.
iew 2 =

Shade fins Click LB on Set to create the shaded view.

All TINSs in the view will be shaded using the faces in order
furthest to nearest the viewer. This has the effect of
removing faces that are hidden from view.

Angle | Sun position by timel

Angle '45"— Eﬁ

Click LB on Finish to terminate the panel.

L L

Now every time the view is refreshed or the view changed, the shaded view will reappear.

To get back to a green triangles rather than a shaded view, click LB on Toggle =>Shade to toggle the shade
off.
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String Picking Concepts

We will now investigate picking concepts and how the mouse is used to interact with 12d when pointing to
and selecting items on your screen. Initially, do all picking (i.e. mouse clicking) with the LB. This uses the
12d Model Tentative pick. Later we will look at Fast picking using MB (F snap) and Fast Accept (A snap).

In Plan View 1 turn on all the models except the triangulation (tin GROUND).

Check that Point snap, Line snap, Cursor snap and Info are on, and Fast snap and fast Accept) snap are
both turned off.

Cursor snap on / Info on
W (x] (6] (e () (3] (s) @ (2] [£) (A) (] (M)
/V' \

Point snap on Line snapon  Fastsnap off fast Accept off

Zoom in to the left dam. Your overall screen layout including the ‘Plan 1’ view should now look as shown

below.

Whilst the string picking concepts are used throughout 12d, especially during construction of design
features where we want to connect into existing geometry, we will learn about them by example through
the relatively simple String Inquire feature.
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7.1 String Inquire

String Inquire is used to inquire and view the details of a typical line (i.e. string) that is already present in
the View. From the Main menu, click LB on Strings=>Inquire to bring up the following panel.

NOTE: the String Inquire panel can also be brought up by pressing the F2 key. This has been defined in
the standard 12d Model function key short cuts (userkeys.4d).

B " String Inquire |L|é]
Click LB on Pick and then move the cursor anywhere over

| one of the bank strings and click LB (press and release LB).
[ Pick | [Finish| [ Help |

If you placed the cursor over a line segment
between two vertices:

you should see the string go light yellow and
a yellow square box appear at the location
where you clicked LB.

If you placed the cursor over a vertex at the
end of a line segments:

if you happened to snap to a vertex rather
than a segment, you will see the string go
light yellow and a yellow diamond appear at
the location where you clicked LB.
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Information 2
In either case, an Information panel will pop up as shown at right F_“l_;;:D_”F”eInput
(provided the Info snap is ON - See.7.4 Snap Settings on Option = Red 12d Solutions Archive Data
page 105.). It reports such information as the name of the Model Date = 24 October 2014
which contains the selected string (survey TOPO BANK TOP), the Time = 00h 56m 02=

string name (TBR), the type of string (Super), colour and linestyle. The ~ General

number of points in the line are also returned along with it’s length.

Model = survey TOPO BANK TOP
MName = TBR

The x, y and z coordinates are those of the string where the pick Sy =

occurred. And in this case the panel shows that the string was accessed

Type = Super
Colour = orange

via a Point snap. Line style = BL

If you move the cursor away from the string and pick with the LB again,

Pt/line = line
# pts = 7

you will notice that the Information panel changes, the string goes back & itributes = 1
to its original orange colour and the cursor is now replaced with a light  Length = 58,637

yellow circle. Vertex id = 2288
Locks = Read (-1)
Point snap =
* = 42530,675
¥ = 36966.239
Z = 66.278
- Prof ch = 43.068
Information P Prof z = 66.278
General Bearing = 269°41'40.64"
Cursor snap = +VE =
X = 42529669 ] . .
Vo 3607250 Ll This sequence may seem strange at first. What has happened is
+ve= that the first pick located a string within snapping distance of

the cursor so the string highlighted in light yellow and the
Information panel for this string popped up. The pick location
showed a diamond to indicate that a snap to the nearest vertex
had occurred. 12d is in effect asking you ‘Is this the string you
want?’. To reject the currently highlighted string, without
moving your mouse, simply pick with LB again.

The last pick couldn’t find any more strings to snap to (adjacent strings were outside snapping distance)
and so no more information panels popped up. Instead, a circle showed at the pick location to indicate that
a snap to the cursor location had occurred. That is, the only thing that 12d could find at the pick location
was the cursor.

The above sequence will only happen this way if Point, Line and Cursor snaps are on. See below for more
about snap settings.

Now if click LB a number of times on the same string without moving your cursor, you will end up getting
the light yellow circle indicating a cursor snap.

The reason for this is that when you click LB the first time, 12d finds all the strings and pick types in the
picking distance of the cursor and highlights the closest string with the closest pick type.

If you click LB again without moving the cursor, the next closest string and pick type is displayed. And
if click LB again, the next closest string and pick type is displayed. This continues until there are no strings
left that have not been rejected by clicking LB again.

The purpose of this behaviour is so that if there are (say) three lines on top of the other, it is possible to
sequentially snap to each one in turn by looking at the Information panel details as you perform each LB
mouse click. Even with the one string, the closest snap point may be a line snap, and when you click again
you may get a Point snap on the same string.

The fact that we could only snap to one string confirms that there is only one string present at this location.

A quick method of restarting a pick sequence is to move the mouse (i.e. cursor) a short distance from the
last pick point. The picking mechanism is then reset and all strings can then be picked again.

The next section shows how the mouse buttons can also be used to restart a pick sequence.

To terminate the String Inquire, click LB on Finish in the String Inquire panel.
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7.2

7.3

Use of Mouse Buttons and Enter Key when using Tentative Picking

The three mouse buttons and the Enter key all have a function when picking strings. Those functions are

LB - Left Button Select the nearest string

MB - Middle button Accept the current highlighted string. This will also terminate the
current pick sequence.

RB - Right button Bring up the Pick Ops menu

Enter key (<Enter> Accept the current highlighted string. This will also terminate the

current pick sequence. This is the same as MB and is very useful if

you only have a two-button mouse (not advisable).

Pick Operations Menu via the Right Mouse Button

We will now focus on the use of the RB. Repeat the above picking sequence but now after getting the
yellow square cursor (i.e. picking the string), click the RB and the Pick Ops menu will pop up

PickOps  [2]
Segmentd » . . . . .
Click with LB on Restart. This resets the pick sequence to start over as if the
Accept previous pick sequence had never occurred.
Restart If you now click on the string with LB, you will notice that the string can now be
Typed input picked again with the LB. The lesson here is that if you ever get confused during a
picking sequence, the picking operation can be reset and start over again by either
Find by name moving the cursor a given distance or click RB to bring up the Pick Ops menu and
Info select Restart.
Vertex ID
Chainage
-(n) points
+(n) points
Intersect
Perpen
Snaps Cad »
Cancel

The Accept menu item needs special mention. During a picking sequence, once you have located the string
you are after, you normally terminate the sequence by clicking the MB. This accepts the current string and
terminates the pick sequence.

The Accept menu item has the same function as clicking the MB during the pick sequence i.e. it is used to
indicate to 12d that the string found is the one that you wanted. If you are using a 2-button mouse, this is
another way around the lack of the middle button (using <Enter> for accepting was described in the
previous section). You can accept a string by using the RB to bring up the Pick Ops menu and click LB on
Accept. If you have a 3-button mouse, it is easier to use the MB to accept the string directly.

The Info menu item also has a special function. The Information panel that pops up when a string
highlights is only displayed temporarily. If you move the mouse cursor a small distance, the information
panel will disappear. This occurs even of you don’t click any mouse buttons. The Info menu item is used to
pop up the Information panel (again) for the currently highlighted string.

The Cancel menu item is used to terminate many of the operations that are recursive. For instance when
creating a string, 12d assumes that it will involve multiple line segments so it stays in create mode after
each segment is placed. After the last point on the string is placed, use the RB to pop up the Pick Ops menu
and click LB on Cancel to terminate the creation.
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7.4

Snap Settings
In the context of String Inquire, the snap settings are used to selectively choose from 12d data sets when
inquiring on existing items. The snap settings can be toggled on and off from the snaps toolbar.
( Snaps toolbar  [BJ (L] (] [6] €] (1] (7] (s] (@] (o] (F] (a] (] (m] >

If you are new to 12d, it is easiest to first stat using the full snaps menu until you get used to the
abbreviations in the Snaps toolbar.
To bring up the full Snaps menu, click LB on Utilities=>Snaps=>Snaps.
On the Snaps menu, at any one time each snap setting is toggled either ON or OFF. If a tick appears, the
snap setting is toggled ON. The settings shown are the default settings when starting 12d.

Snaps ]

Point 7 At this stage we will focus on 4 of the first 5 boxes: Point, Line, Grid and Cursor.

e 7 Upon a successful snap, each snap type returns a unique appearance.

Ted Point Snap - diamond

Zrl Snaps to the nearest point or end of line

Cursor v .

Height Line Snap - square .

Tin ™ Snaps to the nearest line

i Grid Snap - circle

Segment Snaps to the nearest grid intersection point

Name ""

Madel " Cursor Snap — circle

Tolerance 50 Snaps to the mouse cursor (X,y) position. This is used when drawing freehand.

Pt tolerance 10

Info v

Data tip

Fast pick v

Fast accept

Fast cad ¥

Display many
To change a snap setting, click LB anywhere from the snap name text to the snap tick box. The setting will
toggle ON or OFF.
As shown above, it is possible to have multiple snap settings on simultaneously. For instance, if you want
to be able to select a string on either the segments of the string, or the vertices of the string (the ends of the
segments), you need both Point and Line snap ON.
You can generally leave Cursor snap ON. Most times, if all other snaps fail or are not set, you want the
mouse cursor position returned. This is useful when free handing into 12d strings that are not connected to
existing features e.g. the centreline of a new road. If you don’t have Cursor Snap ON, you will get a Failed
Snap error message whenever all other snap settings fail.
Near the bottom of the Snaps menu is an Information tick box labelled Info. If this box is NOT ticked, the
Information panel will NOT pop up as each string is selected.
Above the Information tick box is the menu item Pt tolerance 10. This figure indicates the current point
snap tolerance setting is 10. To change the snap setting, click on Pt tolerance 10 with LB and the
following panel pops up

® ' Point Snap Tolerance | =] ihJ
S The point snap tolerance is measured in screen pixels. In
Tolerance 10 1024 resolution, a point snap tolerance of 10 represents

about one hundredth of your screen width. If point snap is
[ Set | [Finish| [Help| set, then the closest vertex within this distance of the cursor
will be selected.
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e A N

To change the tolerance, lock the cursor in the Tolerance field by highlighting (double clicking on) the
existing text, press <Delete> and type a new Tolerance value. Click LB on Set to activate the new setting.
Click on Finish to terminate the panel.

Similarly for the Tolerance menu item - click on Tolerance and the Snap Tolerance panel pops up

NOTE - When Point snap is set on, any vertex of a string within the point snap tolerance box around the
cursor when LB is clicked, is considered for selection before any other type of snap is considered. Centres
of circles, centres of arcs and arc end points are considered to be vertices.

When Line snap is set on, the cursor only needs to be within the snap tolerance distance of any visible
segment of a string when LB is clicked, and that string is considered for selection. Also arcs and circles are
considered for selection.

point snap
tolerance

(e snap positon

|
| ﬂhis vertex is selected rather
|
|

than the line snap position
because it is inside the
point snap box

L - _l

\ Point Snap Box and Snap Box /

In the area between the point snap box and the snap box, vertices and line snap positions are treated
equally and the closest one to the cursor is selected.

As you use 12d you need quick access the turning snaps on and off but it is not that often that you need to
change the other settings. So rather than having the large Snaps menu on display at all times, the Snaps
toolbar and Snaps (Vertical) menus are available as abbreviated forms of the full Snaps menu. They take
up less room on your screen and hence are useful to the experienced user.

The Snaps toolbar is normally in the top section of the screen but if it has been deleted, it can be brought
back again by clicking on View =>Toolbars to bring up the Customize Toolbars panel and ticking on H (for
Horizontal snaps).

¥ Customize toolbars El = @ »fl, Customize toolbars El = @
[ | Attributes L Scroll down until [ Design ~
(V] Attributes ControlBar = the H tick box is [C]Display
[¥] Cad isibl d turn it [ Drainage
[]Cad Arc Vist _e an mi [|Drainage 2D
[]Cad Circle to a tick (| Explorer
[¥]CAD ControlBar [ | External Apps 3
| Cad Delete (V] Global =
|| Cad Dimension
] Cad Fill [ |Input
[ Cad Hole [ |Label .
[ Cad Image - [ Measure edits
(V| Measures
[|Maodels Add Remaove -
|
Finish |
Finish
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The Snaps toolbar will then appear on the screen

() [ (x] (e) (el () (7] () @ (o) [E] (A (] (]

Similarly selecting Utilities =>Snaps =>Snaps (vert) on the Main Menu) will bring up a Vertical snaps
menu. Unlike the Snaps toolbar, the Snaps Vertical menu can not be docked.

Point

Line

Text

Grid
Cursor
Height

Tin
Segment
Info

Data tip
Fast pick
Fast accept
Fast snaps cad accept
Lists all strings within
snap tolerance

Snaps Vertical menu

E

el IE=E =R - EE

() (x]) (6] (& (r) (1) (s) @ (0] [E] (A (] (m]

Snaps toolbar

At any one time each snap setting is toggled either ON or OFF. For the Snaps toolbar and the Snaps
Vertical menu, the snap setting is OFF when the button is depressed or appears clear and ON when the

button appears raised or blue.

To practice this further, do a Fit on your current View. Pick a feature in the view where lots of lines meet

and without moving the mouse, do a series of String Inquires by repeated use of the LB and observe how
12d will snap to adjacent items near to the mouse cursor. Note the cursor shapes returned that indicate that
sometimes you are getting a Point snap and sometimes a Line snap.

Remember points are just a special type of string.

Page 107
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7.5

7.6

7.7

Models and Snap Settings

Whilst it may appear obvious, it is important to remember that you can only snap to data that is currently
on display. Models that are currently turned off will not participate in the selection process during
snapping. If you find that you are snapping to unwanted items, consider turning off models that are
irrelevant to your current operations

Fast Picking Snap (F)

If Fast Snap (F) is on, instead of clicking LB to select a string, click MB or press <enter>, and the nearest
string to the cursor satisfying the snap conditions is selected.

Hence using MB alone replaces a LB followed by an MB.

Note: If you are using F snap then you get the first string only.

Fast Accept Snap (A)

If Fast Accept (A) snap is on, then if there is only one string that satisfies the snap conditions, then that
string is automatically accepted.
However if there is more than one string then the normal snap selection is followed.

Note: A snap is a good compromise - if there is only one possible string then it is immediately accepted. If
there is more than one possible string, then you get the choice to select which one.
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Modifying the String Highlighting Colour
12d has various default parameters for the display of data including the string highlighting colour. This is
the colour a string is changed to whilst it is selected.

The default highlight colour is white but this is not be very useful if you want to draw strings in white, or if
you use a white background colour. In either case, it is important to change the highlight colour to a colour
other than the white.

To check the highlight colour for the project, we select from the main menu Project => Management =>
Defaults and the Defaults panel pops up.

"B Defaults =] @ (=

Trash Settings ] MName Settings | Defaults.4d |

Default Settings | System Settings l
Colour ﬁ[j
Paint colour [yellow D
Tin colour Igreen— D
Contour colour Icyan— D
Contour beld colour Iblue— ‘:J
0 null height E
Text height (pixels) L E

F
Chord/Arctolerance o1
Culling
Culling size (pix) I4—
Corner angle b=
Weed tolerance b
Section view exagg w
Perspective view exagg Il—
T I—

Cut volume sign negative

Use density drawing

Set Finish Help

From this panel, the user can change various parameters for this project that 12d uses for calculations,
display and data handling.

To change the default highlight colour, select the Systems Settings tab by clicking LB on the Systems
Settings tab.
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The following panel should appear:

I8 Defaults =] =

Trash Settings ] MName Settings | Defaults.4d |

i

Default Settings System Settings
Angle mode W Ed
Length system ’W EJ
Angular systermn 360 =" E]
Cross size (pixels) E
Cross size (mm) ’15— I
Highlight cross size -
Highlight cross colour  [gff yellow D
Highlight colour [off yellow D
Display colours b0
Save interval {min) ’15— ‘i]
Points per string oo
Display precision E
Box precision “«
Fermula precision e
Popup length s
Display reports Display edit info
Print reports Plan crosses [l
Send plots Function results

|
[ set | [Finish| [Help |

Note that the Highlight colour is set to off yellow.

To change this, LB click on the colour icon adjacent to the Highlight colour input box and select another
colour such as cyan from the colour choice box. Then press Select on the colour choice box panel. Colours
can more quickly be selected from the choice box by double clicking LB on the desired colour - the Select
button is not required.

To set the current values for the defaults press the Set button.

NOTE: When a new project is created, the values in the Defaults panel are loaded from the set-ups file
defaults.4d which 12d Model looks for on start up in the standard 12d location (for more information on
the search order, see 43.2.7.3 Defaults File (defaults.4d) in 43 Setting Up & Configuring 12d in the
context sensitive 12d Model Reference manual). For an existing project, all the values in the Defaults
panel are saved with the project so if any have been changed in the project after the project was first
created, then the defaults for the project will differ from those in the defaults.4d file.

If you wish to keep the current defaults for a project to use as the initial defaults for future new projects,
you can save the file defaults.4d to a suitable location by clicking on the defaults.4d tab and then the
Write defaults button to bring up the Write Setup File "defaults.4d"panel.
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-

“fl, Write Setup File "defaults.4d” o] @ |23

Found folder (Read only)

ChProgram Files (x86)\12d\12dmodel11.004set_upsidefaults.4d

@) Current folder

Ch12d\Moved\ Training_cld\design'getting started basic\STAGE 1

User folder

COther folder

[C:\12d\Moved\ Training_old\design',getting started b

| Write | |F‘r0perties| | Finish | [ Help ]

Specify where you wish the defaults.4d file to be saved and then click on Write.

In this example select Current folder. If you wanted the changes to apply to any new project you create
then you would select User folder and it would save the changes to the User folder.

Click on Finish to close the Write Setup File "defaults.4d" panel, and then Finish on the Defaults panel.
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8.1

Creating Strings with CAD

We will now investigate creating strings using the CAD options. We will create points (one point strings), a 2
point line (single segment string) and a line string (multiple segments in the string).

First we will create a new plan view to work in.
From the main menu, click LB on Views =>New =>Plan. This will create View Plan 3.

Maximise the view by clicking on the Maximise icon on the top right hand corner of the view or by double
clicking on the plan view title area.

Minimise Maximise
ESRERE)

Close

Creating Points

The CAD options to create points, lines etc can be done by using the main menu system or by the use of the
CAD toolbar, which is displayed on the left of the screen at start-up. Regardless of the method used to
activate the CAD commands, the CAD controlbar as outlined on in 4.5 Toolbars and Controlbars on
page 38.will be used to define the characteristics of the created elements. We will change the values in the
controlbar as follows.

name colour linestyle tinability

[m] [cap (] [red | NS A Z | Bl (=2

model height weight same as

Click LB in the model field and type in CAD. Click LB on the colour icon and choose the colour red from the
choice box by double clicking on red in the pop-up list of colours. Enter 20 into the height box and leave the
linestyle type as 1.

Note: We are only using red because it will show up on a white background in the images. Use whatever
colour you prefer.

To create a point string (i.e. one vertex string) we will use the CAD toolbar flyout. Pick the points section of
the toolbar by clicking LB over the CAD Point symbol and keep LB depressed.

H#M“f**ﬁﬁ&@ﬂmiimmw#ﬁwﬁt
T

— ——=— — — — — —— —— —

The points flyout menu is displayed which has all the options in the points section of the CAD creation tools.
This is displayed as a horizontal bar consisting of all the icons that make up all the options in the points section
of the CAD tools. Whilst holding down LB move the cursor over each of the icons and the tooltip function
tells what each of the options does.

To select an option, keep the LB depressed until the cursor is placed over the specific option you want and
then release the LB. We will select the Point option which is the first icon in the flyout.

&

T =]

a
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On selecting the Point option, or any other CAD option, the user is prompted for the relevant data in the
screen message box located on the bottom left hand corner of the 12d Model application window

|2 Els
Pick position= [picks] [fast] [Menu]
/{ Output Window |

( Message area

The user can select a position with the mouse and on accepting that point (Middle mouse button or enter)
the point is created at the selected position. The model, colour, height etc. are defined in the Cad
Controlbar.

The snap mode will influence the mouse selection. For example if Cursor snap is on, the user can choose a
position not yet defined. If Point snap is on and the selection snaps to an existing point, the option will
place another point at that location.

Ensure that the Cursor snap is activated in the Snaps toolbar. Click LB at a position roughly in the middle
of the view.

Information @

General
Cursor snap =
X=-10.745
¥ = 57.804
+ye =

Click MB. The point is then created with the model CAD being added to the view automatically.

Plan 3 ===

To see the height of the point we must toggle on the Z values. To do this click LB on the toggle button on
the view menu to bring up the toggle menu. Then click LB on the Z values [off] position.

Don’t walk right on the arrow near this position - this is to specify individual models to turn the Z values
on or off. By clicking LB on the Toggle menu, you turn on (or off) all Z values in that view for all models.
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e o = e
B[] (=) @[] [X) [@&) (&) [ ][] [m] [E]

Toggle "3”
Culling [off]
Linestyles [on]
Sewer [off]
Text [on]
Vertices [off]
Vertex indices [off
Z values [on]
String names [off]
FP Attributes [off]

+ Arc centres [off]

. Tin contours [off]
The Z value is shown near Tin edges [off]
the point that we created. Tin flow [off]

Tin =olid [off]
Grid [off]

Rasters [off]
Clouds [off]
Vertex/Segment UID's [off] »
Point id's [off] 3

Click LB on
Z values

* w\v ¥ El

* v

The default colour for the height text is yellow but to make it clearer on our white background, we will
change the text colour to red (as depicted in the image above).

To change the colour of the height text, click LB on the menu icon from the Plan 3 View menu to bring up
the Plan View menu. From that menu click LB on Settings =>Z values =>Single to bring up the
Z Values for Plan View panel.

From this panel, for the Draw textstyle data field, select the Textstyle Data icon and then click on [Edit].

— Select Textdata =
"B Z Values for Plan View =] @ (==
View [

Arial1 centre -
Arial 2 centre
Catchment Label
Dimension 2.5
Dimension 3.5

Grid Text

1501 centre

150 2 centre

Label Easting

Label Morthing

Label Point Mo
SAlgn Data

SAlgn Header

SAlgn Title

Text 1.5mm

| default values retrieved Text 10mm

Text 2.5mm

[ Set ][Size max] [ Reset ] [ Finish ] [ Help ] Text 3.5mm

Text 5.0mm

Text 7.0mm

Text Box1.5mm

Text Box 2.5mm

Text Box 3.5mm

Text Box 5.0mm

Text Box 7.0mm

Text Whiteout 1.5mm
Text Whiteout 2.5mm
Text Whiteout 3.5mm
Text Whiteout 5.0mm
Text Whiteout 7.0mm

Draw z values

Draw textstyle data ["1" yellow 8

BR -0

Plot textstyle data |2

Height max (w) o

Decimal places 3

Show null z's

m

[ Select

——
[Sameas]
[Clear]

Click on [Edit]
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"fl. Draw textstyle data IEI & @

Favorites

Text style

|

Colour

_,
m
o

A

Height (u)
Offset (u)

Angle

| Set | |Sameas| | Clear | | Finish | [ Help ]

Change the Colour field to red and then click Set and Finish to close the panel.

Finally click Set on the Z Values for Plan View panel and Finish to close the panel. The colour of the
height text will then be red.

The change is made only for View 3 and when any other points are added to the view, they will also have
their height text shown in red.

There are various ways of selecting a position when creating a point. For the first point we just selected
anywhere on the view.

Specification of a position can also be done by the direct input of the xyz coordinate of the point.

Select CAD Point again to begin creating a new point and when over the view either press the space bar or
start typing the x value and the Enter XYZ panel will come up.

The user then enter the X, Y and Z values into the box each value separated by a space. e.g. 200 150 40. As
we have already set a Z value in the CAD controlbar, you only have to specify a X and Y value into the
box. NOTE: The Z value will default to the value entered into the CAD controlbar whether or not it is
specified in the XYZ box. If no height value exists in the CAD controlbar or the XYZ box, then a value
will be interpolated if possible, otherwise a 0 value will be assigned.

We will again create a point by using the CAD toolbar.

Firstly, change the Z value in the CAD controlbar to 50. Then repeat the steps outlined above to choose
the CAD Point option. Instead of selecting a point with the mouse we will type in the coordinate values.

To pop up the XYZ box, press the spacebar. Then type into the box, 200 100 and then press <Enter>. We
did not have to specify a Z value in XYZ box as it was already defined in the CAD controlbar. NOTE: A
space must be placed between the X and Y values.

B EnterXYZ: .

Enter XY Z: |;'_m] 1nu| ‘

A new point is created. Click LB on the Fit icon on the view menu @\ to fit the data in the view.

It should now look like as shown below:
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Plan3
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8.2

Message area

Creating Two Point Lines

We will now create a simple one segment line. To do this we will again use the CAD toolbar but this time
use the CAD Line flyout.

Pick the Cad Line section of the toolbar by clicking LB over the CAD Line symbol and keep LB
depressed.

X | mm = @ e on @ AT
|7|ff_i_.<::?g:a:w.-_»z}—‘5

10T

The Cad Line flyout menu is displayed which has all the options in the lines section of the CAD creation
tool. Select the 2 points option which is the first icon in the flyout.

On selecting the 2 points option, the user is prompted for the relevant data in the screen message box
located on the bottom left hand corner of the 12d Model application window

[FREE

=[Pick first position] (t)angential, (p)erpendicular, (cJusar, Jtype= [picks][][Menu]

We will pick a position with the mouse to define the start of the line. Pick a position with LB about
halfway between the two existing points and then MB to accept. After accepting the start point, the user is
told in the message area to pick the second position (the end of the line). You will also notice when you
move the mouse around that a line is drawn rubber banding to the cursor position.

We now select a point going south east to define the end of the string with LB and MB to accept. The
created string will be shown using the parameters given in the CAD controlbar at the time of construction.

Lol

+
&

oo




Chapter 8 Creating Strings with CAD

8.3

Creating Line Strings
We will now create a multi-segment string.

Although we could use Line String option on the CAD Line flyout, this time we will use the CAD menu
from the Main Menu system rather than from the CAD toolbar

From the Main Menu, click LB on Cad =>Line =>Line string. The Line String option will now be
running. NOTE: These CAD options have no panels.

On selecting Line String the user is prompted for the relevant data in the screen message box located on the
bottom left hand corner of the 12d Model application window

|2 Es
Message area ——— g <Pick start position for string> [picks] [fast] [Menu]
| output Window |

We will pick a position with the mouse to define the start of the line.

Pick a position with LB any where on the view and accept with MB. Then move the cursor to a new
position and pick and accept a second point. Pick and accept a third point and so on.

To finish the string simply press <Esc> on the keyboard, or alternatively RB to bring up the Pick Ops
menu and then select Cancel from it

The string will be created using the parameters given in the CAD Controlbar at the time of construction.

&b

"'If®
+

@CD

This has given a small introduction to the use of the CAD options. For a more detailed explanation of these
tools see the chapter CAD in the 12d Model Reference manual.

We will now finish this section by deleting the current view. As the view is maximised, select
View =>Delete and select view 3. Alternatively, we could have restored the view and clicked LB on the X
icon at the top right of the view.

This should then leave two views, Plan 1 and Perspective 2. If either Plan 1 or Perspective 2 are left
maximised, select the restore button on the top right hand side of that view to leave two views as they were
at the start of this chapter.

Clear the value for the default height in the Cad Controlbar. Leaving the height there may create problems
when creating strings at a later stage. Also change the default model to one of the existing survey models
as we will be deleting the CAD model and don’t want it being created again.
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Finally, to delete the CAD model click LB on the Delete model option from the Main Menu
Models =>Delete =>Delete a Model.

This brings up the Delete Model panel

"B Delete Model =N =l
Model ||

Permanently delete? ]

| Delete | | Finish | | Help |

Select the Model icon with LB and then double click LB on CAD.

Tick on Permanently delete? and then click on the Delete button, and answer Yes to the confirmation
panel for Delete Model.

Delete Model 3

| 1 You are about to delete 1 Model from the project

4

THEREIS MO UMDOQ FOR THIS OPERATION

Delete from the project ?

This then deletes the model from the project.
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9.1

Basic Road Design - Centreline String Creation and
Editing

We will now begin our first Road Design with 12d. Before we can begin, we need to review other
techniques for getting data into 12d.

By use of the Snap settings, we have seen how to snap to existing points and lines. This is useful when
inserting strings into your model that must exactly join existing strings. There are times however when we
wish to place a feature in the model exactly by absolute or relative coordinate entry. We do this by typed
input.

Typed Input

In general, whenever 12d is prompting you for a cursor pick in a Plan view, you have the option of either
Clicking LB with the mouse to return the x and y coordinates OR
Typing the x, y (and maybe z) coordinates

To enter typed coordinates, you simply start typing, or click RB and select Typed Input from the pop up
list. A Typed Input panel will pop up as you begin typing.

B EnterXYZ: L&_J

Enter XY Z: | |

If you wanted to enter the coordinates of the point (100,200,50.5) you would type

B EnterXYZ: [

‘Enterx ¥Z: [10020050.5 |

Just separate the values with a space between each item. Terminate the entry of data from the keyboard by
pressing the Enter key (<Enter>). If you only supply two values and press Enter, 12d will assign a Z
coordinate of zero.

If you ever accidentally touch a key when performing cursor input via the mouse, the Typed Input panel
will pop up. To remove it so that you can revert to cursor input, backspace over any digits that appear in the
input window until the field is clear and press <Enter>. The panel will disappear.

Whilst there are also other ways of entering typed input e.g. by bearing-distance, relative xyz increments
etc. we will not pursue these at this time.

For example, it is possible to turn on a grid and with the appropriate grid snap setting, snap to only the grid
points when entering points and strings. We will look at the grid at the end of this chapter. See 9.6 Using a
Grid to Assist in Coordinate Entry on page 146.
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9.2  Horizontal Geometry (HG) Edit

Before creating an alignment string, we’ll first set up our views the way we want them.

For the View Plan 1, click LB on the Menu button in the View Button area (or click RB in the View Button
Area) and the View menu will pop up. Click LB on Models=>Remove All Models.

Then in the View Button Area, click LB on the + sign button and select all survey models EXCEPT the models
survey TOPO SURFACE LEVEL and survey STN.

From the Snap Toolbar, turn all Snaps OFF except Point, Line, Cursor, Information, Fast pick and Fast snaps
cad accept.

In View Plan 1, click LB on Fit. Your view should look like:

We will now bring up the Super Alignment panel and look at some of the features prior to creating the
alignment

From the Main menu, click LB on Strings =>Super alignments =>Create super alignment. The Create
Super Alignment panel will appear
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Click on the General node

The General node deals with the basic features of the alignment appearance. The super alignment is given
a name and model along with other standard features such as colour, linestyle and weight.

l:ﬂl Create Super Alignment

= Basic

- Chainage

. Interval

- Label

. Transition
- Closure

- Synec

.. IP defaults
=) Advanced

. Start

. End

.. Design

- Profiles

- Equality
- Pipe/culvert

Name
Model
Colour
Haorizontal linestyle

Vertical linestyle

Comment

e
= = Fill out the panel as shown.
These settings tell 12d that
our new road centreline is to
be called RS and it is to be
placed in a new model called
ALIGNMENT.

| name <RS1> ok

(itany )

[SEme as]

| Finish | [ Help |

Click on the Chainage node

ofl! Create Super Alignment ] & | The mode option allows the
user to set where the chainage is
=) Basic
S eenena Control chainage o to be measured from.
M Chainage| Mode [tartpoint =
. Interval stost point = Select Choice @
. Label start point
- Transition d int
- Closure End poin .
- Sync control point
- IP defaults start part
=) Advanced end part
.. Start
..End
.. Design . . .
- Profiles With the given settings, the road
... Equality will start at chainage 0 and the
- Pipe/culvert chainage will be calculated from
the start point.
|
[Create] [ Many ] [Same as] [ Finish ] [ Help ]
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Click on the Interval node

.

;ﬂ: Create Super Alignment

= Basic

.. General

- Chainage

- Label

.. Transition
. Closure

- Sync

.. IP defaults
= Advanced

.. Start

.. Design

- Profiles

- Equality
- Pipefculvert

Haorizental
Chainage interval

Vertical
Chainage interval

(o =[]

10

10

[ Create ]

[ Many |

Same as|

[ Finish |

| Help |

Click on the Label node

.

:a: Create Super Alignment

=} Basic

.. (3eneral

.. Chainage
- Interval

M | abel

.. Transition
.. Closure

- Synec

.. IP defaults
= Advanced

.. Start

.. End

- Design

- Profiles

- Equality
. Pipefculvert

Label style

Major interval

(= = [ =]

R
R
—
—
B

[ Create ]

[ Many ]

[Same as]

[ Finish |

| Help |

The optional Horizontal and Vertical
chainage interval is used for a sample
interval which can be used if
triangulating the alignment string.

As a general preference the design
strings created from the apply many
are used in the tin instead of the
alignment string

The interval is also used to create
vertices on the string when exporting
to another string type

The Chord-arc tolerance adds
additional chainages where the
perpendicular distance between the arc
and a chord drawn between the points
exceeds the input value

If left blank the defaults are 10 metres
for the intervals and 0.1 for the chord-
arc tolerance

Set the label style to full to see both
horizontal and vertical tangent
points and other features

Type in 10 for the Major interval
which says that labels will be
displayed every 10 metres.
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Click on the IP defaults node

#l. Create Super Alignment =8 H=l === 7 gl Select Choice o] ® |z
[=- Basic HIP
- General Type Curve radius A Curve speed
- Chainage Curse radius l—@ B Curve radius
- Interval I - . 3 }‘" Curve length
Label pproach lengt
- Transition Depart length [ Select ]
- Closure
- Syne vip [Sameas]
WP defaults Type Curve length 2
= Advanced Length b
- Start ) \
- End f—— , —
- Design il Select Choice E\ = @
- Profiles .
. The default horizontal and

Aty vertical IP curve information {\ Curve speed
- Pipe/culvert B Curve radius

can be set L* Curve length

(“!\ Asymmetric
| [ Select ]
[Create] [ Many ] [ Finish ] [ Help ] [Sameas]

y

Click on Create and the Super Alignment Editor for RS1 will appear.

Edit SA ALIGNMENT->R51

{Fl‘ij‘%n\f“‘(‘miﬁ .i XHEJ?JJ

It is suggested that you move the Super Alignment editor, the Edit SA menu (or Edit SA toolbar) to
the top right of your screen to get it out of the way when creating your new centreline.

To move the Edit SA menu, press LB somewhere over the words ‘Edit SA ALIGNMENT....." to
pick up the menu, move the cursor and pin the menu down by releasing LB.

We will initially define the horizontal alignment of the road in the View Plan 1. We need to tell 12d
that we are defining Horizontal Intersection Points (HIPs).

To select options from the Edit SA menu hold down the left button over the relevant icon (Add/
Remove IPs) on the toolbar to activate a drop down menu.

To select options from
the editor panel hold

Edit SA ALIGNMENT-=R51

e, P LB B IYODR ! J 7 v,

down the left button
over the relevant icon
(Add/Remove IPs) on
the toolbar to activate a
drop down menu.

e

o
{Eﬁppend HIP i

e

.~ Click LB on the relevant icon.

The data tip displays for a few
seconds which is used to select
the required option

Click LB on Append HIP
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12d is waiting for you to select the starting point of your road. You can choose to either (1) select an
existing point (2) enter coordinates exactly or (3) freehand in the points

Plan1 =N Eoh( 1

Zoom in to the intersection in

the top right of the data and ~
click LB on vertex at the

intersection of the road crowns

Type the X and Y coordinate in turn for the next two IP points:

B Enter XY Z:
‘Enterx‘r’z: 42697941 37350926 | 1P 2 IP 3
X =42697.941 X =42552.804
5 Enter XY 7: 5% Y =37350.926 Y =37099.542
Press <Enter> Press <Enter>

‘EnterXYZ + [42552.804 37099542 |

If you do a Fit on the view you will see the three HIPs already entered and the alignment rubber bands to
where the cursor is as the possible next HIP. We will position the last HIP at the intersection of the roads in
the bottom right corner.

Plan1 o -E )

14

roposed end
of alignment
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TERMINATING THE "RUBBER BAND"

The last HIP is the intersection of the
roads in the south east corner.

Click on the intersection and accept
the position. After the fourth HIP is
defined, it will remain rubber banded
to the cursor.

Pressing the Esc key (<Esc>)
terminates the String creation process
and removes the rubber band. Your
centreline should now comprise of
four points connected by three
segments.

On doing a Fit, your view should now look as shown below.

Note that in the images the labels for the Super Alignment are shown in red instead of yellow so that they
are visible on a white background.

Don’t put the Edit SA menu away yet as we will need it further. Just leave it in the view. Remember this
menu is referring explicitly to the Alignment we are currently creating (ALIGNMENT =>RS1).

To make the road alignment easier to see, we will turn off all the survey models except the survey ROAD
CROWN, survey ROAD PAVEMENT EDGE and survey TOPO TIN BDY.
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"l plan1 ===

We will now put in some
horizontal curves between the
HIPs. We will insert a curve of
radius 200 at HIP 2 and a curve
of radius 100 at HIP 3.

From the Edit SA menu, click
LB on Move/Edit icon then

Change C select Change Curve

The Screen Message Box area advises
<Pick IP to change curve info>[picks][Fast][Menu]
Click with LB in the vicinity of HIP 2 and MB to accept the highlighted HIP.
A panel will pop up prompting Radius. The cursor should already be locked into the data field.

B | Typed Input IJ?—J

- Type 200 and then press <Enter>
Radius |2|:|U |E]

Observe that a horizontal curve of radius 200 is now inserted and the tangent points have symbols and
chainages with user defined prefixing e.g. TC for Tangent Curve.

The insertion of curves is setup to handle multiple insertions. If you now position the cursor in the vicinity
of HIP 3 and click with the LB, accept with MB, type 100 for the new radius and press Enter, a further
radius will be inserted.

To terminate the radius insertion process, press <Esc> (or click RB to pop up the Pick Ops menu and click
LB on Cancel).
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Your plan view should now look as follows.

We’ll now look at interactively obtaining information about the created Super Alignment.

To do this, click on the Information icon on the Edit SA menu.

Edit SA ALIGNMENT-=RS51

o, b, L5, B € V@R ! % ? v,

This brings up the Super Alignment Info panel that displays information about your string geometry. If
necessary, move the panel away from your road centreline.

:ﬁi Super Alignment Info |E
B Selection -
Style Standard =
Chainage 307.0444 =
Dynamic on F
E Genera
Model ALIGNMENT e
MName RS1 ® |
Colour red [ | 3
Style full =]
Points 6
Length 950.064 I
E Point
Xcoord 42703.31 J‘E—
Yeoord 37336421 J‘E
Angle 220°19'55" 2
Mamed Part e
B Static
Level J‘E
Grade J‘E
El ey
Type arc e
Length 145993 e
Radius -200 J‘E
Offset JEE
= -
Type
ranrnant hne
Page 129
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Move your cursor along the new road and you will see the information in the panel change. The panel
shown was created by pointing at HIP 2. It gives you the coordinates of the cursor dropped onto the road
centreline along with the instantaneous direction, arc length and radius.

Click LB on [X] to close the Super Alignment Info panel.

To complete our new road, we now need to define its vertical geometry but to do this we first need to
create a new Section View.

So we will close down the Super Alignment editor for RS1 and look at creating and using a section view
before coming back to creating the vertical geometry for RS1.

To exit the editor, just click on the Finish button which is the Finish. You can also hold LB down on the

Finish button and the fly out toolbar with Finish and Quit buttons will appear and Finish can be chosen

from there. Important - don’t choose Quit because that will throw away any of the editing that you have
done.

[Edit SA ALIGNMENT-RS1 | Edit SA ALIGNMENT->RS1 |

b LBBFIYIN ! % ?2 V)8

9.3

The Finish Edit panel will then appear

“fl. Finish Edit ==

| Do you want te finish editing this string

[ Yes ] [Canr_el] [ Mo ]

Click LB on Yes to confirm and the edits to RS1 will be saved.

Section Views

A section view is a view with the coordinate system of chainage along a selected string along the
horizontal axis and height for the vertical axis. The selected string is called the profiled string.

If there are any models including tins added to the section view, then sections along the selected string
through the tins will be displayed in the section view. For any strings in models added to the section view,
cuts through that string by the profile string will be displayed.

Given that vertical geometry is defined in terms of chainge along a string then a section view is exactly
what is needed to interactively create vertical geometry.

To create a section view, from the Main menu, click LB on Views =>Create =>Section view.

-
| |

EEERIL e lil—lﬂ—?-] When the panel appears, highlight the current entry in

View name |LONG

the view name field by double clicking the LB, and type
LONG for Long Section. Click LB on Create to create

the view.

[ Create] [ Finish ] [ Help ]

4

The new view will pop up as a window overlaying your other 12d windows. Firstly, minimise the
perspective view 2. Then click LB on the plan view title area and select Window =>Tile Vertical.

Note: Views =>New =>Section view also creates a new section view but it does not ask you for a name
and creates it with the next available view number.

The View buttons on the Section view are:
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f Section View Buttons \

Prévious \ , Tolggle| |
string Next | Fit Pan Refresh Clone
Add string Zoom | Previous ~¢'r¢S Properties
Menuy Remove Profile Shrink Plot
K Vertical Exaggeration Regenerate /

=] Section LONG o[- 3]

The first Model to turn on in a section view is always the TIN. The reason for this is to establish the
vertical geometry in the section view. Remember we gave the TIN a name called GROUND and we
placed it in a model called tin GROUND. Add this model (turn this model ON) by clicking LB on the +
sign in the View Button Area of Section LONG. The screen will still appear blank at this stage.

As previously described, a section view has the chainage of a selected string as its horizontal axis and the
height of the string as its vertical axis. Hence we need to tell Section View LONG that we wish to construct
a section view along a given string (in this case our new road centreline RS1).

For an alignment string like RS1 there is the special Section View option
Section View =>Ultilities =>V G edit

that does both the profiling of the Alignment string and brings up the Super Alignment editor but before
we do that we will look at how to profile any string for a Section View.

In general for any Section View we profile a string by selecting the string to profile by clicking on the
Profile icon [Z1 on the Section View and then selecting a string to profile. 12d then does a section through
the TIN along tne selected string. That is, using the x and y coordinates of the selected string, it calculates
z values from the TIN. 12d then uses the z values (heights) from the TIN and the string’s chainage to
construct the Section view.

9.3.1Profiling a String on a Section View

From the Section LONG View Button Area, click LB on Profile icon E .
The Screen message Box displays

<Profile>[picks][][Menu]
12d is asking you to select the string you wish to profile.

Page 131
e = > L7
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In the view Plan 1, click with LB on the string that is the boundary around the data.

String DTMBDY,
to profile

| =Y

Provided your snap settings have at least Line snap ON, the string will highlight and the Information panel
will display.

mormation = \

Function

Type = File Input

Option = Read 12d Solutions Archive Data

Date = 09 November 2014

Time = 17h 22m 04
General

Cﬂodel = survey TOPO TIN BDY ) -

MName = DTMBDY

Stringno. =1

Type = Super

Colour = red

Linestyle=1

Pt/line = line

# pts = 197 . .
£ attributes = 1 Hints on the use of the Information Panel:

Length = 2722.062 ] ) )

Vertexid = 299 If you move the cursor outside of the Information panel after it has popped
ledsSEEY up, the Information panel will disappear. To get it back again, click RB

Point snap =

X = 43017665 whilst the string is still highlighted to bring up the Pick Ops menu. Click LB

;f ?;322999-248 on Info and the Information panel will redisplay.
Prof ch = 1125.058

Prof z = 75.299

Bearing = 1°06'20.84"

\ﬂre = /

The Screen Message Box advises

<Profile>[picks][accepts][Menu]”survey TOP TIN BDY->DTMBDY”

String name and model

Use the name and model in the Information panel to confirm that you indeed have highlighted the correct
string and then click MB to accept the highlighted string.

The section view will now be refreshed and will contain a red string corresponding to the section along the
string DTMBDY and a green string where DTMBDY cuts the TIN as defined in model tin GROUND.
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After accepting DTMBDY, your Section LONG view should now look as follows

A Section LONG("survey TOPO TIN BDY-> DTMEDY") = [E=H =5

string being profiled

section along the string

.
W

The green section through the tin does not appear because DTMBDDY was included in the triangulation
and so lies exactly on the tin and so the red section through the tin is identical to the profile of DTMBDY.
And because the profile of the string is drawn last, you only see the red string. When we profile RS1 in the
next section, we will be able to see a section the through a tin.

When the string DTMBDY was defined, it starting near the bottom middle of the view and proceeded in an
counter clockwise direction so this is the direction of increasing chainage along the string.

We will now examine some of the information features of 12d.

When the cursor is in the Plan 1 view you will notice that the View Coordinates Box at the bottom of the
desktop shows the x and y coordinates of the position of the cursor in the plan view.

When the cursor is placed in the section view LONG, the View Coordinates Box displays the chainage (ch)
of the selected string, the cursor height (ht) and the x and y coordinates of the profiled string. The start
chainage for DTMBDY was zero at the bottom middle of the view.

If you place the cursor in the section view LONG and move the cursor backward and forward laterally via
the mouse, you will see a yellow cross moving along the string DTMBDY in plan view 1. 12d recognises
that the same string is appearing in both views and links the information in the views accordingly. The
yellow cross is positioned in the plan view 1 based on the chainage (i.e. the position of the cursor laterally)
along the string in the section view LONG.

Section Views default to a vertical exaggeration of 10 to 1 but you Toggle "LONG" (g3
can change the exaggeration at any time by clicking on the View Grades [n/a]
Exaggeration or the Toggle button and selecting the required HG [on]
exaggeration. VG [on]
If you require an exaggeration other than those listed, you can click Lx
on Exaggeration from the list and type in the required value. ;i

10

20

Exaggeration

Grid [off]
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9.3.1.1Turning Off the Information Panel
Sometimes the Information panel is always getting in the way of your picking process.

At any time the Information panel can be toggled off to get it out of the way for the duration of a set of
pick operations. You do this by unticking the Info or I tick box on the Snaps menu or Snaps toolbar.

Although the Information panel does not then appear, the name of the highlighted string is still displayed
in the Screen Message Box.

El |2 ElonG
ch=743.399 ht=26.673 x=430

<Profile> [picks][accepts][Menu] "survey TOPO TIN BDY->DTMBDY"

Output Window Background tasks

Alternatively, if you leave Information panel turned on, moving the cursor slightly on the screen is the
casiest way of removing it after each pick. See 4.4 How to Find Your Way Around 12d Menus on

page 34 for more information on moving menus and panels.

9.3.1.2For Advanced Users

If multiple TINs are present, any TINs in models added to the view are also sectioned as the string is
profiled. Also the section view has a Corridor Width so any other strings crossing the corridor will also

appear provided their various models are turned on.
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9.4

Vertical Geometry (VQG) Edit

We will now define our road’s vertical geometry. We do this by defining Vertical Intersection Points (VIPs)
and then placing vertical curves between the VIPs.

To define the VIP’s we need to have the alignment editor running for the alignment and also the alignment
profiled in a Section View. We can do these in the one operation by selecting the flowing Section View
option on Section view LONG:

Section View =>Utilities =>VG edit
The VG Edit String panel then appears, already in picking mode,

¥ VG Edit String =] @ 23]
|

[ Pick&Edit || Finish ||  Help |

and the Screen Message Box advises
<Edit String>[picks][fast][Menu]
In the view Plan 1, click with LB on the alignment string RS1.

String RS1

Provided your snap settings have at least Line snap ON, the string will highlight and the Information panel
will display:

Gformation E \

General
Comment = [RS] Reference String

Model = ALIGNMENT String name and model
Mame = R51

Type = Super_Alignment

Colour = red

Linestyle=1 '

Pt/line = line The Screen Message Box advises

#pts=6 . . . . .

e <Edit String>[picks][fast][Menu]’ALIGNMENT->RS

el B LA Use the name and model in the Information panel to confirm that you indeed
)L("ie:zr;al: ; 0 have highlighted the correct string and then click MB to accept the

¥ = 37208.967 highlighted string.

Prof ch = 462.348
Bearing = 210°03'46.63"
+Ve =
Segment
Type = horizontal line
Length = 105.948
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After accepting RS1, the Edit SA editor is again opened for the string RS1 and your Section LONG view
should look as follows

] section LONG( ALIGNMENT->RS1" ) =8 = =

tring being profiled

section through the tin

/ along the string being profiled

Unlike the previous string being profiled, this string has no z-values and so nothing shows on the section
view for it. What is displayed as the green string is the section through the tin GROUND along the
alignment string.

The figures of -200 and -100 in the view correspond to the radii of the two horizontal curves defined along
the centreline. The R indicates that the curve is an arc and the value is the radius. The negative sign in the
radius indicates that a curve goes to the left when going along the string in the direction of increasing
chainage. Positive curves go to the right. The arrows show the chainage extents of the curves in the section
view.

When we defined the string in the Plan view, we defined it in order starting near the top of the view and
proceeded towards the bottom so by default, this is the direction of increasing chainage along the string.

We can now use the Editor to create vertical geometry in the Section View LONG.

To ensure that the complete road centreline, as defined in the Plan view, is also defined in elevation, and
matches neatly with the existing roads, we can add the model survey ROAD CROWN to the section view
and in the section view, the places where the strings in the model survey ROAD CROWN cut RS1 will
appear as crosses and lines if they run along RS1. These crosses and lines can be selected in the Editor and
so get their exact z value.

2 Section LONG "ALIGNMENT->RS1" = oy =

positions where strings in the model
"survey ROAD CROWN" cut the
profiled string RS1.

Page 136
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If we zoom into the cross at the beginning and remove the model tin GROUND to make things a bit
clearer, we can see that there is a cross and lines at either end of the section. These represent the crows of
existing sections of the road that we want to match.

@ Section LOMNG "ALIGNMEMNT->R51"

. ’ string CR that cuts RS1
string CR that cuts RS1

another string CR
that is on top of RS1

another string CR
that is on top of RS1

—

\ Start of section along RS1 End of section along RS1 j

From the Edit SA menu, click LB on Add/Remove IPs=>Append VIP.

L8338
L e S

Pl

The message in the Screen Message Box is
<Pick start IP location>[picks][fast][Menu]

12d is asking you where you want to place the first VIP. Select and accept the intersection point in the
survey ROAD CROWN model at the start of the profile.

Information

® Function
Type = File Input

Option = Read 12d Solutions Archive Data
Date = 09 November 2014

Time = 17h 22m 04s
General

Comment = [CR] Crown of Road
Medel = survey ROAD CROWN
MName = CR

String no. =1

Type = Super

Colour = grey
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have the right point. The line will then rubber band from the previously placed VIP to the cursor position
in the Section View.

Now select and accept as the second VIP the end of the CR strings that is on top of RS1 at the beginning of
RS1. We have now placed two VIP points which exactly match the existing road at the start of our design

The line will then rubber band from the previously placed VIP 2 to the cursor position in the Section View.

/

Section LONG "ALIGMNMEMT-=R51"

selected as VIP 1

select as VIP 2

K Start of section along RS1

We will now add in two more VIP points by typed input before tying into the existing road at the end of our
design in a similar fashion to the beginning of the vertical geometry.

' Enter Ch Ht: ) Type the chainage and level in turn for the next two VIP points,
|Ente, ChHt: [431249.667 | the same as we did with the X and Y coordinates of the HIP’s:

i | Enter Ch Ht: 3 IP 3 Ch=412 RL =49.667 IP 4 Ch =600 Rl = 66.333
|Enter ChHt: 60066333 | Press [Enter] Press [Enter]

E Section LONG "ALIGNMEMNT->R51" | = @

Tie the last two VIP points (5 and 6) into the existing road at the end of the design in the same manner as
we did previously with the start of the design.

After the sixth point is placed, press <Esc> to terminate the rubber band (or click RB to pop up the
Pick Ops menu and select Cancel). Click LB on the Refresh button in the View Button Area to refresh the
view.

As the VIPs were placed, 12d has annotated the view showing the grades defined between the VIPS
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2] Section LONG "ALIGNMENT->RS1" [ [-E1 ()

12d has many other facilities to accurately place vertical geometry We are now going to insert a new VIP
point on the same grade as VIP 2 but 40 m from the intersection to allow us enough room to place a
vertical curve.

To do this we click on

Add/Remove IPs =>Insert VIP Grade. ﬁ'ég 'f’, ‘5’;‘ EI, {EI "

b M s

nsert VIP Grade |

=

b

WF

As we wish to extend the The Mode will be

grade from VIP 1 through ) 7 | distance as we want the
VIP 2 our starting VIP # Wnsert VIR new VIP to be 40m from
will be 2. Start VIP |2 || the end of the existing
Grade — road to allow enough
|-0681 / |é| room to add a vertical
/Mudghistance Ed curve.
- Value (40 e
The grade will be the grade B -
between VIP I and VIP 2 | |7/ The distance as stated
which we can read from the [Insert| [Finish| [Help | above will be 40m
section view as -0.681

Click LB on Insert then Finish

Your view should now have an extra VIP as shown below.
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inserted VIP

We will now insert another VIP to once again allow enough room to insert a vertical curve before finishing

on the existing road at the end of our design. This time we will intersect two grades from existing VIP
points. Click on Add/Remove IPs =>Intersect VIP Grades.

e . LB B€
N

PSR O L

Intersect VIP Grades |

—/

1%

This time we will be
starting from VIP 5

The second grade is
calculated from VIP 6 to

Grades Intersect VIP

3l |\ viP 7

First grade Second grade
Start VIP |5 W StetVP p (g

The mode will be Mode [grade gy %] Mode [Pz [ - The mode is VIP# so
grade for manual Val s o EndVIP T the grade will be
entry of the grade - g 4 5 = " ! = T~ calculated between the

| cheite ok nominated VIP points

. fnset) Fnist] [Help) Gand7
CType in the value -5) —_ — —_—

Click LB on Insert then Finish

Your view should now have an extra VIP as shown below
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E Section LOMNG "ALIGNMENT->R51" o | = E

As we have inserted two new VIP’s on the same grade as

existing VIP’s we end up with redundant VIP’s which ﬁ}‘ {'*J L DJ
can now be deleted. Click on Delete and select and {
accept VIP 2. &
12d will renumber the remaining VIP’s and hence the {é*
second point to be deleted will be VIP 6. e
u+|-.
&
L 7]
/_i
X
) v (\
X

The resultant alignment then has 6 remaining VIPs.

] Section LONG "ALIGNMENT->RS1" oG]
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We will now place some vertical curves in the design. We will use parabolas to define the vertical curves
and place them via their length.

From the Alignment Edit menu, click LB on Move/Edit icon then

select Change Curve

Click with LB on VIP 2 and confirm it with MB. A panel will pop
up prompting ‘Length’. &

P L BB 4

e
-]

UK X

_ E\\
T—
Change Curve

,

*,

L

%

£l

Click with LB on VIP 2 and confirm it with MB. A Typed Input panel will pop up prompting Length.

:ﬂ‘ Typed Input

Length

Position the cursor in the data field

& w then type 50 and then press <Enter>.

Observe that a vertical parabola of length 50 is now inserted and the position of the VIP is still shown.

The insertion of vertical parabolas is setup to handle multiple insertions. If you now point in the vicinity of
VIP 3 and click with the LB, accept with MB, type 150 for the new length and press <Enter>, another
parabola will be inserted.

You can insert the remaining parabolas in the same fashion with VIP 4 having a length of 200m and VIP 5
a length of 100m.

To terminate the parabola insertion process, press <Esc> or click RB to pop up the Pick Ops menu and
select Cancel. Click LB on the Refresh button in the View Button Area to refresh the view and revise the
annotation.

Your Section LONG view should now look as follows.

2] Section LONG "ALIGNMENT->RS1" =R EoH ==

length and extent

of par bolas
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Note that on the Section View the length of each parabola re is given followed by an L, and there are

arrows to indicate the extent of the Vertical curves.

We can now use the Information panel to show the details of our vertical geometry. From the Alignment

Edit menu, click LB on Info to pop up the Information Panel.

Move the cursor in the Section View along the Road centreline string. The data in the Information panel

changes dynamically as the cursor is moved.

E Section LONG "ALIGMMENT->R51" [ :ﬂ‘ Super Alignment Info 125
=] -
Style Standard -
Chainage 391.274 =
Dynamic on 4
=)
Model ALIGNMENT s
MName RS1 ]
Colour red . r
Style full 7]
Points 6
Length 949,419 e
=)
Xcoord 42651416 o
Yeoord 37270342 A
Angle 240° 2
Mamed Part [aBd
=)
Level 52172 e
Grade -0.207 et
=)
Type line 4
Length 106.264 e
Radius e
Offset A
B -
|
The results in this panel are from placing the cursor near VIP 3.
We have now finished defining our horizontal and or press LB down on
vertical geometry and wish to exit from the alignment the Finish icon and
editor. To do so, as before we click LB on the Finish select Finish from the
button drop down toolbar.

fie, <,
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The Finish Edit panel will then appear

+fl. Finish Edit =

| Do you want to finish editing this strine

[ Yes ] |Canr_el| | Mo |

Click LB on Yes to confirm and the edits to RS1 will be saved.

WARNING: Do neot select Quit from the alignment editor. Quit will throw away all the changes made to
the string since the alignment editor was started.

NOTE: We don’t have to exit from the alignment editor for the string RS1. We could simply leave the Edit
SA menu on the screen and return to it later.
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9.5

Editing an Existing String

Now that we have left the alignment editor, we need to know how to go back into the editor to make future
modifications to the alignment string. In fact, what we now do applies to editing any existing string, not
just an alignment string.

To edit an existing string, simply click LB on the option Strings =>Editor which brings up the Edit String
panel.

B Edit String o B [k
|

| Pick&Edit || Finish || Help |

Now pick and accept the string you want to edit, in this case, the string RS1. The appropriate editor for the
selected string will then be started. Note that RS1 can be selected in the Plan View or the Section View.

Plan1

= || @ [ 52 | | & Section LONG "ALIGNMENT->RS1" =N =

Informaticn £
[ Help | | General

¥ Comment = [R5] Reference String
Model = ALITGNMENT
Mame = R51

Type = Super_Alignment
Colour = red
Linestyle=1

Pt/line = line

Fpts=h

The Edit SA panel will then reopen and you can modify the alignment as necessary - HG in a Plan View
and VG in any Section View where the alignment is profiled.

fe. P LB BF YIOR ! e, 7 v,

QUICKER METHOD OF GETTING THE STRING EDIT PANEL

In 12d you can define function keys and combinations of Shift, <Ctrl> and a function key to bring up 12d
options. In the standard install, F6 brings up the Edit String panel.

So to bring up the String Edit panel, simply press F6.
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9.6

Using a Grid to Assist in Coordinate Entry

For the work so far we have been using typed entry to enter coordinates however for some work you want
to be able to snap to the intersection of Grid lines to get the coordinates.

So we will now quickly look at how you can turn on a grid in a Plan View and use it to snap to. The same
can be done for a Section view for laying down VIP points.

First we’ll create a new view using the option from the Main Menu, View =>New =>Plan.

A new plan view called 3 will be automatically created. In the View Button Area for Plan View 3, click LB

on the + sign button and select all survey models.

Now let us set our grid settings so that they are suitable for grid snap purposes.

From the Plan 3 view, click LB on the Menu button in the View Button Area to pop up the View menu.
Select Settings =>Grid and the Grid on View panel pops up

4

“fl. Grid on View o] @ |5
) Tick on the grid draw box
view E /
grid draw Note the default value for Grid mode setting.
Dr.aw I ‘/B/ The choices are either full lines, crosses, marks or
grid mode |fu|| lines E] marks and crosses.
grid x [100 Click LB on the Choice icon if you want to change
grid y |1|:":| & the value.
grid level o Note the default grid x setting. You can change this
grid colour |-:Iark green E] setting by placing the cursor into the grid x field,
press the Backspace key (or the Delete key) and
2 42 [text at bottom a typing the required number.
b2t [text at left a Similarly for the grid y field.
text style 1
. i | The text x field has the choices fext off, text at bottom,
Pre*postfix x | text at top and text at bottom & top.
e | If you don’t want text on the grid, click LB on text off.
Sl 10 Similarly for text y.
text plot height (mm) |5
text colour yellow D
cross size (pixels) 5
cross plot size (mm)  [1
| Grid set
— Click LB on Set to activate the change.
[Flnlsh] [Help]

Plan View 3 will now look like

ge 146
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Plan 3

g

=
+

+ 4t

To use the intersection of the grid lines, we use Grid Snap we simply set Grid snap ON.

So on either on the Snaps toolbar toggle on G for Grid snap, or on the Snaps menu, toggle on Grid.
Whenever one of them is changed, the other will be automatically changed to the same setting.

(p] (][] (el () (H][T](s] (@[] [E] (A] (K] [M] - Snaps Toolbar

Snaps & . . .

Point When creating new strings you would probably want Point
) oggle Grid snap on and Line snap OFF so that you don’t inadvertently snap to

ine and Point and Line features in the view.

Text nap off

Grid - Any of the Snaps menus or the Snaps toolbar can be used

to toggle Grid snap on

Cursor o

Height

Tin ™" If you want to use the Snaps menu and it is not already on

Tin display, click LB on Utilities=>Snaps=>Snaps from the

Segment Main menu.

Mame ""

Maodel ™"

Tolerance 20 Snaps Menu

Pt tolerance 10

Info ¥

Data tip

Fast pick v

Fast accept

Fast cad v

Display many
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If a grid is not already on display on a view, then in the View Button Area of the view, click LB on
Toggle =>Grid to turn on the grid with the current grid settings.

If you want to turn a grid OFF for a view, then in the View Button Area of the view click LB on
Toggle =>Grid to turn OFF the grid.

So for any view, a grid can be quickly turned on and off by using the Toggle =>Grid.

You only need to bring up the Grid on View panel if you want to change some of the setting for the grid.

With Grid Snap turned on and a grid on the view, if we were now to start creating strings, then with each
position pick we could snap to a grid intersection.

The purpose of introducing this here is to show you how you can set up and a grid.

At this stage we will not be using it so we will delete Plan View 3 by clicking on the X in the top right hand
corner of the view.

Also from the Snap toolbar, turn Grid Snaps OFF.

Then on the View Plan 3, click LB on the Menu button in the View Button area (or click RB in the View
Button Area) and the View menu will pop up. Click LB on Models=>Remove All Models. In the View
Button Area, click LB on the + sign button and select all survey models EXCEPT the models survey
TOPO SURFACE LEVEL and survey STN.
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10.1

Road Templates

The simplest way that 12d can create a road design is to calculate the effect of passing a user defined cross
section template along the alignment and the interface between the new template and the existing terrain.

12d has Templates that are always defined for half of the road. When used on the left, the template is
applied on the left hand side of the road. When used on the right, the template is applied to the right hand
side of the road.

Each template has various parts to it. There is a Fixed part that is always used in applying the template.
Then there is a Cut/Fill part that is variable. As many links in this part are used as is necessary to reach the
intersection with the natural surface. If after using all of the Cut/Fill links, the road profile still has not
intersected with the surface, a Final Cut/Fill slope is used to try to calculate the intersection. All parts of
the template are optional.

Creation of Basic Templates

Template creation is a mechanical process of filling widths, crossfall (slopes) and delta heights into a panel
and the created Template data is stored in files.

A typical use of templates files is to store standard templates as required by a particular road authority.
These can then be read in and modified to suit each particular job as required - quicker than starting from
scratch each time.

For the purpose of the tutorial, we will use an existing template to save time. Previously stored template
values will be read in from file "ROAD TEMPLATES.tpl". This is one of the files supplied with the
Training disk.

From the Main menu, click LB on File =>Templates =>Templates input. The Read Templates panel
pops up.

-

Read Templates = weidmm| | Place the cursor on the folder icon for the File field and click

LB to pop up a list of template files. Navigate to the folder

File [JAD TEMPLATES tpl |;| C:\12d\11.00\Training\design\getting started basic

then double click LB on ROAD TEMPLATES.tpl.

| Read | | Finish | Help Select Read to read in the template file and Finish to
terminate the panel.

Handy Aside:

For any File field (File ox) on any panel, you can drag the file from Windows Explorer onto the File field
and the full path name of the file will written to the File field.

Our Template file contains a number of templates. Initially we will look at the templates called FULL
LEFT and FULL RIGHT. The various parts of the template just read in will now be displayed. These are
just arbitrary names that have been assigned to these particular templates. There can be many templates in
just one file, and in general any template can be applied to either side of the centreline. In this case we will
use the convention to have left and right suffixes / and r in the names and to use these templates on the left
and right respectively.

An alternative to creating a left and right template is discussed in 10.3 Alternative Template Creation
on page 157..
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We will now investigate the template FULL LEFT.

From the Main menu, click LB on Design=>Templates=>Create/edit.

( B’ Template Create/Edit |¢|1
In the template panel that pops up, S
place the cursor on the Information Template name
button for the Template name field | Select Template =]

and click the LB to pop up a list of
templates. FULL
P L e

1 FULL RIGHT

Double click LB on FULL LEFT
[ Select ]

Each template has up to five parts. We will only use Fixed, Cut and Final Cut/Fill. This means that in a
fill situation, the final fill batter will join onto the fixed part of the road template since we are not defining
a variable fill template. If a template panel contains blank fields, 12d will such fields in its processing of
the various template parts.

Fixed Part of Template
From the Template Create/Edit panel, click LB on Fixed and the fixed template panel pops up.

Width | Height | XFall % | Mame | Celour E]
i 3.5 -3 Ikl cyan E]
i 0.45 -0.04 ikl dark blue @

2(004 015 tokl blue
4|01 0 bokl  green
5| dark green

CL

— 19
bofol

g-mm

| valid colour

Y

This section is called Fixed because all the links in this section of the template are always used.
A large number of fixed links can be defined but we will only need five.

Note that the name of each link in the left template has been given a suffix 1.
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The template defines a carriage way width of 3.5 metres at -3% crossfall to the kerb line lokl. This is
followed by a kerb and channel, iokl, tokl and bokl and then out to the back of the footpath bofpl.

The sign convention is +ve is up and -ve is down. Each width defines a link from the previous link so the
order is important i.e. links are defined relative to one another, not from the template centreline.

As you will see later, this is one of the features that makes 12d so powerful - the ability to use string
handling to automatically perform total road redesign after any geometry or template link changes.

These template link values could now be changed. At completion of any changes, select Apply to
implement the changes but leave the panel on the screen. Select OK to implement and terminate the panel.

Variable Part of Template

The Cut and Fill sections are called the Variable part of the template because depending on the terrain, a
different number of links may be used.

Note that the links in the Variable part of the template connect onto the Fixed part i.e. the first variable link
follows immediately after and connects to the last fixed link. The Fixed part always appears so it is normal
to put kerbing etc. in the fixed part.

The variable Cut part only appears if at the end of the Fixed part of the template is in a cut region. That is,
the end of the Fixed links is under the ground and you need to cut into the terrain to reach that point.

Each of the links in the Cut part is then be used until the surface is reached. No more of the Cut links are

then used.

It is normal to put benching in the variable part of the template when battering is required.

Similarly, if the end of the Fixed links is in fill, then the variable Fill part of the template is used.

Variable Cut Template

From the Template Create/Edit panel, click LB on Cut and the Variable Cut Template panel pops up.

Again a large number of links Width | Height | Slopel: | MName | Colour E
can be defined here. We will 1)3 13 bermll  grey (=]
use six to define our batter 2|1 01 bermi2  purple [ E
slopes. Slopes are defined by 3|3 15 berml3 | grey

giving a horizontal width x 41 01 berml4 | purple . g
where the slope is 1 vertical in 5)3 1.5 bermlS | grey E
x horizontal. 5|1 -01 berml6 | purple .

The sign convention for slope
in Cut section is t+ve is
upwards.

Unique names are given for
each link in the template. Note
the / suffix in each link name

Warning: in the Fill section,
the sign convention for slope is
+ve is downwards.

-

~

[ Variable Cut Template - "FULL LEFT™

bofpl
berml2
berml4
bermls
bermlé

berm/3

ﬁermH

[valid colour

Coc]  [Aesy]  [Dew]  [(Fwn]  [Fep] |

These values could now be changed. At completion click LB on Draw to preview the template.

Click LB on Apply to implement any changes. Click LB on OK to implement any changes and close the
panel. In the Template Create/Edit panel, click LB on Finish to close the panel.
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Variable Fill Template

Whilst we are not using one here, this section is included to define the rules of usage.

By leaving the panel blank, 12d understands that the variable fill template feature is not to be used.

The sign convention for slope in a Fill template is +ve is downwards

Final Cut/Fill Template
From the Template Create/Edit panel, click LB on Final Cut/Fill and the Final Cut/Fill Template panel

pops up

e ™
& Final Cut/Fill Template - "FULL LEFT" Mﬂu

| Final cut slope 1vin
Final fill slopelvin

Maxirmum slope width

T
—

Final name ’mtl=
|
(k] [Awy] [Fmsn]

After the Variable part of the template, 12d
will use the final cut and fill slopes to
calculate the intersection with the natural
surface. This only occurs if the Variable part
hasn’t yet reached the natural surface. 12d
will examine a corridor up to 100 metres
from the previous link to achieve this. An
interface string named intl will be placed on
the TIN at the intersection. Again note the

suffix /

These values could now be changed. At completion click LB on Apply to test out any changes. Click LB
on OK to implement any changes and terminate the panel.

In the Template Create/Edit panel, click LB on Finish to close the panel.
Note that apart from the suffix 1 or r, the FULL RIGHT template is identical to FULL LEFT.

The links in the left and right
templates are identical except
that links in the FULL LEFT
template have a suffix of 1 and
those on the FULL RIGHT
template have a suffix of r.

This ensures that links on either
side of the centreline have
unique names — essential for
string modifiers and applying
boxing as we shall see later

-
i Fixed Template - "FULL RIGHT™
- L ol

:

= =L

cyan
dark blue
blue

green

Width |Height |XFaII % |Name |Colour
1(35 -3 lokr
2(045  -004 iokr
3004 045 tokr
T4|011 0 bokr
5416 25 bofpr

dark green

[al[BlX][<][o]

[ ok | | Apply |

3 - ‘
[ valid colour
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Variable Cuts for
right side have
suffix r.

The interface name intr has
suffix r.

-
® " Variable Cut Template - "FULL RIGHT"

Width | Height |5lopel: | Mame | Celour
113 15 bermrl | grey
2|1 -01 bermr2 | purple
3|3 15 bermr3 | grey
41 -01 bermrd | purple
503 15 bermrs | grey
6(1 -01 bermré | purple

MEX[EB)

bofpr

Eermr‘l

bermr2
bermr3
bermrd
bermrs
bermré

[ valid colour

Lok ]

[ Apply |

[ Finish | [ Help |

Final cut slope 1vin |1

Final fill slope 1vin

[2

Maximum slope width 100

Final name

|ir1tr

oK |

| Apply |

| Finish | | Help |

y
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10.2  Applying Templates

Before we apply the template to the road centreline, let us rearrange our views so that we can see what is
happening more clearly.

:ﬂ{ 12d Model 5M 11.0C1a (nt.x86) - Project "CA12d\11.00\Training\design\getting started basic\STAGE I\STAGE 1" - Client "12D Solutions - Lee’ = || B[ &R
Project File Edit View Models Strings Cad Tins Survey Design  Drafting Plot  Report  Utilities User Window Help
| 5 [ base [+ [green L ] = Sl &2 E M A (]
M X](s]EE AR ER E M) : G e @ SR T 440 A R - I
+, Plan1 = |2 ][ 52 | | B Section LONG "ALIGNMENT->RS1" =
.,
L
Q.
55
=)
e
'i‘j‘
e,
<,
=)
=,
O,
Q' ]
&,
e
£,
X' ‘
'S
[m,
A%,
H.
\.,f_‘ @ Per.. | & || & || £3
O. B[z 8 a4 b
e, cap|[MUmM|[scrL[]
W, Output Window Background tasks
The design can be applied in two ways.
The simplest way is to create an Apply function which uses the templates for the length of the alignment
without any modifications such as widening or superelevation. This is also useful for users who don’t have
the Alignment module.
The other more typical way for most design applications is to create an MTF file (Modifiers and Template
File) which allocates and allows modifications of templates and strings. This is then processed using the
Apply MTF Function.
IMPORTANT NOTE:
The Apply MTF Function requires the Alignment module. The Apply MTF Function is not in the Getting
Started for Design manual but is covered in the non-Introductory Design courses.
Page 154
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We will now create an Apply Template function to apply the template to the road centreline.

From the Main menu, click LB on Design =>Apply =>Apply template.

The Apply Template Function panel pops up.

s

Ia‘ﬁl Apply Template Function

— | Fill in the panel as shown.
E=R(E=R = P

Main | Models | Misc | Tin | Filter |Plot |

%

Function name [Rs1
Tin [GROUND
Left template [FULL LEFT

Right template [FULL RIGHT

EEE

Reference |ALIGNMENT->RS1

Start chainage |21,35|:]5

End chainage |g;'_3,5435

Section separation [10

Report file [RS1 Vol.rpt

ERIe ]

(= )

[ "ALIGNMENT->RS51" selected

[views |  [Apply|  [Finish | [ Help |

A function name is needed so that the process of
applying this particular template to this piece of
centreline can be referred to later in any redesign. In
the Function name field, type RS1 and then press
<Enter>. On the Models tab the Model names will
be automatically filled in after you press <Enter>.
This is based on the function name. In the Tin field,
click LB on the tin icon to pop up a list of available
TINs. Double click LB on GROUND

In the Left and Right template fields, click LB on
@ button to pop up a list of templates. Double
click LB on FULL LEFT and FULL RIGHT
respectively.

Select the Reference pick icon and then select the
alignment string in the plan view

As we already have existing road at the start and end
of our design we do not want to start and end the
template at the beginning or end of the alignment
string. Type in the chainages shown to ensure the
design matches up with the existing road surface.

-

l:ﬂ: Apply Ternplate Function

‘Main  Models |Misc | Tin | Filter

o= || = |

| Plot |

Model for strings [RS1 Stre
Model for sections |RS1 Sects
Section colour [cyan
Model for polygons [RS1 Palys

[ "ALIGNMENT->R51" selected

[views |  [Apply| [ Finish |

| Help |

NOTE FOR PRACTISE VERSION:

The default Section separation is 10 but for the
Practise Version use a Section separation of 20 and
an End chainage of 400. This will keep the number
of points under 5,000.

Click on the Models tab and note that the model
names are already filled in. If they are not go back
to the Main tab and press <Enter> after RS1 in the
Function name field.

The other tabs we don’t need to worry about at this
stage.

Note: If desired, use the shorthand suffix notation of
", 1" after each model name to automatically add the
model to View 1 as the template is applied. If this is
not done, the strings and sections will still be
updated but will not be on view. In such case they
can be turned ON manually from the View Button
area with the + sign button after the template is
applied.

Explanatory Note: 12d permits the chainage of a road to be defined by a string called the Reference string.
The template is always applied at right angles to the Reference string. To cater for complex projects, the
centreline of the template is not necessarily located on the Reference string. Another string called the
Hinge string is used for this purpose. The Hinge string and the Reference string do not necessarily
coincide. If there is no Hinge string, the Reference string is used as the Hinge string.
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In simple projects such as our new road, the Reference string and the Hinge string coincide. By default,
12d assumes the Hinge string defaults to the Reference string so we do not need to click the Hinge button
in this case.

When the panel is complete, apply the template by clicking LB on Apply

There is now a short delay whilst 12d performs the calculation. The message box at the base of the panel
will advise the current chainage as the template is applied. As the calculation completes, the view 1 will be
updated with the new road strings and cross sections.

The panel message box now displays the cut, fill and balance volumes resulting from the application of the
template. The default convention is negative for cut and positive for fill. Interpret these as follows

¢ -35281.620 cubic meters of cut

f 7149.330 cubic metres of fill

| c-35281.620f 7148330 b -28132.290 b -28132.290 balance in cubic metres showing
surplus of cut over fill

Clearly we have too much cut at this stage. We will subsequently improve the design to minimise this.

NOTE
You volumes may vary slightly from these depending on the exact position of the initial first two and last
two VIPS that where selected from the existing road.

Click LB on Finish to terminate the Apply Template Function panel.
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10.3

Alternative Template Creation

12d can use just the one template for both sides of the road. The templates would be set up with no suffix

after the link names

From the Main menu, click LB on Design=>Templates=>Create/edit

Type in the template name FULL.

-
7 Template Create/Edit

)

Template name

[FULL]

=

|

T—

B Fixed Template - "FULL"

KFall %

Colour

Select Fixed

Here the values are shown in
the table without an / or r suffix

Select Draw

Select OK to implement any
changes and finish panel

Select Cut

Again the panel appears similar
to the Full left but without the
suffix Jor r

Select Draw

Select OK to implement any
changes and finish panel

- y, 1(35 -3 lok cyan
2045 -0.04 ok dark blue
3(004 0A5 tok blue
4011 1] bok green
5 dark green

cL

| valid colour

-
|87 Variable Cut Template - "FULL"

.- ==

Slopel:

Colour

15

grey

purple

15

grey

purple

15

grey

purple

[valid colour

(Apply |

[Dlaw]

[ Draw | [ Finish | [ Help |

(2]
(=]
X
(]
(=
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-

Select Final Cut/Fill

Final Cut/Fill Template - "FULL"

[EESEE

One template is defined
Note no suffix / or r

Select OK to implement any

Final cut slope 1vin
Final fill slope 1v in

Maxirnum slope width

1
2
100

changes and finish panel T"al name int
[ok | [apply] [Finisn] [ Help |

L8

From the Main menu, click LB on Design =>Apply =>Apply Template

The Apply Template Function panel pops up.

=)o s

| Fitter | Plot |

"i‘l Apply Ternplate Function

Main | Models | Misc | Tin

Function name |RSl

Tin |GROUND
Left template |FULL
Right template |FULL

LHS prefix [ RHS prefix [
[ALIGNMENT->Rs1
| (]

Reference

Start chainage |;'_1,35(]5
End chainage 3285435

Section separation 10

=

Report file |R51 Vol.rpt

[c-35281620 f 7149.330 b -28132.290
[ Finish |

(Views | [ Apply | (_Help |

This action will suffix all road string names with 1 for the left side strings and r for the right side strings

The panel is filled in the same as shown in10.2
Applying Templates on page 154. with the
exception of the Left and Right template names
which are both FULL

The prefixes need to be added. For the entry of the
LHS prefix type in *1 and for the RHS prefix type *r.

Note that these will actual be suffixes of 1 and r

NOTE FOR PRACTISE VERSION:

The default Section separation is 10 metres but for
the Practise Version use a Section separation of 20

and an End chainage of 400. This will keep the
number of points under 5,000.

The advantage of this method is the reduction in number of templates created.

The advantage of the previous system is the ability to pick strings from the view to match names which is

useful when modifying templates and boxing.

Each method has its own merits but the first method is probably the best for future advanced work using

Modifiers and the Apply MTF.
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11 Design Long Sections

11.1 Section Profiles

We will now focus on the sectioning facilities available in 12d. As we already have our Section LONG
view displaying our road centreline, there are also many other ways in which information can be viewed.

In subsequent operations we will be picking strings. To help make this easier from our Plan 1 view we
need to zoom it as before. Zoom in on the area shown so that each string is visible in the Plan view.

We will now section a series of strings that were created during our road design.

In the Section LONG View Button Area, click LB on the Menu button to bring up the View menu. Walk
right on Profile =>Many strings.

(Note: This option can also be selected by clicking RB on the Profile button to bring up the Profiling menu.
Click LB on Many strings.)

]|

Information
Function
Mame = RS1

<Profile>[picks][][Menu] GE”E’al +— (L0] Leader O
omment = eader Upen

12d is asking you which string you wish to profile. Model = RE1 Strs
In the zoomed Plan 1 view, click with LB on the Mame = lokl
cyan string just above the magenta centreline. The Type = Super
string should highlight and the Information panel Colour = cyan
will display (see right). Click MB to confirm the —rEEra=l

string selected. Pt/line = line
#pts =122

Length = 898.475
Locks = Read (-1)
Line snap =

X = 42900008

Y = 36934092

Z = 59.045

Prof ch = 892,509
Prof z = 59.945
Bearing = 116°00'00.57"
+We =
Segrment

Type = horizontal line
Lenath = 8.643

The Screen Message Box advises




12d Model Getting Started and Training Manual

The string will now appear in the Section LONG view.

P

Section LONG "RS1 Strs->lokl” [= ][ &[]

BEEl = kRN KR E

f TN

The Screen Message Box is immediately prompting you for another string to profile.
<Profile>[picks][][Menu]

In the Plan 1 view click LB on the infr interface string between the road formation and the existing terrain.
This is the red-green string (shown highlighted below). Click MB to confirm the selected string.

Plan1 e e
__ = EE&®% K@ | e =

Mame = RS1

General

Comment = [INT] Interface
Maodel = RS1 Strs
Mame = intl

Type = Super

Type like = Interface
Colour = magenta
Linestyle=1
Pt/line = line

#pts =122

Length = 884,047
Locks = Read (-1)
Line snap =

X = 42895632

Y = 36945307
£=758320

Prof ch = 869.072
Prof z = 58.320
Bearing = 122°33'02.64"
+VE =

Segrnent

Type = horizontal line
Length = 10.066

The Section LONG view will refresh as below.
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P

e

You will notice that for the section along intl, you can’t see the section through the tin. That is because
each vertex of the interface string intl is ON the tin and so the two sections coincide at every vertex of intl.

So using Profile =>Many strings you can rapidly look at the profiles of any string

To terminate the Profile =>Many strings feature, press <Esc> or click RB whilst the cursor is anywhere
in the Section LONG view to bring up the Pick Ops menu, and click LB on Cancel.

Whilst the various strings have been profiled, clearly they are being scaled to fit the size of the Section
view. To begin to get a feel for the scale of these strings, we can turn on a grid.

Firstly, let us make sure our grid settings are suitable. From the Section LONG view, click LB on the Menu
button in the View Button Area to pop up the View menu. Click LB on Settings =>Grid and the following

panel pops up

-

1" Grid on View I. = _|_]_s_3_

view LONG
grid draw [

Draw last on view [

grid mode W@
grid x |100=
gridy T
grid level ’O=
grid colour W
text x tetatbottom ||
texty tetatlet <]
text style R [T
Pre*postfixx l—

Pre*postficy ’=

text height (pix) o (]

text plot height (mm) |5=
text colour WD
cross size (pixels) ,5—
cross plot size (mm) ,1—

[ set | [Finish|

Click LB on the Grid draw field to tick the tick box. This
activates the grid.

Note the Grid y setting. If it is set to 100, move the cursor
into the Grid y field by clicking with the LB at the right end
of the "100", press the <Backspace> key followed by
<Enter> (or double click with LB anywhere on the 100 and
type 10 and press <Enter>).

Click LB on Set to activate the change.
Click LB on Finish to terminate the panel.

Note that you can turn the grid on with the above tick box or
alternatively in the View Button Area of Section LONG, you
could have clicked LB on Toggle =>Grid

BUT you need to bring up the Grid on View panel to change
any setting.
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The Section LONG view will refresh as follows

@ Section LOMG "RS1 Strs-=intl"

Depending upon what other information you wanted to display or create in this sectional view, the vertical
scale may be too great. There are a variety of ways of changing the vertical scale.

The default vertical scale uses an exaggeration of 10 to 1. This can readily be changed by clicking LB on
Toggle from the View Button Area to pop up the Toggle menu.

Toggle "LONG" [

Grades [off]

HG [on] Click LB on 5x to change the vertical exaggeration 5 to 1.
VG [on]

X In the View Button Area, click LB on Fit to fill the view.
X

2% —
o | 1x |
10x

20

Exaggeration
Grid [on]

E Section LOMG "RSL Strs-»intl"

Change the Vertical Exaggeration back to 10x (10 to 1).
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12 Viewing and Assessing the Design

Remove any models on the Perspective view and then add the models survey ROAD CROWN and
survey ROAD PAVEMENT EDGE in the perspective view.

Now that we have run the Apply, we have new design models RS1 Strs and RS1 Sects. Add both these
models to the plan and perspective views.

The centreline model ALIGNMENT should be turned off in the plan view and turned on in the
perspective view

Set up the views on the screen up as shown below.

:ﬂ: 12d Model 5M 11.0C1a (nt.x86) - Project "C:\12d'\11.00\Training'\design\getting started basic\STAGE 1\STAGE1" - Client "12D Solutions - Lee" = @
Project File Edit View Models Strings Cad Tins Survey Design Drafting Plot Report Utilities User Window Help

[ (o base [ lgreen ] [EE =] = E[FEHEE MM (A = [=: @]

BUEXEERETE @R E R E M G e E F2ORRVPORLF ALY %SO % DEHEI
. | EPian1 = |[® [ 22 ] || [Z] Perspective OpenGL 2 E=n|E=R [

JANLBF OBEN BN

S
[m,
i,
B
7 E Section LONG "ALIGNMENT->RS51" o= || E [ ER
o.
ch,
Y,
=
A,
B2 & 4
CAP||NUM||SCRL| |
Output Windo: Background tasks
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To begin assessing the design, click LB on Zoom in the Plan 1 view as shown below

[ plan1 ==

green interface

in fill \\
red interface

in cut \

Note that the interface strings between the road template and the existing terrain are coloured red in cut
areas and green in areas of fill. This can be confirmed by placing the cursor in the Section LONG view and
moving the cursor backwards and forwards across the view (to change the chainage of the cursor). Observe
the corresponding movement of the yellow cross in both the Plan 1 view and the Perspective OpenGL 2
view.

Also note the various coloured strings that have been inserted in Plan 1.

From the main menu, click LB on Strings =>Inquire and inquire on the various strings in Plan 1. Make
sure that your Point and Line snaps are set ON. Place the cursor in an area near the road, click LB
repeatedly and observe what happens. With each click a new string is selected. As the information panel
pops up each time, note the various string names and the fact that each one now has a profile chainage
(prof ch) and profile Z coordinate (prof z). These are now three dimensional strings and can be observed in
the Perspective OpenGL 2 view.

You will observe that the cross sections are also strings with their own unique names that are used when
referring to cross sectional views. For instance ‘design 130’ refers to the section string at chainage 130.0

QUICKER METHOD OF GETTING THE STRING INQUIRE PANEL
In the standard install, F2 brings up the String Inquire panel.

Whilst the View is zoomed try panning along the road to assess the interaction of the template with the
existing terrain. From the Plan 1 View Button Area, click LB on the Pan button. Position the cursor on the
centreline of the road near one edge of the view and press LB down. Drag the cursor across the view and
the image will pan with the cursor until LB is released. Keep positioning the cursor on the road centreline
each time and clicking LB down and move down the road whilst in the zoomed state.

Press <Esc> or RB to cancel Pan.
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12.1 Perspective View Operations

In 6.10 Orbit on page 92 we saw how Orbit could be used to orientate your eye in relation to your data
in a perspective view. We will now use this facility again to observe our design.

The Orbit option is accessed by clicking LB on Orbit in the View Button Area of Perspective Open GL 2.

Make sure that models RS1 Strs, RS1 Sects and the survey ROAD CROWN and survey ROAD
PAVEMENT EDGE are turned on.

Try hold LB down in the perspective view and moving it around to rotate the image, and also using the
mouse wheel to zoom in and out to, get a view of the intersection at the end of the design

@ Perspective 2 EI@

You will notice that this facility gives you a good feel for the design you have created. You will see
perspective views similar to that shown above.
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12.2  String Drive

String Drive allows you to nominate a string and a speed and 12d simulates driving down the road. We will

drive down the centre of the road with our

The string drive facility is accessed from the
Perspective view by selecting the Drive
button in the View Button Area of
Perspective 2. The String Drive for View
panel pops up.

Set the Eye height to 10 metres. The default
values for the other items are OK. Note that
the speed is set for 100 kph.

To repeat the drive once the end of the string
is reached tick on the Repeat check box

Click LB on the String to drive along icon
and then select the centreline of the road.
The easiest way to do this is to pick it from
the Section LONG view.

eye height 10.0 metres above the road.

.
-

»fl. String Drive for View EI = @
View 2
Eye height 10
Eye offset |,3
Target height 0.3
Target offset |,3
Target dist | a0
Speed (kph) |1,:|,:|
String to drive along |
Chainage |,3
Repeat 0

[Drive] [Finish|

Click LB on Drive to begin the string drive process. The image in Perspective will now change to that at
chainage zero, looking down the centreline.

The image will repaint automatically multiple times as the drive proceeds. Each image will be calculated
such that the viewer appears to be travelling down the road at 100 kph. The following are two typical

images.

E Perspective 2 EI@ Perspective 2

(SRR ES ORI N E

# —
Fi A 5,

=
74 kY
/ / \

/ /Af\ \

]\

Observe that extra crosses appear on any pl
any section view where RS1 is the profiled

an or perspective views that the alignment string RS1 is on and
string. The red cross, is the Eye (or Camera) point and the

green cross is the Target point for the perspective view of the drive.

On the perspective view that you are driving along (if the string ALIGMENT is on the view), you will only
see the target cross because the eye point is not in the Perspective view. The target cross is 40 metres
chainage further down RS1 and 0.3 above the z-value of RS1 at that chainage.

Observe the locations of the eye and target
crosses move as the drive progresses.

crosses on the other views that the alignment is on. These

You can stop the drive at any time by pressing <ESC> or RB. To resume the drive, select the Drive button

again on the String Drive for View panel.
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Once the drive has finished, you can replay it again by resetting the chainage to 0 (or any legitimate value
along the road) and clicking LB on Drive again. Note that both the eye and target points must be on the
string at all times for the Drive to work.

If the Repeat button is ticked on the String Drive for View panel then the drive will automatically start at
the beginning of the alignment once the target point is at the end of the alignment.

It is possible to enter negative values for both the Target distance and Speed. A negative Target distance
(-40) is equivalent to looking out the back window of the truck as you drive down the road. Set the
chainage to 40 to start.

Similarly, a negative Speed (-100) can be used to drive back up the road in the opposite direction (i.e. in
the direction of decreasing chainage). To do this you need to set the Chainage to somewhere near the end
of the road (say 870) before you start the drive and also set the Target dist to -40.

Click LB on Finish to terminate the string drive.

Note
It is also possible to have negative values for Eye height, Eye offset, Target height and Target offset.
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12.3 Defining a New Perspective View using Eye and Target points

Sometimes it is desirable to locate your perspective view exactly. For example, you wish to locate your eye
at a particular point and look to a particular point.

To do this, click LB on the Eye button in the View Button Area of Perspective 2 and the Perspective View

panel pops up.
( B ' Perspective View = eS| )
View A Ignore the current values in the panel.
EyeXVZ They are left over from our string drive.
X coordinate 42781403 = Click LB on Eye Target. 12d asks you to
¥ coordinate |36983.0467 locate your first point on the view line.
Z coordinate 68.314 Make sure that your Point and Line snaps
are ON.
Target XYZ

X coordinate ’W@
¥ coordinate 360705118

Z coordinate ’W
Maove dist U—
|
[ View ][ Eye Target ][ Finish ][ Help ]

s ’

[E2] Plan1

In Plan 1 click LB on Fit to fill the view. Select
the first point by clicking LB on the intersection
of the existing road at the end of our design.
Confirm the point with MB.

When the Enter height panel pops up backspace
over the existing height and over write the value
with 95 and press <Enter> since we wish to look
down slightly on the design.

12d then prompts you for the second point on
the view line. Click LB approximately in the
centre of the road as shown. Confirm with MB.
This time when the Enter height panel pops up,
just press < Enter> to accept the value.

@PerspectiveZ EI@
BrENFe@xEEEEENRE

Your Perspective 2
should now look as
shown here.
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8 | Perspective View I. = ﬁj

In the Perspective View panel, lock the

cursor in the Move distance field by View 2
double clicking the existing entry with the Eye XVZ

LB and type 50. X coordinate W@
Now every time that you click LB on View, V¥ coordinate 359427289

the view will be advanced 50 metres along Z coordinate W

the eye-target view line. If you zoom in

five times you will see a view like the one Target XYZ

below. X coordinate W@

¥ coordinate W
Z coordinate W

Move dist |5c|
[ finished drawing

[ View ” Eye Target ][ Finish ][ Help ]

-

@Perspecti\reE | = || =] || 3 |

BErERaEHE = E R eNRE

Clearly this facility gives you the opportunity to orientate your eye point accurately in any perspective
view.

Click LB on Finish to terminate the panel.

That completes a brief look at some of the facilities in 12d that can be used to visually verify your design
parameters using plan, section and perspectives. We will now look at more traditional ways of displaying
design data - long sections and cross sections






Chapter 13 Design Cross Sections

13

Design Cross Sections

12d has many facilities for displaying and plotting design cross sections. We will look at one of these
called Model profiles. This name is derived from the fact that when we passed the template down our road,
we created and stored our cross sections in a model. Model profile allows us to display this data by
profiling the cross sections one at a time.

We now need a Section view in which to display the cross sections. As we still need our existing Section
LONG view for our long sections, we will create another Section view.

From the Main menu, click LB on Views =>Create =>Section view. When the New Section View panel
appears, place the cursor in the View name field, press the Delete key and type CROSS. Click LB on
Create to create a view which will now be referred to as Section CROSS.

As before, you need to drag the border to resize the view. Stretch the Section view out so that it is
approximately the same size as the Section LONG view we created earlier. Click and hold LB over the
name Section CROSS and drag the view to the bottom right of your desktop as shown below. Pin it by
releasing the LB. The View will initially be blank as no models are turned on.

Make sure that Point and Line snaps are set ON. Your overall desktop layout should now look something
like this.

g, 12d Model 5M 11.0C1b RC 1 (nta@6) - Project "C:\12d\11.00\Training\ design'getting started basic\STAGE 1\STAGE 1" - Client "12D Solutions - Lee” =N R
Project File Edit View Models Strings Cad Tins Survey Design Drafting Plot Report Utilities User Window Help

AR UEASEARNONONES B

BEFREFODNEBRES

B |[F: |BLonG EcRross IS
For Help, press F1 4P| [NUM[scRL

Output Window Background tasks

HHEEHDEEREAMEM HELADLD GdEa®a PORBRVORNFH S AQuivila

(& [ese [ [green L En S M B M3 = e

[ pran1 [=][®@][=] [ Perspective 2 [o]@][=]

RS Bl reuserslaeN=nmE

B

£ Section LONG "RS1 Strs->intl" =N |22 | || & Section CROSS =R [EcH ==
BxEl EEPllERAEEKERE (Bl EEpRAERREREKERE
|

\
1
|
Lo
|
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13.1 Model Profiles

In the Section CROSS View Button Area, click LB on the Menu button to bring up the View menu. Click

LB on Profile =>Model strings. The Profile Model on Section panel will display.

If necessary, move the panel away from your Section CROSS view so that it does not obstruct the view.

+fl. Profile Model on Section E = @

Model
RS Sects = pop up. Double click LB on RS1 Sects.

Dynamic profile

Your Section CROSS view will look as follows

EH Section CROSS "RS1 Sects-> design 21.86" =N e =

This is the cross section through your road at chainage 21.86 (the first section along our design).

View [CROSS (8] Place the cursor on the model icon for the Model
— field and click LB. A list of available models will

Pickstring  [RS1 Sects->design 21,86 (&)
Itemn no. |1 ||
Itemn chainage |21.86 |Q_T|
Highlight o] Fit view | Autopan Now click LB on Next and observe the Section
[Finished CROSS view. The first design cross section will
now be on display and highlighted white
[Prev| [Met|  [Finish| [Help] play grie

Now each time you click LB on Next, the next cross section along the road will be displayed. Try doing
this a few times and observe what happens. Observe that the view is refreshed each time so that the cross

section fully fills the window.

Try clicking LB on the Highlight tick box to turn highlighting OFF. You will notice that the cross section

string displays its normal colour (cyan) rather than the highlighted colour.

The Item no. field in the Profile Model on Section panel just gives the number in the list of the profile
string in its model. It will increment/decrement as the Next and Prev (for Previous) buttons are selected.

The Item chainage field in the Profile Model on Section panel displays the current chainage of the profile
section. This field allows the input of a chainage from typed entry. A value can be typed in, followed by
<Enter> and if there is a section of the entered chainage then that section is profiled. For example, typing

100 <Enter> moves the profile to chainage 100.

Also note that when the Highlight field is ticked on in the Profile Model on Section panel, the profiled

section will also highlight in any Plan view that the model RS1 Sects in on, For example Plan 1.
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We have the ability to link the Section view to Plan views by ticking on Dynamic profile in the Profile
Model on Section panel.

Then when you move your cursor along the sections from the model RS1 Sects in the view Plan 1, the
closest section will be profiled in view Section CROSS.

1 = || B e @ Perspective 2

& | | v

\ cursor is closest to

the section with
chainage 10

»fl. Profile Model on Section EI = @

View [CROSS
Model [RS1 Sects

ion LONG "
S Dynarmic profile

[RS1 Sects-> design 110
11
[110

1
the section 110 is now I".
Highlight W] Fit view Autopan profiled in the section I'L__‘

view |

| Model <RS1 Sects> exists

[Finish|  [Help]

As we asked for cross sections at 10 metre intervals when we generated the road, that is the increment that
sections are being displayed at. There will also be additional cross sections at tangent points etc.

We will now improve the legibility of our view. From the View Button Area of Section CROSS, click LB
on Toggle. Move and pin the menu to one side so that it stays visible.

Toggle "CROSS" B Click LB on Grid to turn the grid on. The spacing of the grid will default to 100 in
Grades [on] both x and y directions. Set the Grid x spacing to 5 and the Grid y spacing to 2

HG [on] metre. (See 11.1 Section Profiles on page 159. for information on how to

VG [on] access and change your grid settings).

éx Click LB on 2x to change your vertical exaggeration to 2 to 1.

X

S Click LB on Grades to annotate the section.
;gi From the View Button Area of Section CROSS, click LB on the + sign button and
Exagaeration turn on model tin GROUND. This will display the natural surface (the green
an?m] """"""""""""""""" string) on the cross section. The cross section string is cyan.

Your view should now look as follows
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& Section CROSS "RS1 Sects->design 110" =N ol

Zoom in on the text area to see it more clearly. When finished click LB on Fit to return to the normal scale.

From the Profile Model on Section panel for CROSS, click LB on Next a number of times and observe
your road sections.

If preferred, you can untick the Fit View tick box in the Profile Model on Section panel and the scale will
remain the same as you go from section to section. This can be useful when you have the grid turned on. If
your sections are on a longitudinal slope, the sections may walk off the view as you go from section to
section. Normally you will want the Fit View tick box turned on so leave it that way when finished.

Note that the various views are still linked. To see this properly, you will need to turn off unnecessary
models in your Plan 1 view. In the View Button Area of Plan 1, click LB on - and click LB on RS1 Strs.

Put the cursor back in your Section CROSS view and move the cursor backwards and forwards laterally.
You will see a cross in the plan view moving along the section string of the section you are currently
viewing in Section CROSS.

Another way of selecting the model of strings and the first string to profile for the Profile Model on
Section panel is to actually pick the string. This is what the Pick button is for on the pane.

To try it, in the Profile Model on Section panel click LB on Pick. Then move the cursor to the
Perspective 2 view and click LB on any one of the cyan cross section strings. Click MB to accept the string
chosen. The Section CROSS view will refresh with the chosen cross section and the model containing the
selected string is written to the Model field on the panel. The Item no. and Item chainage fields will also
be updated.

You can combine Prev and Next commands with Picks to move around your sections.

Click LB on Finish to terminate the Profile Model on Section panel.
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13.2

13.3

Quick Model Profile for the Section View

There is also a quick method for profiling model strings.

If a string is selected for profiling using the standard Profile button in the View Button Area of the Section
View, the model containing the profiled string is also recorded by the view.

Clicking LB on the Previous String and the Next String buttons in the View Button Area of the section
view then profiles the previous/next string in the model in the same away as the Prev and Next buttons on
the Profile Model on Section panel. The profile sections are automatically fitted to the section view but
are not highlighted.

Profile string Previous string Next string

N\ /
£ section CROSS w W/ ==l
B ERERE RS EEARE)

Extend the Profile in the Section View

It is possible to see more of your natural surface than is currently on display. To see how this works we will
extend our view 5 metres on the left and 5 metres on the right.

In the Section CROSS View Button Area, click LB on the Menu button to bring up the View menu. Click
LB on Settings =>Extend. The Section Profile Extend panel will pop up.

B Section Profile Extend | = e

Place the cursor in the Extend Left field and type 5 and

= |CROSS = press <Enter>. Then type 5 for the Extend Right field.
Extend Left 5 e Click LB on Set to activate the settings. Click LB on
Extend Right |5 e Finish to terminate the panel.

|
[ set | [Finish|

4

To see the new settings in action click LB on Fit in the View Button Area. As shown below, the view now
extends beyond the extremes of the section being profiled. This can be useful in checking how the new
design encroaches on other existing constraints. Remember that it is possible to turn on any other models
in this view and 12d will show where the strings in these models cross this particular section. We will
investigate this further in the next Chapter 14 Services Interference on page 177..

& Section CROSS "RS1 Sects-> design 110" =N ol
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14  Services Interference

12d provides facilities that permit you to check for interference between existing constraints such as
underground services and your new road design. Any underground pipes or cabling for instance can be
included as strings in your overall terrain model. It is then possible to check the clearances in any of the
12d views.

14.1 Addition of Services to the Terrain

Most of the breaklines and points that we imported at the start of our design were on the natural surface,
however there was also some underground features, namely two strings that represent a 250 mm water
pipe and a 225mm diameter underground sewer.

These strings were mapped as super strings with an associated diameter when we import them into 12d,
however they could be converted to pipe strings inside 12d.

In view Plan 1, turn on the Plan1 o= ]
models ALIGNMENT,
survey SEWER PIPE and
survey WATER PIPE.
Turn off the road strings
and sections models RS1
Sects and RS1 Strs.

The blue line is the 250
mm water pipe and the
brown line is the 225mm
sewer.

The make things easier to
see at this large scale,
toggle off Text by clicking
on the Toggle button and
then clicking on Text [on]

{ PickOps [=]
Segment4 | Segment =
Tinable (n/a) b
Accept Visible (n/a) L
Rectart Radius (n/a)

Typed inpul | Diameter (string=0.225)
_ Colour (string=brown)
FingAsy nan| | 7ext (n/a)

@ check the diameter of each string go to Strings =>Inqui§

fo r
(or press F2) and select one of the pipe string segments. The EH:ET\E: (n/a)
information panel pops up, but it gives us no information Vertex ID Delete
about the diameter. To see the diameter information, click the Chainage | |pdend
RB anywhere on the screen. Walk right on the Segment menu | [-tn) peints | | Bxtend Ht
and the diameter of the string is shown. 1| +(n) points
You can click on this or any of the other options to make 1 Intersect
cKhanges to the string properties. / {|Perpen
||5naps Cad »
Cancel
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14.2 Profiling the Services

It is possible to get a quick picture of the services just imported by profiling them on a section view.

From the View Button Area in Section LONG click LB on Profile. Put the cursor over the blue pipe string
in the Plan 1 view and click LB. Then click MB to accept the highlighted string. Your Section LONG view
will appear as follows.

ju]ld]

Al

::%\

a]n]
=) =) =) =
=) = =) =
— [ [ =t

This is a longitudinal section through the pipe showing the depth below natural surface. If we turn on the
design strings, RS1 Strs, in the section view, we can instantly see that we have a problem.

a1t
Pl
::Q:;_:: +
+ +
. +
+
+
+,_|-,dJ-r
6@ *
= =) = =
= =) = =
- I I -+

The points on the screen represent the design strings at right angles to the profiled water pipe and hence we
can see that the water pipe is above the road design.
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14.3

View Services in Cross Section
We will now look at our underground services in cross section in the Section CROSS view.

First we need to modify our Plan 1 view to add the string we wish to select. Click LB on the + sign button
in Plan 1 and turn on RS1 Sects. Then Zoom in on Plan 1 view so that we can pick cross section strings in
the vicinity of where the underground services cross our new road. Zoom in on the area shown. When you
zoom in far enough you will notice that the pipe strings now appear as two parallel lines i.e. they have a
diameter in Plan.

We currently have the text turned off on Plan 1 so the alignment string chainages are not being displayed
so we now show another method of displaying some information about the strings on a view without using
String Inquire using Data Tip.

On the Snaps toolbar turn on D snap (or on the Snaps menu, turn on Data tip):

(2] (i (o (e (e (0] (1) (5 (@) (d () (2] () (M)

and as you hover near strings in a Plan view, a Data tool tip will be displayed showing information such as the name,
model and x, y and z value of the string near the cursor.

Data tool tip

design 180
AS1 Sects
42818.243
37385.703
62.085
62.085

From the Data tip we can see that the name of the section closest to where the water pipe crosses the
alignment string is design 180. This means that it is the section at alignment string chainage 180.

Now we will set up Section CROSS to display the appropriate cross section and pipes.

In the View Button Area of Section CROS’, click LB on Profile and point to the cross section string in the
Plan 1 view that is closest to where the cyan string crosses the road centreline. From the Data tip it can be
seen to be the section design 180. Pick and accept this string.

Now add the models survey SEWER PIPE and survey WATER PIP to Section CROSS. You should
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now see a small blue dot on the view at level 64. This is where the 250 mm water pipe crosses the section.

Your Section CROSS view should now look as follows:

s )

4] Section CROSS "RS1 Sects->design 180" (o= == |

BELz2 kRN EREAEKEEEE

(250 mm water pipe)

S

Zooming in closer the pipe is shown as

What this represents is not only where the section cuts the Water pipe but also where a parallel section a
little bit to the left and the right of the section also cuts the Water pipe. This will be discussed in more
detail in 14.5 Setting Corridors on page 182.
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14.4

Viewing Interference with Services in Long Section

We can also check for interference in the long section. The invert of kerb string is the lowest point in the
fixed portion of our road cross section. We will now profile this string and look where the services appear
in our long section to check for interference. Turn on the model RS1 Strs in view Plan 1.

From the View Button Area in Section LONG click LB on Profile. Put the cursor over the dark blue iokr
string in the Plan 1 view and click LB. Unless you zoom right in, you may need to press the LB several
times to cycle through the selections until you get the iokr string. Remember to keep looking in the info
panel to ensure you have the correct string, then click MB to accept the highlighted string.

In the same Section LONG view, click LB on the + sign button and add the models survey SEWER PIPE
and survey WATER PIPE to your view. You may see some orange and cyan dots added to the view
Section LONG as it refreshes. At this scale they are very small so zoom in around the 200 x grid line and
they will start to appear.

Section LONG "RS1 Strs->tokr” [ |- =[]
BE=le [EeERe %N E
it

e TR
T

L

5@
@ = ) ) = = = = @
49 = o) o] o] ! ! ! & &
Ll LS| LT =1 LT 1L 1 Lt L))

First note that the pipes appear in the section views. The reason that they appear as ovals and not circles is
that we have a vertical exaggeration of 10 to 1 set on the view.

-,

Section LONG "RS1 Strs->tokr” [ &[]

B =l ) EeER AR @ X ) @ (E

. \
!

a1l

= @\

S &
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14.5

Setting Corridors

Rather than seeing just a thin slice where the pipe crosses the section, 12d has the concept of setting a
corridor width along a profiled string. Then whenever you profile a string in a section view, everything
that appears within the corridor width will be projected onto the view and drawn. We will set a corridor
width of 20 metres either side of the string being profiled to see this more clearly.

In the Section LONG View Button Area, click LB on the Menu button to pop up the View menu. Click LB
on Settings =>Corridor and the Section Corridor panel will pop up. Note that the values for Width Left
and Width Right are currently 0.01.

Double click the LB in the Width Left field and type 20. Press the Tab key to go down a field and type 20
for the Width Right. This has now defined a corridor 40 metres wide.

s B
‘il Section Corridor A ]
View [LONG
Width Left [20
Width Right [20
Overlap Left .01
Overlap Right [0.01
Chord/Arc tolerance |g.02
[ Finished
| set | |Defaults) | Finish | | Help |
L

Click LB on Set and the view will be updated. Click LB on Finish to terminate the panel.

The Section LONG view should now look as follows.

-

E&] Section LONG "RS1 Strs->tokr” (o= =]

BeE = g% e E
™~

e

T
=

S~

Whilst it may not appear obvious, the blue string now appears in the view as a tube. This is because much
of the pipe appears in the 40 metre corridor is shown in the view. Zoom in on the pipe for a closer view.
Click Fit when finished Zooming.

1
2EIE

Remember that once a corridor for a view is set, it continues to remain set until changed, regardless of
which strings are subsequently profiled.
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15

Modification of Design Parameters

We will now perform a typical redesign operation and see how efficiently 12d handles such tasks. We will
modify the vertical geometry of our road centreline to pass over rather than through our services.

We will rearrange the views and the information on display in our views.

Minimise the views Section CROSS and Perspective 2 leaving the views Plan 1 and Section LONG. Then
tile them vertically.

Helpful Tip: Before Tiling, click on the View that you want to be on the left had side of the tiling. That
will give that view the focus and Tile Vertical puts the view with the focus as the first view.

In the Plan 1 view, ensure that the ROAD 1 Sects and Strs are turned on.

In Section LONG reset the corridor to the default values 0f 0.01. Also set the Exaggeration to 5x. Ensure
that the alignment string is profiled and that the survey SEWER PIPE and survey WATER PIPE models
are turned on.

We will now profile the road centreline RS1 on the Section LONG view and also bring up the Edit SA
menu for the RS1 in the one step.

On the Section LONG view, bring up the view menu and select Utilities =>VG edit.

The VG Edit String panel then appears asking you to select the string to be profiled and edited. In the Plan
1 view, pick and accept select the string RS1. You may need to zoom in to make it easier to select RS1.

The Edit SA menu for RS1 will pop up.

Move the Edit SA menu to the upper left area by clicking and holding LB over the words Edit SA, moving
the cursor and pinning it by releasing LB.

Your overall screen layout should now look something like this

AN DERSEANRONONSF

*fl. 12d Mode! 5M 11.0C1b (nt.86) - Project "C:\12d\11 00\ Training\design\getting started basic\STAGE 1\STAGE 1" - Client "12D Solutions - Lee" (=N R
Project File Edit View Models Strings Cad Tins Survey Design Drafting Plot Report  Utilities User Window Help
\ (8] [eaze =4 [green ] Fn = E EFERSIE D EHE
T ANV SR CERsRaRRE R I P 2OR2RQ@TURI !
M e A 1%
Lj'c, PLBEBLIDT ! 5 ? v | |mess) | A Section LONG "ALIGNMENT->Rs1" = (==

B=Q

Bsec.. [@ [ @ ZZTIEP&'.H 2= :@]

TREFOSNEEHS

ERZAEEEE 4

Output Window Background tasks

CAP||NUM||SCRL
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15.1 Modify Vertical Geometry

We are now ready to begin modifying the road geometry. We will raise the level of the road in the vicinity
of the pipes by inserting a new VIP into the alignment. We could do this by Inserting a VIP using the
cursor but it is more realistic to add it in at the same grade as already exists between VIP’s 1 and 2.

Note that this grade is displayed at top of the view Section LONG and is -0.681%.

So from the Edit SA menu click LB on Add/ Edit SA ALIGNMENT->R0OAD1
Remove IPs =>Insert VIP Grade. o
e P LB B~NE IO
—ﬁ‘é;———\—_——_——
Lo p=@)9)[&) @)@ (%
{s* T
A,
N
¥
Al
| Insert VIP Grade |
b4
7fl. Grade Insert VIP mEsm
Fill in the panel as shown S -
Start VIP [ [p=3 |
We will insert a new VIP on the same grade as VIP1 Grade =
to VIP 2 and at a chainage of 202. -0.681 |/£|
Mode hai
Click on Insert then Finish once you have filled in [chainage |§|
the panel. Value 202 |£|
|
|In5ert| |Fini5h| | Help |

The Section LONG view should now look as follows

=] Section LONG "ALIGMMENT->RS1" =N =R
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TS AR S = 4
i & | — i From the Edit SA menu press LB on the Move/Edit icon then
= = | | G select Change Curve.
e = c
e

;\&
-

Point to VIP 3 and click LB and confirm it with MB. A panel will pop up prompting New length. Type in
the value shown.

- Press <Enter> to terminate data entry. A vertical curve will appear
. Typed Input @ in the view. Click LB on Fit to ensure that all information in the

Length [130 [ | view is updated.

Edit SA ALI
fé*, &, 4 As VIP 2 is on grade between VIP 1 and VIP 3 it is not needed and

; hence we can delete it from the section view. Press LB on the Add/
Remove IPs icon and select Delete from the toolbar, and then select

VIP 2.

Note that the vertical curve on VIP2 is also removed.

The Section LONG view should now look as follows
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15.2

Recalc after Modifying Vertical Geometry

We will investigate one of the most powerful features of 12d. You will remember that earlier we defined a
template to be passed down our road centreline. When we filled in the template panel we gave the template
function a name - we called it RS1. The purpose of that name will now be shown.

We can now refer to the template function by name and get it to reprocess the series of steps it needed to
calculate the road geometry from a single menu click!

From the main menu, click LB on Utilities =>Recalc =>Recalc =>RS1. You can also walk right on
Recalc in the Recalc Panel and select the function RS1.

You will notice that 12d goes into a heavy compute operation. After a few seconds, the various plan and
perspective views are all updated and now display the redesigned road. At the end of the calculation, the
Apply Template panel will pop up

78 Apply Template for "RS1" 5 12d advises you of thf? new cut and fill
c -6758.326f 7834.472b 1076146 volumes a.SSOClated with this
recalculation.

Click LB on OK to remove the panel.

If we now repeated any of the operations we did earlier such as the string drive down the road or the
profiling of sections, we would be looking at the revised data. It is strongly suggested you try this in your
own time to convince yourself that all of the data have in fact changed!

If you unminimise the view Section CROSS you will see that during a recalc, the view Section CROSS
goes blank and is then redrawn. This because the string being profiled (design 180) is deleted and is
recreated as a new string when the function RS1 is rerun. The section view senses that the original string
has been deleted and finds the string with the same name in the same model and profiles it.

It is worth noting that if we had used multiple templates and restricted each template application by
chainage to only part of the road, we may have needed multiple template functions to achieve our full road
design. This is more typical of what happens in a real world situation. In such case, it is possible to process
all template application functions in sequence with a single menu click.

You would do this from the Main menu by clicking LB on Utilities =>Recalc =>Recalc all or click on
Recalc all in the Recalc Panel.

OR better still, use the option Design =>Apply =>Apply MTF which is part of the Alignment Module.

Important: Each time you perform a recalc, all of the string data that is calculated by 12d is automatically
deleted and replaced by new data. This is unlike most other processes in 12d where if you repeat an
operation such as importing a string or creating a string manually, you end up with multiple copies of
coincident strings.

We saw above how we can modify vertical geometry and get 12d to automatically recalculate our revised
road design. We can also change the horizontal geometry and get 12d to update our section view. We will
now perform a series of more complex changes that are typical of the redesign steps required in a real
world situation
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15.3 Modifying a Vertical curve by Moving the Tangent Points

We will now look at how we can pick up points with the cursor and use the mouse to visually place curves.
First Zoom in on the area shown in the example below.

I .1

E Section LOMNG "ALIGMNMEMT->R51" = || =] &

150 . ADFL

YCT 33

b, £ BB £ From the Edit SA menu click LB on Move/Edit =>Move Tangent. Place the
cursor on point VCT 3 (Vertical Curve to Tangent point) as shown above and
click LB. Click MB to confirm the selection. Then move the cursor to the left
and right and observe what happens. Through excessive movement of the
cursor it is possible to create a vertical curve that interferes with its adjoining
vertical curve. Whilst 12d will permit you to make such a change, the
template function will not proceed when you attempt to create the road. To_
ensure that the template function can work, it is essential that your vertical

geometry is meaningful.

Move the cursor to the right slightly to minimise the length of tangent

between adjoining curves i.e. minimise the distance from VCT 5 to VTC 6

; BE (Vertical Tangent to Curve point). Pin the tangent point down by clicking
i) LB. Click LB on Fit to fill the view.

Move Tangent §&%

e i
Alternatively to get the tangent point to exactly match the chainage of VTC 6 use the Tangent Wizard option
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; Click LB on Move/Edit =>Tangent Wizard.
Wb L BB # Click on IP 3

Tangent Wizard
H

The curve length will change so that the two tangent points are at the same chainage. This may be either
VTC 3 or VCT 3 depending on the geometry.

View Section LONG should now look similar to this

=] Section LONG "ALIGNMENT->RS1" == EcH =

After practising moving TP’s with the mouse, you should reset your VC length back to 150 metres. Click
LB on Move/Edit =>Change Curve from the Edit SA menu, click LB on the VIP you just modified and
MB to confirm the selection.

X| Type 150 and press <Enter>. Click LB on Fit to refresh the view.

Length |15|:| ﬂ
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15.4 Changing Template Widths and Introducing a Table Drain

The following steps are designed to show you how to modify template values and how to introduce new
links in a template. We will make a copy of your existing templates and then edit the copies to make the
template changes. This way your original templates are left unchanged should you need them again

PERFORMING TEMPLATE CHANGES MANUALLY

From the main menu, click LB on Design =>Templates =>Copy and the Template Copy panel will pop

up.
“8l, Copy Template (=== In the Copy Template panel, click on the Old template icon
Old template  [FULL LEFT and select the FULL LEFT template.
New template [LEFT \W TABLE DRAIN In the New template name field type the name FULL LEFT
| W TABLE DRAIN. Click LB on Copy.
[Copy] [Finish] [Help]

u‘a" Copy Template EIE@

Old template  [FULL RIGHT Repeat the process and copy FULL RIGHT to FULL
RIGHT W TABLE DRAIN. Click LB on Finish to terminate
the Copy Template panel.

New template [GHT W TABLE DRAIN

[ template copied

[Copy] [Finishl [Help]

From the main menu, click LB on Design =>Templates =>Create/Edit and the Template Create/Edit panel will
pop up.
In the Template name ficeld, click on the icon and select the FULL LEFT W TABLE DRAIN template.

P

#fl. Template Create/Edit o] @ (]
Template name [FULL LEFT W TABLE DRAIN (B =
Select Template Ed
|
| Fixed || Decisions || cut || A0 |[Final Cut/Fil  [FOCL
— FULL LEFT
Eanish FULL LEFT W TABLE DRAIN
FULL RIGHT
FULL RIGHT W TABLE DRAIN
1 T ¥
[ Select

We will confine our changes to the Fixed part of the template. Click LB on Fixed.

The Fixed Template panel pops up. The panel displays the template links we used earlier in the tutorial
(see 10.1 Creation of Basic Templates on page 149).
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Width | Height | XFall % | Name | Colour
1(3.5 -3 lokl cyan
2]045  -0.04 ikl | dark blue .
3004 015 tokl | blue .
4011 0 bokl | green .
5|46 25 bofpl | dark green .

[el][io] (] (<) [#]

lok
1K)

CcL

bofol

| valid colour

y

Position the cursor over the
Width entry on line 5 and
click LB to lock the cursor
into the field. decrease the
footpath width from 4.16 to
3.5 metres.

Press < Enter> 5 times so
that a new line appears in
the template, or click on the
Inset row below icon.

Type in the details for the row 6 for the table drain string iodl as shown in the example.

Click LB on Draw to update the diagram

o

m: Fixed Template - "FULL LEFT W TABLE DRAIN"

E=]

4

Width | Height | XFall % | Name [ Colour
1(35 | optiona -3 okl Eq,ran
2(045  -004 | 'f'iokl darkblue [
3004 0. g ‘tokl  blue
o | bokl  green
513.5 | ;2.5 :bofpl édark green [
F 7 1 i iodl | ||

AEXER) &

CL
lokl

bofpl

iod|

[ valid colour

P

Select OK to exit the panel.
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Repeat for the fixed part of the FULL RIGHT W TABLE DRAIN template (shown below)

Width | Height | XFall % | Name | Colour

35 -3
0.45 -0.04

004 015

011

35 25
2

lokr
iokr
tokr
bokr
bofpr

iodr

cyan
dark blue
blue
green
dark green
dark blue

[e1] 0] (X] [¢][%]

S £ g E
] g £
[ valid colour
Apply Help

y

That completes the changes to our templates. Select OK to exit the panel

Click on Finish to close the Template Create/Edit panel.
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15.5

Recalc after Modifying the Template and Other Geometry Changes

Clearly we have now made significant design changes to the template and to the vertical geometry of the
road centreline. We need to get 12d to update the views to reflect these changes. Regardless of how
complex the changes are, all we have to do normally to perform a complete redesign is run the Recalc
function.

Since we have changed the names of our templates however, we must make minor edits to our
Apply Template Function to point to the new templates.

Before recalculating the changes, turn on the RS 1 Sects and Strs models in the Plan 1 view.
From the main menu, click LB on Utilities =>Recalc =>Edit fun =>RS1

The Apply Templates panel will pop up with the values in each field already filled in. 12d remembers the
values you entered earlier. You can now make any required changes.

':ﬂ:AppIyTemplateFunction E = @

Main |Models | Misc | Tin | Fiter | Plot |

Function name [Rs1 |fj|
Tin [GROUND (@)
— In the Left template field select the FULL
Left template
. g [FULL LEFT W TABLE DRAIN lgl LEFT W TABLE DRAIN template.
Righttemplate  [FULL RIGHT W TABLE DRAIN 2] )
- T In the Right template ficld select the
(1) (7], FULL RIGHT W TABLE DRAIN
Reference [ALIGNMENT->RS1 |£| template
| L&)
Start chainage [21.2605 |E|
End chainage 9285435 |£|
Section separation |17 |I|
Report file [RS1 Val.rpt |Z|
| c-10871458 f 7220650 b -3650.808 When complete, reapply the function with
[views |  [Apply|  [Finish| [ Help | the new templates by clicking LB on

Apply then Finish

At the end of the calculation, the revised cut, fill and balance volumes appear in the message line.

This time the cut and fill volumes are smaller and more closely balanced.

Note that in the views Section CROSS and Perspective OpenGL 2 you will now see the open channel v

drain running through the areas of cut. In the areas of fill, the drain will blend into the final fill slope.
[=7] Perspective 2 (=10 | I I | ]
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Now profile the invert of kerb string on view Section LONG to confirm that the road now lies above the
services.

From the View Button Area of ‘Section LONG’, click LB on Profile and LB on the iokr string from Plan
1 view. You may have to zoom to pick the right string

@ Section LOMG "R51 Strs-=iokr”

Clearly the road now lies above the services.

Finally click LB on Finish icon in the Edit SA panel. Click LB on Yes to confirm
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16

16.1

16.2

16.3

Using 12d on Typical Projects Involving Volume Calcs

General Cut and Fill Calculations

12d has many features that enable accurate cut and fill calculations to be performed. The easiest way to
manipulate data for volume calculations is via surfaces (i.e. TINs). For instance, a simple way to calculate
the cut and fill volumes on an earthworks project is to create a TIN of the natural surface and a TIN of the
finished design surface and get 12d to calculate the volume between the TINS.

We will now demonstrate how to do this with a practical example - designing a pad footing for a
commercial building.

Pad Footing Design Prerequisites

Note that if you are jumping to this Chapter of the Training manual rather than working through it
sequentially, the only prerequisite for this Chapter is that the tin GROUND must already exist. This TIN
was created in 6.3 Triangulation on page 81.. All other data related to Pad Footing design is created
from scratch.

Alternatively, you can import the 12da ascii file Chapter_16.12da which contains all the models, strings
and tins created to date.

Pad footing Design using the Interface Function

The Interface function is the simplest form of geometry construction within 12d Model. Generally, it is
applicable whenever the batter lines are at a constant slope from top to bottom (no benching) and the
constant slope applies in all directions (i.e. a constant batter slope at right angles to the alignment string).

We will use a super alignment for our pad footing

We will generate this alignment in
order 1,2, 3, ...6.

The alignment will be a closed
alignment so once the IP at position 6
has been created the string will
automatically join back to position 1.
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From the Main menu, click LB on Strings =>Super Alignments =>Create super alignment. The Create
Super Alignment panel will appear

Select the General node

:ilj Create Super Alignment EIIEI@

=) Basic o
M General Name PADL Type in the name PAD1
- Chainage Model [PAD ALIGNMENT and the model name PAD
E:gal Colour yellow D ALIGNMENT
... Transition Horizontal linestyle 1 Select colour yellow
- Closure Vertical linestyle L
. Sync —I—
- IP defaults @

=) Advanced St
- Start 2
..End
.. Design
- Profiles
- Equality
- Pipe/culvert .

[Sameas] [ Finish ] [ Help ]

Select Label node

:ﬁ: Create Super Alignment El' =] '@

=) Basic
- General Label style na labels (= Select no labels for Label style

- Chainage l— N
.. Interval l=
® Label i
- Transition
- Closure l—

- Sync

.. IP defaults
= Advanced

- Start

- End

- Design

- Profiles

- Equality
- Pipefculvert

Select Closure node
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':ﬂ':CreateSuperAIignment El =] @

—J- Basic
.. General Closed string 7

Tick check box Close string

. Chainage to create a close the string

- Interval

- Label

.. Transition
- Synec

.. [P defaults
—J- Advanced

.. Start

.. End

- Design

- Profiles

- Equality
. Pipefculvert

[ Create | [ Many | [Same as| | Finish | | Help |

Click on Create and the Edit SA toolbar will appear.

feld. LB, B E£3MR ! %, ? v,
«

e
Append HIP
N5

Select Append HIP

X < )N f

The message at the bottom of the screen is

<Pick start IP location> [picks] [fast] [Menu]

Type in the start point coordinate 42560 36970 then press <Enter> (the Enter X Y Z box comes up when
you press 4)

:ﬂ: Enter XY Z: @

Enter XY Z : |4 2560 36970 first HIP

The first HIP point is then created and the message at the bottom of the screen is then

<Pidk IP location or (r)elative, (b)earing/distance > [picks] [fast] [Menu]
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We are now going to create the rest of the lines of the pad using Bearing and Distance rather than picking
points or typing in coordinate values.

First type b to put the editor into bearing distance mode

The bottom left of the screen prompts for a bearing

<Enter bearing> (tlangental (plerpendicular (clursor (n)egative (typed (d) 330° 5' 25" [picks][fast][Menu]

Type in the bearing 90 <Enter> (the Typed Input box comes up when you press 9)

la‘ﬁ_" Typed Input @
Enter bearing [op- [

The bottom left of the screen then prompts for the distance

<Enter distance > (t)angental (p)erpendicular {ight angle (cursor (n)egative (typed (d)66.1

Type in distance value of 50 then press <Enter> (the Typed Input box comes up when you press 555)

I:ﬂ_: Typed Input @
Enter distance [50 ﬁ second HIP

The second HIP is then created and the select reverts to cursor pick again.

The message at the bottom of the screen is then

<Pidk IP location or (r)elative, (b)earing/distance > [picks] [fast] [Menu]

We will continue typing in Bearing and Distances to go round the pad.

To type in another bearing and distance in we type b again and then 180 <Enter> followed by 15 <Enter>

+6l, Typed Input [£3a] || B Typed Input ESCE )
Enter bearing [iap- [ 5 || Enterdistance [15 [k

Then type in the following values of Bearing Distance values to finish the pad

|;ﬂ‘ T:'rped Input @ l:ﬂJ Typed Input @ fourth HIP
Enter bearing 770" E Enter distance |70 E
u‘ﬁ: Typed Input @ 'TEL' Typed Input @
Enter bearing [ig0° E Enter distance |35 H fifth HIP
7@ Typed Input ) o Typed Input =5 sixth HIP
Enter bearing [370° E Enter distance [3g m
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Press <Escape> after placing the sixth HIP to terminate the addition of HIPs (or click RB to bring up the
Pick Ops menu and select Cancel from it).

To see the string you just created zoom in on the pad footing area as shown below.

We now need to define the height of the pad. Firstly we need to get an idea of an approximate Z value to
be used for our pad footing elevation
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From the main menu click LB on Tins =>Inquire =>Height

=10} =
E _I_I_I Click LB on the icon for the Tin field and click LB on
Tin [GROUND @I GROUND from the pop up list.

| £=065.428 x=42582.630 y=36944.

Finishl Help I

&

Now place the cursor in the Plan 1 view inside the pad footing and note that the Z values on the tin range
from about 63 to 67.

4 Plan1 = = &=
El

:ﬂ: Tin Height Inquire

Tin [GROUND a
[2=66.024 x=42572.050 y=36939.331 tin=GROU

[Finish)| | Help |

To roughly balance cut and fill let us make an initial guess to set the pad footing at height Z=64.
Click LB on Finish to terminate the Tin Height Inquire panel.

We now need to give the alignment the height of 64. This is done in the Section view LONG.
Profile the alignment string in the Section view LONG.

Click LB on the Append VIP icon
in the Edit SA panel. fe . LB B € YOG ! N, ? V.
fie”
b6’

*| Append VIP

u_h

A
)4

X < %
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Over the Section view LONG, type in 0 64

This will bring up the Enter Ch Ht panel with
the values in it. Press <Enter>

Then press <Escape> to finish the VIP entry

Because the alignment is closed, just the one
VIP will suffice to define the height 64 for the
entire string.

Select Finish on the Edit SA panel.

»gl. Enter Ch Ht:
Enter Ch Ht:

To see how the pad footing aligns with the natural surface, click LB on the + sign button in the Plan 1 view
and double click LB on tin GROUND. From the View menu for Plan 1, click LB on Toggle =>Tin
contours. Your view should now look as follows

Let us assume that it is important to
have side 1-2 aligned as closely as

IS

Point 1 Point 2

possible with the natural surface
contours.

o, To achieve this we will rotate our

\
RN

pad footing clockwise by 40
degrees about point 2 (top right
corner) so that side 1-2 is close to
parallel with the natural surface
contours in the vicinity of point 2.

Select String =>Super alignments =>Tools =>Rotate.

Or if you turn on the Super Alignment Tools toolbar, Rotate can be selected from there.

Lom

i

Fa e —
L2 E =

[=
i

5
<,.+
L
Qs
64
e
4
G
&
+
g
a
[+
lq

In either case, the Rotate Super Alignment panel is displayed.
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'u.i: Rotate Super Alignment

[o]l O ]

Super alignment  [pAD ALIGNMENT->PADL

Crigin
i 4
-40°

W
[Finish |

| Help |

X coordinate |4261U

¥ coordinate |3ﬁgm

Rotation {cow)

[ "PAD ALIGNM

Click LB on the Super alignment pick icon and then
the PAD1 string from the view.

lick LB on the Rotation Centre icon and select
point 2

Type in the rotation angle to -40 degrees clockwise
. Click LB on Rotate to activate the rotation.
Click LB on Finish to terminate the panel.

Delete the previous alignment using option
Strings =>Delete

Your PAD1 string should now appear rot:

Your revised Plan 1 view should look as

\

We will now translate the PAD1 string +20m in the X direction and -30m in the Y direction to get our pad

ated.

follows

Z

footing away from the valley and more onto the ridge of the natural surface contours.

Select String =>Super alignments =>Tools =>Translate. Or seclect Translate from the Super Alignment

Tools toolbar.

In cither case, the Translate Super Align

Translate i

ment panel is displayed.

-

:i!" Translate Super Alignment

Super alignment  [pAD ALTGNMENT->PADL
Horizontal translate

Delta x 20
[-30

Delta y

Vertical tranzlate

ENT-=PAD1" 5
Finish Help

[ "PAD ALIGNM

Translate

== |

Click LB on the Super alignment pick
icon and then select the PAD1 string from
the view.

Type in 20 for the Delta x and -30 for the
—_ Deltay

Click LB on Translate to activate the

/ translation.

Click LB on Finish to terminate the panel.

Delete the previous alignment using
option Strings =>Delete
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Your PAD1 string should now have moved downwards and to the right.

o

Move your cursor over the Section view LONG and you will notice that the view automatically re-profiles
for the new string PADI.

This is because the previous two options have created new alignments and the string originally profiled on
the section view had been deleted. But even through the original string no longer exists, the section view
remembers the model and name of the profiled string and when the cursor is moved over the view, another
string of the same name and model is automatically searched for and profiled.

i "

=] Section LONG "PAD ALIGNMENT->PAD1" -2 S
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We can now have our first trial run to see how well our pad footing fits in with the existing natural surface.
Firstly we will set up the default corner angle for sections to be created at corners

From the Main menu, click LB on Project =>Management =>Defaults

u‘ﬁ" Defaults EIE@

Trash Settings l MName Settings | Defaults.dd |
Default Settings | System Settings l

Colour F D
Paint colour W D
Tin celour ﬁ D
Contour colour ﬁ D
Contour bold colour Iblue= E]
IO null height EC
Text height (pixels) o
Chord/Arc tolerance l(]1=
Culling ]
E::.:? :::liplx] 45— Change the Corner angle to 15
Weed tolerance o Click LB on Set then Finish
Section view exagg l]_(]=
Perspective view exagg |1=
Cut volume sign W E]
Use density drawing El
I

|

From the Main menu, click LB on Design =>Apply =>Interface

The Interface Function panel appears.

e _ - — | We need to give our interface function a name so that we can refer
e T——— L= [LELEER T o it later. Type in the name PAD1.
Function [PAD1 Select the alignment string as the String Interface
String Interface _
I RLIGNMENT > PAD1 The default Section separation is 10 metres. Set this to 2 metres.
Cut slope 1vin [1
Eill slope 1v in - | As our pad PAD1 string has been generated in a clockwise manner
_ ? _ L (from starting point 1 to 2 to 3 etc.), we are looking to calculate the
crlmeEE T B intersection of our batter lines with the GROUND tin on the left of
Search distance [100 the string (left as we proceed in a positive direction along the string.
left o right fleft E] Positive direction is always in the direction of increasing chainage).
Tin [GROUND Click LB on the Tin button and double click LB on GROUND from
Model for interface  [pAD1 INT the popup list.
Model for slope lines [pAD1 SECTIONS Finally supply the name PAD1 INT to the Model for interface
field. The interface string corresponding to where our batter lines
Remove loops

meet the GROUND tin are placed in model PAD1 INT. (Optional)
| finished interface Slope lines are placed in model PAD1 SECTIONS.

[Interface] [ Finish ] [ Help

Tick on Remove loops.

Then press the Interface button to generate the Interface string.

After a short delay, the panel message box advises ‘finished interface’. Click LB on Finish to terminate
the panel
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To see the interface that has
been calculated, click LB on the
+ sign button in the Plan 1 view
to pop up a list of models.
Double click LB on models
PAD1 INT and PAD1
SECTIONS.

.
We will now observe a very powerful design feature of 12d Model. We will make some major changes to
our pad footing and see how quickly 12d can redo its calculations with a minimum of effort.

First, we will change the shape of our pad string. Remember that we rotated our pad footing 40 degrees.
We will now change point 4 by moving it 10m towards point 3. Because of the rotation, line 4-3 is at a
bearing of 130 degrees.

Go back into the Super alignment editor

| NI Y AT LRERE, Click LB on the Extend by Length icon
[ a = 4 * HEa ‘,A

Pick near IP at position 4 but on the straight
leading from position.

The Typed Input panel for Length comes up.

“fl, Typed Input [

Length |.1p [

Type in -10 <Enter>
Finish the alignment Editor

Plan1 =R
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The Interface function can now be recalculated by selecting Utilities =>Recalc =>Recalc =>PAD1.

12d will now recalc the pad interface using the same properties set in the Interface Function panel
previously.

] Plan 1 E=B|E=R~=)

B =)&) €& |[@) (@)% X)) = E

As the Horizontal Geometry of PAD1 was modified, the profile through the tin was automatically updated
in view Section LONG. And although we didn’t have Vertical synch turned on for PAD1, because the VG
was a constant z-value for the entire HG, the VG is still in the correct position

If for some reason the modified HG and VG appeared incorrect, the profile can be updated in the Section
LONG view by simply clicking LB on the Regen icon.

I Section LONG "ALIGNMENT->PADL"_  __— Regen = [ & | [5]
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16.4

16.5

Volume Calculations from Surfaces Created with the Interface Function.

Now that we have batter, pad and interface strings, it is a simple matter to create a TIN of our finished
design surface and perform volume calculations.

Creating a TIN of the Finished Quick Pad Footing Surface

Rather than specifying a list of models, we are going to use the data on a view to create the triangulation.
that way we can visually check that we have the correct models.

To ensure that only the correct strings are used in the creation of our finished TIN, we will first take all the
models off the view and then selectively add the appropriate pad footing strings and sections models to the
view.

The fastest way to do this is to click LB on the Menu button in the View Button Area of the Plan 1 view to

popup the View menu and click LB on Models =>Remove all models. Then place the cursor over the +
sign button in the Plan 1 view and double click LB on PAD ALIGNMENT, PAD1 INT and PAD

SECTIONS.

Since these are the only models on display in View Plan 1, we can confidently build our TIN by
triangulating the view.

From the main menu, click LB on Tins =>Create =>Triangulate data

-~

Give the triangulation the function name TIN

7

o || =

I:il' Triangulate a Data Source

General | Data ] Nulling]

Additional settings

| ok - no Tin <PAD1> exists

ITrianguIate] I Finish J I

':l: Triangulate a Data Source

General Data |Nu|ling|

Data to tnangulate

View |1

PAD1

Position the cursor in the New tin name field and

Retriangulate function [TIN pADL type in PAD1 and press <Enter>. This name will
Mew tin name also be used to fill in the Model for tin field but
T col :F'ADl with the prefix "tin ".

in colour orange

i — Click LB on the colour icon and select orange.
Tin style [1
Modzl for fin ftin PADL Click on the Data tab and set the

Data to triangulate to View 1.

Click on the Nulling tab. To ensure that the pad

P tri ¥ R bubbl . . -
rESEN_E e E_mwe HERES O TIN is restricted to within the bounds of the
Weed tin [] Triangle data ([ interface string defining where our pad footing
Cell method [7] Colour by triangle data [ intercepts the natural surface, click LB on the
Null polygon button and select with LB the red-
reen closed int tring surrounding the pad
Create many E g interface string surrounding the p

footing.

(=] O (=

Ia‘ﬁl Triangulate a Data Source
General l Data Mulling |

Apply nulling  [7]
Angle |5 2
Length | 100

Combined angle +3|:|= 2

Combined length |20

Null polygon  [PADL INT->interface

Make sure that the string you select has the correct string name PAD1->interface and is of type Interface

Page 207
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16.6

as shown in the Nulling tab. If necessary, keep clicking LB until you get this string. Once you have it, click
MB to confirm the selection.

Then click LB on Triangulate to create the TIN.

The triangulation will occur and the Triangulate a Data Source panel replaced by the Retriangulate Tin
panel for Tin PADI in case you want to modify any of the parameters. Select Finish to remove the panel.

To display the TIN, click LB on the + sign button in the Plan 1 view and double click LB on tin PAD1
from the pop up list.

The TIN on the view will currently be displayed with contours and not triangles
To see the triangles, click on the toggle icon and turn off Tin contours.

The finished TIN should appear as shown below.

Volume Calculations Between Surfaces

Now that as we now have two tins, GROUND and PAD1, we can get 12d to calculate the volume between
the TIN surfaces. 12d provides two methods of calculating such volumes:

End Area: Here parallel sections are taken at a constant user defined angle from the X axis (angles are
measured anticlockwise from the X axis) with sections a user defined distance apart. When calculating end
area volumes, the quality of the answer is highly dependant on the values chosen for the angle of the
sections and the distance between sections.

Exact: In this method exact volumes are calculated by summing the volumes of the various prisms
between the triangulated surfaces. This method is exact in that it is as accurate as the TINs themselves.
Depending upon the overlap between triangles in each TIN, each triangle may be split up into multiple
prisms. All prisms are accounted for hence the term exact.

We will use both methods and compare any differences.
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16.7

End Area Volume Calculations

To enable string selection to be easier, first turn off the tin of the PAD. So click LB on the - sign button in
the Plan 1 view and double click LB on tin PAD from the pop up list.

To calculate volumes between TINs using end areas, from the Main menu, click LB on

Design =>Volumes =>End Area =>Tin to tin

-

u‘a" End Area YVolume Between Tins [o || = |[=]
Original tin [GROUND
Mew tin [PaD1
Angle for sections Igg=
Dist between sections 2
Original tin sections lxs ground
Mew tin sections s padl
Difference model [xs diff
Difference colour [magenta @
Use Extrapolated Areas ]

Clean zections models beforehand

gl

Poly PAD1 INT-»interface
Report file [PADL VOLUMES. pt
Report mode [summary @

Volume mode

2

|Average end area

| File <PAD1 VOLUMES.rpt> will be created

Fill the panel in as shown. Place the cursor on
the tin icon for the Original tin field and click
LB to popup a list of the available TINs.
Double click LB on GROUND. Repeat the
process for New tin and set it to PAD1

Leave the angle for sections at 90 degrees.
This will make the sections at 90 degrees to the
X axis i.e. parallel to the Y axis.

Set the Distance between sections to 2 as
this is a relatively small site.

Enter three new model names - xs ground, xs
pad1 and xs diff for Original, New and
Difference sections respectively. The cross
sections corresponding to each of these
profiles will then be stored. Entering a name in
the Difference model causes a series of
sections to be created that correspond to the
depth differences between the Original and
Final cross sections. Note that all these model
fields are optional.

Set the Difference colour to magenta.

Tick the checkbox for Clean section models
beforehand to clean out the section models
before running the option

A closed polygon can be defined to restrict the extents where the calculations will be performed. If a string
is selected that is not closed then the first and last points of the string are automatically joined to form a

closed polygon.

We can use the interface polygon for this purpose i.e.use the string which is the intersection of the pad
footing with the existing ground. Click LB on the select icon at the end of the Poly field then select the red-

green interface polygon in the Plan 1 view.

By entering a name in the Report file field, a report can be created showing the details of the end area
volumes. Enter PAD1 VOLUMES and press <Enter>. The suffix ".rpt "is appended by 12d. Set the report
mode to summary as we don’t need to see the volumes for each section. This would only be used if an

alignment is used for the section creation.

Click LB on Volume to cause the end area volumes to be calculated.

If a name is entered in the Report file ficld, 12d will immediately jump to the Editor and display the report:
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Project: STAGE 1

User: 1ig

organization: 12D Solutions - Lee
Date: sSun Nov 23 13:24:35 2014

Report File: PADL VOLUMES.rpt

————————————————————————————— BEGIN TIN-TIN VOLUME REPORT ———-——— e e
surface to surface volume report - (with plan polygon "PADL INT->interface")

original tin GROUND

new tin PADL

separation  2.000

angle 90° 00" 00"

method Average end area

extrapolated no

cut volumes and areas are negative
111 volumes and areas are positive

total plan area 1789, 026
total cut -1342.436
total fill 95.135
balance -1247.302
ie excess of cut over 411 1247.302

————————————————————————————— END TIN-TIN VOLUME REPORT ————-———————mmmm oo

Click LB on File =>EXxit to terminate the Editor and return to 12d.

Note that once the calculation is finished, the Cut, Fill and Balance volumes are displayed in the Panel’s
message line.

velume moae |Average endarea ||
| € -1342.436 £ 95,135 bal -1247.302
[ Volume | | Finish | [ Help |

Click LB on Finish to terminate the End Area Volumes Between Tins panel.

NOTE: We used a polygon for the End Area volumes but a polygon does not have to be used. If no
polygon is used then the volume calculations are restricted to the regions where both TINS exist.

It is possible to view the sections that were calculated during the end area calculations and it is always a
good quality check to see that the sections look reasonable both in plan and section.

From the View Button Area of the
Plan 1 view, click LB on the + sign
button and turn on model xs ground.

Note that the various cross section
strings display in green.

We can now profile any of these cross
section strings. We will use view
Section CROSS for this purpose.
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From the View Button Area for the Section CROSS view, click LB on Profile and then click LB on the

string top sect 23 in view Plan 1. Click MB to confirm the selection. Add the model tin PAD1 to the view
so you can see the section through the tin of the pad.

Toggle off the Grades and set the vertical exaggeration to 5. Use the menu on view Section LONG to
select the option Settings =>Grid and change Grid y value to 1.

The following view shows the profile of cross section 23 and its section through tin PAD1.

.

E Section LOMNG "xs ground->top sect 23" EI@

The tin GROUND is also on the view Section LONG but you won’t see it because the sections in the
model xs ground should be exactly on the tin GROUND.

If the model xs padl is also added to the view Section LONG, the section in xs pad 1 at chainage 23 will
also be drawn because it will be in the corridor around the profiled string 23 in the model xs ground.

This string will also not be seen because it is on the tin PAD1 however you will see crosses where the
vertices of the string are.

.

E Section LOMNG "xs ground->top sect 23" EI@

vertices of the string rom
the model xs padl

By clicking on the Next and Previous buttons on the view Section LONG, you can look at the sections
from xs ground and xs pad1 and quickly see that they all lie on the appropriate tin.

Note that for the End Area calculation, the cut and fill area for a section are the cut and fill areas between
the two sections shown in the section view. For this section, it is all in cut.

From the report there is not much fill so we will move the pad up to reduce the difference between cut and
fill (the balance). Then we will show how the Exact volumes calculations are done on the same pad.
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16.8

In the Super alignment editor for PADI,
select the icon Change Height.

Modifying Pad an Redoing End Area Volume Calculations

We will now move the pad up to reduce the amount of cut and achieve a better cut to fill balance. But

moving the pad will require a number of options to be repeated. They are:
1. Raise the Alignment PAD1

. Run the Interface function

2
3. Retriangulate the tin PAD1 using the new Alignment, Interface string and sections
4

. Calculate the end area volume between the new tin PAD1 and tin GROUND.

Step 1: Raise the Pad

First profile and edit string PAD1 by selecting Section LONG menu Utilities =>VG edit and then selecting
PADI. Or if PADI is already profiled on the Section Long then edit the string PAD1 by pressing F6, or
select Strings =>Editor on the Main menu, to bring up the Edit String panel. Then pick the string PAD1

from the view Plan 1.

The see the z-values more clearly on Section LONG, bring up the Grid panel by the Section LONG menu

option Setting =>Grid and set Grid y to 1.

fe | LB BFHYOEG !

N, 7 VL

Then in the view Section =] Section LONG "PAD ALIGNMENT->PAD1"

LONG, select anywhere on the Py e T T [ s e Tz e T s
|:|“|:| = 5 <":| |:‘|> ‘!3 E BT | tgz {
vertical geometry of PAD1. D=l > EERRa) ‘”\{H—Mk”

The Height Typed Input panel
will then come up with the
current height of 64.

Type in 65 and press <Enter>

:ﬂ‘ Typed Input

Height |55

The height of PAD1 will then change to 65.
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EZ] Section LONG "PAD ALIGNMENT-»PAD1" =N | Eoh| >

Step 2: Run the Interface Function

Because the creation of the Interface and the sections was a function, it only needs to be Recalced and the
new Interface and Sections will be created for the modified alignment PADI.

So walk right on Recalc =>Recalc and double click on the function name PADI.

Recalc B
Auto 4

Edit func .
Editdats | | UmeHons =
Recalc
Recalc all
Ueca ca RSy
SEr TIN GROUND

TIN PADL
Edit chain
Run chain

4 Inr 3

| Select

[Sameas]

The new Interface and sections are created.

Step 3: Retriangulate the tin PAD1

Creating the tin PAD1 was also done as the function TIN PAD1 and although the strings in the models

have changed, the new tin will be made up of exactly the same models as before. So recalcing TIN PAD1
will update the tin PAD1.

So walk right on Recalec =>Recalc and double click on the function name TIN PADI.
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Recalc [=]
Auto 4
Edit func :
S Functions =]
Recalc BADL
Recalc all
Ueca ca RS1
& TIN GROUND
TIN PADL
Edit chain
Run chain

[ Select ]

[Sameas]

Step 4: Calculate the New End Area Volume

The End Area Volume Between Tins panel is not a function and so will need to be brought up, filled in
again and run again.

So select Design =>Volumes =>End Area =>Tin to tin to bring up the End Area Volume Between Tins

panel.
So select . End Area Volume Between Tins (o || =[]
Design =>Volumes =>End Area =>Tin to tin Original tin [GROUND
to bring up the End Area Volume Between Tins Mew tin [PADL l@
panel again. Angle for sections ko- @
Dist between sections 2 lrl-;]
Fill in all the fields as before. Original tin sections li= ground l;]
MNew tin sections s padl E]
Notice that we ticked on Clean section models Difference model xs diff E3
beforehand. This is important now that we are Difference colour |[magenta [ ]
rerunning the option because it means the section Use Extrapolated Areas [
models are cleaned from the first run before the |
rerun. |
Clean sections models beforehand
Poly PADL INT-»interface %)
Report file [PAD1 VOLUMES.ipt [5]
Report mode |5ummary E]
Once the panel is filled in, select Volume and the ok ane RaLe |Average end area | &
new volumes will be calculated. | File <PAD1 VOLUMES.rpt> will be created
I Volume I I Finish I [ Help I

Because the Report file already exists, you are asked whether you want to Append to the existing file or
Replace it. Select Append.
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Report file £3

WARMING: The file [PADT WOLUMES rpt] already exists.

Wiould vou like to...

| Append || Replace || Cancel |

The Cut, Fill and Balance volumes displayed in the Panel’s message line and the report are now:

| € -339.429 f 886.456 bal 547.027

| Valume | | Finish | | Help |

Note that the cut and fill now differ by 547 cubic metres but this time there is more fill than cut.
Click LB on Finish to terminate the End Area Volumes Between Tins panel and close the report file
editor.

If you move the cursor over the view Section CROSS the new top sect 23 string will be automatically
profiled.

s "

E Section CROSS "xs ground->top sect 23" = || =] ER

Notice that some of the section is now in cut and some is in fill.
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16.9 Chains

Although the four steps to recalculate the volumes don’t take too long to go through, it would save time
and errors if the process could be automated, especially the volume calculation which is not a function.

To make things easy, 12d has the concept of Chains. Chains allow you to define a series of 12d options
that can be automatically run one after. Chains can recalc function, and also record and run most 12d
options.

So to automate the volume calculations, after we have modified the alignment PAD1 (Step 1), we need the
chain to:

2. Run the Interface function
3. Retriangulate the tin PAD1 using the new Alignment, Interface string and sections

4. Calculate the end area volume between the new tin PAD1 and tin GROUND.

To create a Chain, select “Fl. Create/Edit Chain = & ==
Utilities =>Chains =>Create Chain file | PAD1 End Area Volumes.chain Read
from the Main menu to
bring up the |
Create/Edit Chain panel. T P 0
. Always record parameters 1
Flll n the name Of the Run chain in interactive mode [
Chain file as: T [

PAD1 End Area Volumes (2] (=]

------ & Commands

and then press Write.

The file ending ".chain"
well be appended to the
name and a Chain file
created.

We will now add the
recalcing of the functions
PAD1 and TIN PADI.

Insert - add a new Chain command

[oK
Finish
Flrsttchc(llidon the Ig}sle!'t P Insert
icon to add a new Chain -
B ®
command
) ) =@ Commands Type [Function @
Click on the icon at the Y New| Use parameters 7! Select Choice o @ == [
end of the Type field Function | L]
and expand the + in Command name Naw ] |2 0 Bxecution - g
. Option
front of Execution and Active Option - Manual 7]
then double click on Continue on failure Screen layout file o
. Functicn
Function from the Run in interactive mode Delete function [
Select Choice pop up. Comments Delete all functions L
Chain T
Macro ml
Plot
Page 216
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Click on the icon at

the end of the o) ®
Function field and =-& Commands Type [Function
then double click e Use parameters i
on PAD1 from the Function [PaDL
Select Function pop Cemmand name  [Recalc PADL
up. Active
Click on Write Continue on failure 0
Run in interactive mode =
Comments
A Chain File panels warning Chain file =]

you that the chain already exist
is displayed.

Click on Replace

WA RMIMG: The file [PADT End Area Volumes.chain] already exists.

whould pou like to...

Replace l [ Cancel

The chain now includes Step 2 - run the Interface Function:

We will now repeat the process but this time select the Function TIN PADI.

Click on Insert.

For the Function field

B ® B 8 8 8 @ &5 @

=% Commands

select TIN PADI. '@ Recalc PAD1
Click on Write. 9
When the Chain File

warning appears, click on

Replace.

The chain now includes Steps 2 and 3.

Type [Function
Use parameters Record [l
Function [TIN PADL
Command name  [Recalc TIN PAD1
Active
Continue on failure 1
Run in interactive mode ]

Comments

The Volumes option is not a function so to add it to the Chain, we Record it.

To Record, we simply click on eh Record icon and the Create/Edit Chain panel is temporarily removed

and the Chain Recorder toolbar appears.

12d options can now be run and they are automatically added
to the Chain until the Stop icon is pressed.

Stops
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So again select
Design =>Volumes =>End Area =>Tin to tin

to bring up the End Area Volume Between Tins
panel.

Fill in all the fields as before.

Once the panel is filled in, select Volume and the
new volumes will be calculated. Click on Finish to
remove the panel.

Then click on the Stop recording icon and the
Create/Edit Chain panel will reappear with the

-

:ﬁ" End Area Volume Between Tins
Original tin

Mew tin

Angle for sections

Dist between sections

Original tin sections

Mew tin sections

Difference model

Difference colour

Use Extrapolated Areas

Clean sections models beforehand

EELES
[GROUND
[PADI
o~
2
|xs ground
|x5 padl
lxs diff
|magenta E]

[

=]

recorded options in it. Poly PADIL INT-= interface
Report file [PAD1 VOLUMES. rpt
Report mode [summary E]
i Volume mode |Average end area E]
| File <PAD1 VOLUMES.rpt> will be created
Stop [ Volume l [ Finish ] [ Help ]
Click on Write. =
When the Chain File o o ot L [Option
Waming appears, click @ Recale TIN PADL Command name  [End Area Volume Between Tins
on Replace. -9
. . i ffc Parameters Gonti fail
The chain now includes e -
Run in interactive mode [
Steps 2, 3 and 4. c
omments

Click on Finish to remove the Create/Edit Chain panel.
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To use the Chain, first use the SA Editor Change Height command to change the height of the VIP for

PADI to say 64.5.

Then run the chain by walking right on
Recalc =>Run chain and double clicking
on the chain name

PAD1 End Area Volumes.chain

The chain then runs repeating Steps 2, 3
and 4 for the pad with height 64.5

Recalc
Auto
Edit func
Edit data
Recalc
Recalc all
Uzer

Edit chain
Fun chain

T

[

Select

[Lib]
[Uzer Lib]

Looking at the report, the balance is now down to 352.349.

BEGIM

TIN-TIN VOLUME REFPORT

surface to surface volume report - (with plan polygon "PAD1l INT-=interface")

original tin GROUND

new tin PADL

separation  2.000

angle 90" 00" 00"

method Average end area

extrapolated no

cut volumes and areas are negative
i1l wolumes and areas are positive

total plan area 1791.593
total cut -750.030
total fill 397.682
balance -352. 349
ie excess of cut over fi11 352,349
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16.10 Exact Volume Calculations

Now go back to the Plan 1 view and remove any extra models so that only the models
PAD ALIGNMENT, PAD1 INT and PAD1 SECTIONS are on the view. Click LB on Fit to fill the view.

To calculate exact volumes between TINs, from the Main menu, click LB on

Design=>Volumes=>Exact=>Tin to tin

la‘ﬁl Exact Volume Between Tins

{]

Original tin [GROUND

Mew tin [PaD1

Clean faces model beforehand

Report file [PAD1 EXACT VOLUMES.rpt
Polygon options

@ Use a polygon

Polygon

1 Use a model of polygons

EMaDEER]

ADL INT-> interface

[ "PADL INT->interface” selected

I‘u‘olume] I Finish ]

| Help |

Fill the panel in as shown. Place the cursor on
the tin icon for the Original tin ficld and click
LB to popup a list of the available TINs.
Double click LB on GROUND. Repeat the
process for New tin and set it to PAD1.

By entering a name in the Report file field, a
report can be created showing the details of
the end area calculations. Type in the name
PAD1 EXACT VOLUMES.rpt.

Click LB on the Poly icon and then select
String icon. Select the red-green interface
polygon in the Plan 1 view with LB. Confirm
the selection with MB.

The report will be calculated and immediately display. The following is a typical report

Project: STAGE 1

User: 1ig

organization: 12D Solutions - Lee
Date: Mon Now 24 03:18:17

Report File:

2014
PAD1 EXACT VOLUMES.rpt

volumes from tin "GROUND" to tin "PAD1l" - (with plan polygon "interface")

cut volumes are negative
i1l volumes are positive

Total cut -750. 898
Total fi11 397.77
Total balance -353.122
ie excess of cut over 111 353.122

Polygon plan area = 1791.593

Note the cut, fill and balance volumes are also display in the message area of the Exact Volumes Between

Tins panel.
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@ Use a polygon

Polygon ADL INT->interface [%]

Use a model of polygons

—

| ¢ -750.898 f 397.776 b -353.122

|‘u‘|:ulume| | Finish | [ Help ]

Click LB on Finish to terminate the panel.

We used a polygon for the exact volumes but like the End Area volumes, a polygon does not have to be
used. If no polygon is used then the volume calculations are restricted to the regions where both TINS

exist.
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16.11 Comparison of End Area Verses Exact Volume Calculations

In the above examples where the height of the pad was 64.5, the end area calculation for balance of
volumes was -352.349 verses -353.122 for the exact calculation, a negligible difference.

On a large site, you may notice a significant discrepancy between your answers from both these methods.

In such case, try performing your end area calculations with a smaller Distance between sections. Also try
to orientate your sections at right angles to the major direction of cut/fill movement. These steps will
minimise errors inherent in the end area method.

It is possible to perform end area calculations such that all sections are at right angles to an arbitrary string,
just as you would with template generated sections in normal road design. See Design =>Volumes =>End
Area =>String Tin to tin for how to do this.

Apart from being a double check on the calculated volumes, the End Area and Exact also provide different
types of information.

The End Area calculations are the more important if you required section by section volumes such as used
in mass haul calculations.

The Exact calculations can provide volumes split up by depth ranges between the two tins used in say
isopach analysis.

16.12 Sign Conventions for Cut and Fill

The entire tutorial on volume calculations so far has been performed assuming the convention that Cut
volumes are negative and Fill volumes are positive. However this is a user definable convention.
If preferred, Cut volumes can be made positive and Fill volumes negative in the Defaults panel.

This convention is set in the Defaults e~
L. . ufl, Default: [=]
panel which is on the Main menu at ¢, Defaults === ==
Project => Management => Defaults Trash Settings | Mame Settings | Defaultsdd |
Default SEttIrIgS | S}rstem Sett|r|95 l
Colour [green D
Point colour [yellow D
Tin colour [green D
Contour colour [cyan D
Contour bold colour  [plue E]
/O null height |_ggg &]
Text height (pixels) [10 &]
The field Cut volume sign near the Chord/Arc tolerance  [p1 (]
bottom of the panel defines the sign for Culling [
the Cut Vplumes, and' the sign for the Fill e n
volumes is the opposite. —
Corner angle fis* A
Place the cursor on the choice icon for the -
. . Weed tolerance [0 &]
Cut volume sign field and click LB to - :
pop up a list of alternatives. Click LB on SEESTTIEIEEL [0 (=f)
either positive or negative. At this time, Perspective view exagg [1 M
leave the value negative. Cut volume sign [negative L‘_’l
Click LB on Set to activate any changes. Use density drawing Select Choice (&)
Click LB on Finish to terminate the | :EE;:':
panel.
|
[ set | [Finish| [Help |
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16.13 Advanced - Difference Sections

This section will explain what the Difference model is that was generated by the
End Area Volume Between Tins panel.

Ia‘ﬁ: End Area Volume Between Tins (o[ @] =]
Original tin |GROUND
Mew tin [PADL
Angle for sections ko-
Dist between sections |2
Original tin sections |x5 ground
Mew tin sections [c nadl [ |
@erence model |}<5 diff
irerence colour |magenta
Use Extrapolated Areas ]
|
| =
Clean secticns models beforehand
Poly PADL INT->interface
Repart file [PAD1 VOLUMES.rpt
Report mode [summary E]
Volume mode |Average end area E]

| File <PAD1 VOLUMES.rpt> will be created

[‘u‘olume] [ Finish ] [ Help ]

The difference sections are the depths from the Original tin to the New tin. That is, the value on the
difference section is:

Z- diff = (Z-value of original tin) - (Z-value of new tin).

We will now look at a section though the New tin, the Original tin and the corresponding difference
section.

The difference sections can not easily be displayed on the same Section view as the sections between the
tins because the Z-values through the tins are around 60 to 70 and the Z-values for the difference sections
are between -1 and 1.

So we will display the sections through the tins on one Section view and the corresponding difference
section on a different Section view.



12d Model Getting Started and Training Manual

On the view Section CROSS organise things so that only the models tin GROUND, tin PAD1 and xs
PAD1 are added to it: Then profile the string top sect 23 from the model xs ground.

@ Section CROSS "xs ground-»top sect 23" E@

section through the
original tin GROUND

Create a new section view and profile the string diff sect 23 from the model xs diff on it. To find the string
diff sect 23 it is probably easiest to create a new Plan view, add the model xs diff and then select the string
diff sect 23 on the new Plan view. The plan position of the string will be exactly the same as the string top
sect 23 on Plan 1.

=] Section 4 "xs diff-> diff sect 23" o & [k

Looking the magenta string you will easily see that the z-value a each chainage along the section is the
depth between the GOUND tin and the PAD1 tin at that chainage.

That is the difference section is a schematic where a positive Z ordinate represents cut and a negative Z
ordinate represents fill. The datum for change from cut to fill is at Z=0.
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17

17.1

Plotting

Overview
This chapter is arranged so that relevant sections appear in blocks for easy reference.
The layout of this chapter is as follows:
17.14 Plotting sheets of Long sections on page 248. relates to long section plotting.

17.15 Plotting Sheets of Cross Sections _on page 272. relates to cross section plotting.

17.16 Plan Plotting Using Plot Frames on page 284. relates to plot frame plotting.

17.17 Plan Plot Sheet on page 302. relates to plot sheet plotting.

For user convenience, each plotting section is self contained (requiring some duplication).

The data used for the plotting has been built up by working through the Getting Started manual. If you
have not worked through the Getting Started Manual to this point then, you can import the 12da file
Chapter_17.12da, which will bring you up to this point. This is in the folder

C:\12d\11.00\Training\design\getting started basic
You also need to copy the file
C:\12d\11.00\Training\design\getting started basic\RS1 Vol.rpt

into the working folder for your project.
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17.2  Triangulating the Road

In order to calculate the volumes and display the quantities in the long section plots we need to create a tin
of the surface of the road which is made up of the data in the models RS1 Sect and RS1 Strs.

To create the tin, us the option Zins =>Create =>Triangulate data

Fill in the Retriangulate function with TIN DESIGN
and the New tin name as DESIGN followed by
<Enter>.

The model for tin will then be automatically filled in as
tin DESIGN.

Set the Tin colour to magenta.

I:ﬁ" Triangulate a Data Source

General | Data ] Nulling]

Retriangulate function [TI DESIGN
Mew tin name |DESIGN
Tin colour |magenta E]
Tin style |1
Medel for tin |tin DESIGM

Additional settings

Preserve strings Remove bubbles =

Weed tin = Triangle data [l

Cell method [7] Colour by triangle data [
Create many ]

]
£l

| ok - no Tin <DESIGN> exists

[Triangulate] [ Finish ] [ Help

To select the data to triangulate and create the tin, we can either

(a) add the models we wish to include in the tin onto a View and select the View as the Data to

triangulate,

or

(b) we could uses the Models icons and list the models.

We will use the View method so that we can quickly see that the data to triangulate is the correct data.

So remove all the models from the view Plan 1 and then add just the models RS1 Sects and RS1 Strs.

u‘ﬁ" Triangulate a Data Source (o = |[ &=

General Data | Mulling ]

So on the Data tab, select the View icon

and then either type in 1 in the View View
field, or select 1 from its pop up, or

click MB in the View field and select

a string in Plan View 1.

Data to triangulate
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On the Nulling tab, w could use the
polygon that encases the road in the
RS1 Polys model as the Null polygon.
Or alternatively we can set the Length
field to 1 and 12d Model will null out all
the triangles with an external side longer
than 1 (that should be all the triangles
outside the interface strings).

So tick on Apply nulling and type 1 into
Length.

Click on Triangulate.

:ﬂ: Triangulate a Data Source E = @

General ] Data  Mulling |

Apply nulling |V
Angle [5= |£|
Length [1 |£|
Combined angle E.:f |£|
Combined length |;_~g ||.J.~;|
| =

The data is triangulated and the Retriangulate a Tin panel displayed in case you wish to make any
changes. Click on Finish to close the panel.

Add the model tin DESIGN onto the View 1 to check the result of the triangulation.

PRACTISE VERSION: To keep the number of points below 5,000, the road data has been created with
sections at a S0m interval rather than Sm. This means that the pictures are not exactly as they appear in the
manual when running with the Practise version.t

Page 227
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17.3  Plot devices
12d can generate plots to various devices. Firstly, it supports a full interface to Windows so it can create
plots on any device that is supported by Microsoft Windows.
12d also supports various popular plotting devices in their native format so it can plot directly to Hewlett
Packard pen, inkjet and laserjet printers/plotters, although today, most plotter are driven as a Windows
plotter. 12d supports Postscript, HPGL2 and PCLS5 plotters directly and plotters that emulate these devices.
We also talk about the concept of plotting to CAD where we treat CAD as just another plot device. This
process generates a native CAD file which can subsequently be read in by your CAD system, manipulated
further if required and then plotted from your CAD system. However please note that when plotting there
is an origin of (0,0) in the bottom left hand corner and the units are in millimetres. As such a plot, we can
plot to AutoCAD (DWG, DXF or DXB) or Microstation (DGN).
There is plotting to a model. This is a technique for previewing a plot. See 17.10 Previewing Plots on
page 231. for more information on previewing plots.
There is plotting to a pdf file. In this case a physical plot is not generated but a pdf file. PDF has become
an industry standard and many companies no longer produce physical plots and only pdfs. PDF’s are also a
good technique for previewing a plot.
The list on the right shows the default set of gelect Plotteg =]
Plotter types shipped with 12d Model. To keep
the pop-up list a reasonable length, the plotter =1
choices have been grouped together but clicking _
. . windows_mono
on a + will expand any of the groups allowing an windows_emf
individual plotter to be selected. raster
raster_mono
windows_xps
The popup list of plotter types is customisable so xps_writer
the list can include line items such as "Mary’s pdf_12d
inkjet — 2™ floor". You can remove plotter types model
that are irrelevant to your organisation. = EJE]FFuII Scale
There is extra information that can be set for a PDF black
user defined plotter such a colour mapping files PDF black string weight
and pen thickness files. All of this customisation PDF colour .
. .. . PDF colour string weight
of the available plotter types is implemented via 5 £ Half Scale
the plotters.4d file which is documented in the POF black 50%
12d Reference manual in the chapter Plotters and PDF black string weight 50%
Plotting. PDF colour 50%
PDF colour string weight 50%
PDF unmapped
|2 DWG
=) Windows
=1 XPs
B | Other
|2 Postscript
= HP
= DG
|2 Legacy
| Select
[Settings]
[Recet]
Page 228
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17.4

17.5

Plot Parameters
The appearance of most of the plots generated by 12d Model is user definable.

There are simple plots such as plotting what you see on a 12d Model view but most users need to generate
special plots such as a road longsection, or pages of cross section plots, or a drainage plan plots.

For these special plots there are a large number of plot parameters that govern what is included on the plot
and how it appears. These parameters are stored in plot parameter files, known as ppf files for short.

Each parameter has a default value so that even if you perform a plot without supplying a ppf, you will still
get a plot.

Part of the configuration of 12d is deciding which parameters you require to achieve your drawing
standard. Once the standard is achieved you can save the parameters away in a ppf with the name of your
choosing so that you can use the same ppf files from job to job with minimal or no changes. One advantage
of this approach is that regardless of the skills of the operator, a common presentation standard of plotted
documentation is achieved.

The training data gives you samples of typical ppf’s to achieve common engineering standards for plan,
long and cross section plots. It is recommended that users new to 12d take a copy of these and use them as
a starting point for their own customisation.

Plotting Text from a Plan View

Whilst some plotting of a Plan View is WYSIWYG (What you see is what you get), the millimetre size of
the text on a plot will depend on the units that the text is defined in. That is, if it is defined as World,
Screen or Paper units.

For text that is defined in World units, the size is defined when displayed on any plan view and when in a
plot, the Scale of the plot determines the size of the text in the plot.

Text that is defined in Screen (device) units is defined in pixels so that is has a fixed size on a Plan view,
regardless of how much you zoom in or out on the view. However there is no corresponding size on a plot.
For some Screen text, there are separate sizes that are used when the text appears on a plot. For example
for the text labelling the grid lines on a view, there is not only a size in pixels but also a size in millimetres
that is used whenever the grid is plotted.

For text defined in Screen units that has no plot parameter defining it’s plotted size, there is an overall
Factor that the screen size is multiplied by to give a millimetre size on a plot. This Factor is set by

Plot => Plotting setups => Pixels to mm

which brings up the panel

5| Pixels to Millimetres Plot Factor EI [=] @

Factor 05 ﬂ
|
Set Finish Help

A value of 0.5 means that screen text that is 10 pixels high will plot at 5 mm high.

-

The default value is 0.5 but you can set this to whatever value you require.

Text that is defined in Paper units already has a millimetre size and that is the size it will be on the plot
regardless of the Scale of the plot.

However unlike text defined in World or Screen units, for Paper units there is no way of determining what
size it should appear on a Plan view. So each Plan view has a Plan Plotting Scale with a default value of
1000 and this is used to convert the millimetre size to a world size for displaying on that Plan view.

If the Plan Plotting Scale for a view is the same as the Scale used when plotting a view, then the text will
appear at the same size on the view as on the proposed plot.
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17.6

17.7

17.8

Note however that the Plan Plotting Scale can be set to a different value for each Plan view so the Paper
text can be a different size on each Plan view.

To set the plot scale for Plan view, select the Menu icon on the relevant Plan view and then select
Settings =>Plotting scale
to bring up the panel

'a‘ﬁl Plan Plotting Scale EI [=]
View [1

Type the required plot scale
Scale [500 into the field Scale and then
| press Set.

v ) §)

| set | [Finish| [Help |

Text Fonts

12d Model supports Windows True Type fonts and most AutoCAD .shp files as well. The standard install
supplies you with sufficient fonts to get started — typically ISO, ISOEQ, GOTHIC, HELV, HELVL,
MONO, ITALICC, SCRIPT, ROMANC and ROMANS. See the 12d Model Reference manual or context
sensitive help for more information on the files textstyl.4d and fonts.4d.

Mapping Line Colours to Pen Thickness

In the days of pen plotters, the plotter contained pens of different colours and line thicknesses and these
were used to create the plot.

Today with plot devices such as raster plotters, inkjet printers and pdf files, there is almost an unlimited
choice of colours and line thicknesses.

When plotting from 12d to such plot devices, it is possible to map 12d colours to user defined line (pen)
thickness or weight in millimetres. It is also possible to easily override the default weight for a particular
string.

Plot Files and Queues

In general, whenever 12d creates a finished plot file for a hard copy device, it will only place the file in the
local working folder (one level up from the .project folder). The exception to this is when plotting to the
Microsoft Windows interface. In such case Windows takes over the control of the file and sends it to the
device automatically.

Thus in general, plot files are not automatically submitted to any plot queue. It is the users responsibility to
then place the plot in an appropriate queue, decide when it will be plotted, decide on the number of copies
etc.

It is possible to have Windows run a background batch file that will automatically place any plot files in a
plot queue.

Similarly, when the plot device is a PDF file or CAD system, the PDF or CAD file will be written to the
local working folder. After writing the PDF/CAD file, the user can then use PDF viewer or their CAD
system to examine the file.

Windows Based Plotting

In the list of plotter types shown in 17.3 Plot devices on page 228., there is windows and
windows_mono. These devices interface directly with Microsoft Windows. This allows you to plot direct
to any Windows device on the network. All plot queue issues are handled direct by Windows. The plot file
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17.10

is deleted at the end of the plot.

Previewing Plots

To save wasting paper when producing actual paper plots, we strongly recommend that all such plots be
previewed before producing the plot on paper.

We can do this in two way - by plotting to a PDF file or by plotting to a model.

17.10.1 Plotting to a PDF File

We plot to a PDF file by selecting any of the Plotter Type that produce a pdf file. For example pdf_12d or
PDF black.

Select Plotter E

Blld
windows
windows_mono
windows_emf
raster
raster_mono
windows_xps
xps_writer

model
g PDF
E I Full 5cale
PDF black
PDF black string weight
PDF colour
PDF colour string weight
B 1) Half Scale
PDF black 50%
PDF black string weight 50%
PDF colour 50%
PDF colour string weight 50%
PDF unmapped
I DWG
2 Windows
I XP3
I Other

17.10.2 Plotting to a Model

When the plotter type model is selected, am actual 12d model is created instead of a file. This model is
stored in the normal 12d database just like any other string data.

A physical plot is a simple 2D drawing in the X-Y plane with (0,0) in the bottom left hand corner, and the
plot itself in the positive quadrant. The industry standard for units in a plot are millimetres.

So for convenience, when 12d Model plots to a model, the sizes are multiplied by a thousand. So an A4
Landscape plot will be 280 units wide by 210 units high. That way, when the model of a plot is added to a
Plan view, the units can be read as though they are millimetres. No matter how any text was defined
(screen, paper or world), when it is plotted it is converted to millimetres so when it is plotted to a model, it
is created as world text with the final millimetre size multiplied by a 1000.

Because of the multiplication by 1000, it is important that you turn all other models off when previewing
models of plots in a Plan view. If you don’t, your plot may well be mixed in with real world coordinate
data. This will make the plot appear very small and probably in the extreme lower left corner of your
screen, near the origin (0,0).

A major reason for plotting to a model is that it is then possible to make changes to the model of the plot



12d Model Getting Started and Training Manual

and then do a “plot of a plot’. For example when you want to make minor changes to a long section plot by
adding some new line work or new text.

In that case it is important to remember that the plot in the model has the size multiplied by 1000 and so if
you add line work, you need to think in units of millimetres rather than metres. For example, you would
create text 5 high so it would be the same as 5 mm on the finished sheet.

Important Note:

After making changes to a model of a plot and it is time to create a ‘plot of the plot’, you must use a Scale
of 1:1000 so that the ‘plot of the plot’ of the plot comes out in millimetres.
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17.11 Overview of Plotting
We will look at seven of the many types of plots available.

Quick Plan plots - see 17.12 Quick plots on page 234.

Quick Section plots - see 17.12.1 Quick Plan Plots on page 234.

Quick Perspective plots - see 17.12.3 Quick Perspective OpenGL Plots on page 244.

Sheets of Long Sections - see 17.14 Plotting sheets of Long sections on page 248.

Sheets of Cross Sections - see 17.15 Plotting Sheets of Cross Sections on page 272.

Sheets of Plan plot frames- see 17.16 Plan Plotting Using Plot Frames on page 284.

NS kR =

Plan Plot Sheet consisting of multiple plans on the one plot - see 17.17 Plan Plot Sheet on
page 302.

Each of these plot types will now be discussed in detail.

Apart from these six plot types, there are also others such as Drainage plots, Sewer plots and Pipeline plots
which will not be discussed in this Chapter.

To preview any plots we make by plotting to a model, we will create a Plan view called PREVIEW that we
will know is for only viewing models of plots and not for displaying any real world data.
So before continuing, create a new Plan view with the name PREVIEW using

View=>Create=>Plan view.
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17.12 Quick plots

The key purpose of Quick Plots is for occasions where the scale of the plot is less important than the
contents. For example, if you needed to table a drawing at a meeting showing a certain detail, all that is
needed is that you get the detail up on your screen and zoom in on it until you see the extents of your area
of interest. You then create a plot and you will get exactly what you saw on the screen.

17.12.1 Quick Plan Plots
In 12d Model there are two ways to create a quick plan plot - Quick Plot and Quick Sheet Plot.

We will use the option Quick Sheet Plot because it allows us to choose the size of the sheet of paper and it
dynamically displays what the plot will contain on the selected Plan view.

17.12.1.1 Quick sheet Plot

For view Plan 1, make sure it has the models ALIGNMENT, RS1 Sects, RS1 Strs, Survey ROAD
CROWN and ROAD PAVEMENT EDGE on it. If this is not the case, add and/or remove models until
only those models are on the view.

The cut down on the amount of information on the view, we will also turn text off on Plan 1 by clicking the
Toggle icon and then on Text [on] to toggle it to Text [off].

53] Plan 1
B3] (=] [ 5] (&) [@) (@] (L

i
“d

Culling [off]
Text [off]
Linestyles [on]

Sewer [off]

String text [on] k
Vertices [off]
Vertex indices [off] 4

-

In Plan 1 view zoom in to the area as shown below.

[ Plan1 = ENES
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From the View Button Area for view Plan 1, click LB on the Printer icon in the view buttons area and select
Quick Sheet Plot to bring up the Quick Sheet Plot panel.

Plan1

We will plot to a model and also to a PDF file.

-j] Quick Sheet Plot

View [1
Plotter type [medel
Plot file

|preview plot

Clean model beforehand  [ahways clean

Scalel: 809813537 L
Sheet size wd ht (mm) |A4 /\ZT
Plot Sheet Margin [5 / |F|
Rotation Angle b |E|

Origin

X coordinate |4275W |I| |E|

¥ coordinate [3273.4536 |F|

Plot Are Anchor

@ Fixed in View - Scale Zooms Centre

Fixed in Data - Scale Fixed Origin

Title and border o
Text style It (T
Text height (mm) |4
Title line 1 | =)
Title line 2 | (]
Title colour |cyan |_|
[ plotter ok

|3 | | %2 | [Piet| [|Finish| |Help|

View Plotting "1” [

Quick plot
Quick sheet plot
Plot frames
Drainage plan

Pick 1 for View and select the Plotter Type model.

Type in preview plot for the model name

Select aways clean as Clean model beforehand mode

Select A4 for Sheets size, 5 for Plot Sheet Margin and 0

for Rotation Angle.

Then click on Fixed in View - Scale Zooms

The Scale 1: and Origin X and Y coordinates are

automatically calculated so that an A4 sheet will fit as
much as possible in the view.

A representation of the A4 sheet is drawn on view Plan 1.

Plan1
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“f Quick Sheet Plot [

View I (=]
Plotter type |m|:|l:le| |§|
Plot file [preview plot =
Clean model beforehand [ahways clean =]
Scalel: [209.813537
Sheet size wd ht (mm) (2 [=|
Plot Sheet Margin |5 ||‘"'||
Rotation Angle p: [ 2|
Origin
X coordinate [42760.0316 (2 (&)

Y coordinate [36873.4536 |;’_|

Plot Area Mode Anchor

@ Fixed in View - Scale Zooms <d——T=rtre |

Pick 1 for View

and select the Plotter Type model.

Type in preview plot for the model name

Select aways clean as Clean model beforehand mode
DO NOT ENTER SCALE

Select A4 for Sheets size, 5 for Plot Sheet Margin and 0
for Rotation Angle.

DO NOT ENTER ORIGIN

Then click on Fixed in View - Scale Zooms

The Scale 1: and Origin X and Y coordinates are
automatically calculated so that the A4 sheet will fit as
large as possible in the area visible on the view.

A representation of the A4 sheet is drawn on view Plan 1.

Note: Using Fixed in View- Scale Zooms means that if you
zoom in and out in the view, the scale and Origin change so
that the A4 sheet stays exactly as it now is in relation to the
view edges.

For Fixed in Data - Scale Fixed, the plot frame keeps its
size relative to the data when zooming and panning.

Fixed in Data - Scale Fixed Ornigin

Title and border o
Text style i |i|
Text height (mm) (4
Title line 1 | [ e |
Title line 2 | [ b |
Title colour eyan (|
| plotter ok

|3 | [€:| [Plet] [Finish| |Help|

Plan1

A representation of the A4
sheet is drawn on view Plan 1

The four cut marks in the /

corners represent the full
A4 sheet.

The upper box represents
the area of the plan view
that will be plotted.

The bottom rectangle
represents the title area.
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o

Select Arial for Text style.

Now type 2.5 for Text height (mm) and press <Enter>.

The cut marks stay in the same place but the upper

rectangle gets larger and the title rectangle gets smaller.

Fill in Title line 1 and Title line 2.

“§ Quick Sheet Plot [ =
View 1 =1
Plaotter type |mu:ude| |§|
Plot file [preview plot =
Clean model beforehand |alwa}r5 clean |;|
Scalel: 809.813537
Sheet sizewd ht (mm)  [a4 (+=]
Plot Sheet Margin |5 |F|
Rotation Angle b‘ |D¢T|

Origin

X coordinate [42760.0316 () (&)

¥ coordinate |35353,594? |£|

Plot Area Mode Anchaor

@ Fixed in View - Scale Zooms Centre

Fixed in Data - Scale Fixed Origin

Title and border U
Text style [Avial (T]
Text height (mm) [25
Title line 1 [Check plat (=
Title line 2 |for Intersection |@|
Title colour |eyan |_|
| plotter ok

| @ | |[#:| [Piot| [Finish| |Help|

Plan1

The cut marks stay i/

the same place

but the upper rectangle
gets larger

and the title rectangle
gets smaller because
the title text has been
reduced from 4 to 2.5.
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Click on the button Plot and the model preview plot will be created.
Add the model preview plot to the view Plan PREVIEW and click on Fit.

Your finished plot should look like the one shown below.

[&=] Plan PREVIEW = =R
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(G rommr D
To plot to a PDF file: Wi

View i
Simply select the Plotter type to be say pdf_12d
- Plott:
and the Plot file name will automatically have the ¢ e.rtype lpdf. 124
Plot file |preview plot.pdf

ending ".pdf" attached to it.

Clean model beforehand  [always clean

Scalel: [a09.813537
The press the Plot button. Sheet size wd ht (mm) (a4
Plot Sheet Margin 5
Rotaticn Angle o*
Origin

R WO©n

X coordinate |42?50,U315

¥ coordinate |35358,594]‘

Plot Area Mode Anchor

@ Fixed in View - Scale Zooms

Centre

() Fixed in Data - Scale Fixed @ Origin

Title and border

Text style [Arial

He

Text height (mm) 25

Title line 1 [Check plot

Title line 2 [for Intersection

Title colour [eyan

NEE

[ plotter ok

8] (%] [Pwet] [Finish|

A pdf file will then be created and opened in your default PDF Viewer.

'@ preview plot.pdf - Adobe Reader

== |§

|Fi|e Edit View Window Help

BB 6|

Tools Sign Comm

Sig

v Export PDF Files

Adobe ExportPDF

Convert PDF files to to Word or Exc
online.

Select PDF File:
|@ preview plot.pdf

1 file /

Convert To:
| Microsoft Word (*.docx)

Recognize Text in English(U.5.)
Change

» Create PDF Files

» Send Files
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17.12.2 Quick Section Plots

This is very similar to the Quick Plan plot we have just finished.

We will investigate this facility by profiling our RS1 centreline string in view Section LONG. From the
View Title Area of view Section LONG, click LB on the Profile button and select the centreline string on
display in view Plan 1.

Note: if you have just read in the data for Chapter 17 then a section view called LONG needs to be created,
with a exaggeration of 5 and a Gird turned on with gird x 100 and grid y 1.

Set the corridor back to the values defined in 14.5 Setting Corridors on page 182. using the option on
the View Title Area of LONG: View LONG menu =>Settings =>Corridor with a Width Left and Width
Right of 20.

=gl Section Corridor [ = -Ehl

View [LONG (=]
Width Left [20 e
Width Right 20 e f
Overlap Left [0.01 Lef
Overlap Right [0.01 i
Chord/Arc tolerance |g.02 Jei
[ Finished
| set | |Defaults) | Finish | | Help |

If you add the models tin GROUND model along with the pipes, survey SEWER PIPE and survey
WATER PIPE and ensure that your grid is still toggled on, then your section view should be as shown
below.

enu button +
= swy LONG "ALIGNMENT->RS1" Profile button =S EcR /===

Zoom in on the portion of the profile where the services cross under the road.
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Your view should look like the one shown below.

£ Section LONG "ALIGNMENT->RS1" P|°tbu“0n\ View Plot menu o)
B =] = |[Ele)=) %) @) [ (@& %] X

Leng plot

i X plot

8 | Drainage/Sewer
Melbourne Water
Pipeline

Note the services under the road.

If you add the models Survey SEWER PIPE and survey WATER PIPE onto Fiew 1 you can check that
is where the services do go under the road.

Also note that even though we asked for the vertical grid to be 1 m apart, the grid will only display in full
at this separation when the view is uncluttered as it is in the zoomed in view. If 12d thinks the view will be
too cluttered when you are Zoomed out, it will only display some of the requested grid lines as seen above.

From the View Title Area of view Section LONG, click LB on Menu=>Settings=>Geom annot
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[ ‘ii Section Geometry Annotations = A
View [LONG
Show HG
Show VG
EE L m Note that you can set the height of text displayed on
(iew text ht (pix) [10 the screen in pixels (View text ht (pix)
( T T T s ) in('iependently of how the same text will appear in
t\m — o l_] height on the finished plot (Plot text ht (mm).
arrow colour [green E] 1
HG wview arrow ht (pix) |3
HG plot arrow ht {mm) |1.5
VG view arrow ht (pix) |3
VG plot arrow ht (mm) |1,5
Draw grades as1 in =

| Click LB on Set and Finish.

-
|

We will now create a plot of what is on the Section view.
From the View Button Area for View Section LONG, click LB on Plot =>Plot

Fill in the panel as shown. Make sure that the plotter type is model or pdf 12 so that we can preview the

plot.
i = ™
=fl Section Plot L=l — il 1
p. Section Plo J— Fill in the panel as shown.
View [LONG Select the plotter type model so that we can preview
Plotter type [model the plot on a Plan view.
Plot file [review quick section Type in preview quick section for the Plot file
Clean model beforehand  [31ways clean (=]|| Select always clean for Clean model beforehand
Scalel: (500 In the Scale 1: field, type 500 and press < Enter key>
Sheet width E . . . .
© wl_ — [409.2 Using the aspect ratio of the Section LONG view and
slest Al |184.8 the scale, the sheet width and height is then
Plot Sheet Margin [5 calculated and written to their fields.
Title and border Note: It is possible to type in any one of the three
Text style 50 numbers Scale, Sheet With and Sheet height and
Tt s ] s press <Enter>, and 12d v.v1ll calculate the other two.
o “|l For instance to fill the width of a Landscape A1l sheet
|| Titlefine 1 |Check plot where you are not interested in the scale of the plot,

Title line 2 [for long section type in a width of 841 and press <Enter>.

[iectn lcyan Il Tick on Title and border, Text style of ISO, Text
[ view plotted height of 5 and a simple title.
| Plot | [Finish| Click LB on the Plot button.

Now go to the View PREVIEW and use the - sign to take OFF model preview plot and then add ON the
model preview quick section.
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Plan PREVIEW E=N | EER( 5

Check plod
for long =eciion

Note that, in general, the plotted text may have a different height to that in the Section view and all the text
plotted to the model will be turned into world text.

If the plot is satisfactory, the user can send the plot to another plotter type. Simply select an appropriate
device from the Plotter icon at the end of the Plotter type ficld and then Click LB on the Plot button.

=l Section Plot E‘_l_]ih

View lone [H
Plaotter type model |§I

— Select Plotter

Plot file review quick section |
Clean model beforehand always clean |~_§

12d
Scalel: B - PDF
, —| |mows
Sheet width (mm) 109.2 & =) Windows
Sheet height (mm) 1848 = 3 KPS
= 7 Other

Plot Sheet Margin s [

Title and border

Text style 150 (1

Text height (mm) s [k
Title line 1 [Checkplst N
Title line 2 [forlong section
Title colour Ic}fan— |_|
|viewp|otted

o) Emd (G
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17.12.3 Quick Perspective OpenGL Plots
This is very similar to the Plan and Section plots above. The Orbit, Joystick, String Drive or String Walk
options can be used together with the Zoom options to establish the extents of what you can see. To get a
plot of this is very similar to the above except with regard to the plot size. The plot size can only be
established by trial and error.

To start off, just use any of the above tools to get some data on display in your Perspective OpenGL 2 view.
In our case we turned on the model tin DESIGN after doing a String Drive. Let us assume that this is the
data we wish to plot

Perspective OpenGL 2 Plot bUttOIl\ = IFE =

Click LB on Plot=>Plot from the View Button Area of View Perspective OpenGL 2.
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‘B Perspective Plot EI [=] @
View |2 |E|
Plotter type [model |§| For Plotter type select model.
Plot file s quick perspective |;| For Plot file, type in preview quick perspective.
Clean model beforehand [always clean = For Clean model beforehand, select always clean.
Sheet width m

= WI_ b 627 é Note that the Sheet width and height have already been
sheet height (mm) 401 g filled in. They are in the ratio of the aspect of the
Title and border J Perspective view.
Text style L (T] If your plot is too large, you can change either Sheet width
Text height (mm) i 1F or Sheet height and press <Enter>. The other one will be
Title line 1 | o calculate keeping the same aspect ratio.
Title line 2 | To change the aspect ration, you need to change the shape
Title colour fhite |—| of your Perspective OpenGL view.

. = For Title colour select white.
| view plotted

[Piot | [Finish) (Help) Once you are happy with the plot size, click LB on the Plot
button to generate the plot.

Now go to Pan view PREVIEW and remove any models on it and add on the model
preview quick perspective. Your previewed plot should look like:

Plan PREVIEW [ &[]
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In the Perspective OpenGL view 2, Toggle=>Shade. Your view should now look like:

Perspective OpenGL 2 EI@

Teggle "2"

Text [on]

Vertices [off]
Vertex indices [off]
Z Values [off]
String names [off]
Attributes [off]
Tin contours [off]
Tin edges [off]
Tin flow [off]

Tin mesh [off]
Shade [on]
Extrusions [off]

1x

2%

S

Grid [off]

If on the Perspective Plot panel, the Plot button is clicked again, the Plan view PREVIEW will change to:

Plan PREVIEW =R 5=

12d Hodal

Sert Ap- 15 15,43
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If the plot is satisfactory, the user can send the plot to a device.

So for example on the Perspective Plot panel select PDF colour for the Plotter type and click LB on the

Plot button.

8 Perspective Plot

(=] & =]

(=]

View 2
Plotter type |F'DF colour
Plot file

|uick perspective.

p df Select Plotter

Clean model beforehand

|always clean ®C312d

Sheet width (mm) B3 PDF
_ |62? = =5 Full Scale
Sheet height {rmm) |4|:|1 PDF black

Title and border

Text style i "
_ | [ |51 Half Scale

Text height (mm) |1|:| [; PDF unmapped

. . 3 DWG
Title line 1 | B ) Windows
Title line 2 | B I3 XPS

5] Other

Title colour |white [:
| plotter ok

PDF black string weight
POF colour

PDF colour string weight

This particular plotter choice will map the white text to black but keep the other couloirs as they are so the

pdf file will look like.

12d Model

Sat Apr 18 15:52:53 2015




12d Model Getting Started and Training Manual

17.13

17.14

Plotting Using Plot Parameters

Often a more detailed plot is required than the "what you see is what you get" plots of views already
described can produce.

This is especially true for long sections and cross section plots where many pages of plots are required and
the layout includes large amounts of additional information such as the labelling of chainages, heights,
depths, alignment geometry and services.

In 12d Model, the way more complex plots can be produced is controlled using files called plot parameter
files (ppf’s for short).

PPF’s consist of a large number of parameters and values which gives the user tremendous flexibility on
the way the plots.

To make plot parameters accessible to all users, 12d Model has interactive PPF editors to create, modify
and store the plot parameters in a binary plot parameter file (or ppf) format.

See

17.14 Plotting sheets of Long sections _on page 248. relates to long section plotting.

17.15 Plotting Sheets of Cross Sections on page 272. relates to cross section plotting.

17.16 Plan Plotting Using Plot Frames on page 284. relates to plot frame plotting.

Plotting sheets of Long sections

Although long section plots of an alignment can be produced with no 12d Model view involved, if you
have a section view with the alignment string profiled on it, then many of the plot parameters are taken
straight from the section view and don’t have to be entered separately.

So we will use the view Section LONG to illustrate the plotting of long sections that involve multiple
sheets.

View Section LONG should still be set up with the alignment RS1 already profiled on it, but if that is not
the case, make sure that the models tin GROUND, survey SEWER PIPE and survey WATER PIPE
have been added to the view and the string RS1 is profiled on the view.

Set the corridor back to the values defined in 14.5 Setting Corridors on page 182. using the option on
the View Title Area of LONG: View LONG menu =>Settings =>Corridor with a Width Left and Width
Right of 20.

Also change the vertical exaggeration of the view Section LONG to 2 and toggle the Grid OFF using
Toggle=>Grid.

@ Section LOMNG "ALIGNMENT-

— Vertical exaggeration 2 Toggle button

Plot buttore || = [[=5]

Plot

Long plot )

X plot
Drainage/Sewer
Melbourne Water
Pipeline
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The Long Section Plot PPF Editor can be brought up by either

(a)

or

clicking LB on the Printer icon in view Section LONG and then selecting Long plot (i.e. view Long

menu Plot =>Long plot),

(b) by clicking LB on the Main menu option Plot=>Plot and PPF editors=>Long Sections.

@ Section Long Plot PPF Editor

(=] O (==

Plot parameter file |

=)- Section Long Plot
- Notes

- Plot to models
[+ Title block

[+ Plot sheet layor
- Pagination

[+ Boxes

[- Chainage/Stag
- Uprights

[+- Datum area

-- Graph area

- Corridars

- Bubbles

- Quick horizont
H- Extensive horizi
H- Quick vertical ¢
- Extensive vertic
- Labelling point
- Labelling point
H- Hatching cut/f
|- Cuts

t- Paired cuts

e [ [
sl il ol

- Prirnary string 1

=l
=l

i- 5cale labelling
- Plan Plotting
- PPF's to includ

4 I I

View to load details from
WView

Global variables
Text style

Section parameters

Mame of string to profile

Horizontal scale

Vertical exageration

Sheet size setup
Sheet size wd ht (mm)

Plotter parameters
Plotter type

Plot file stem

Chainage range

Use HG and VG to determine min/mazx chainage

[@] Write

[LoMG

=]

o=

[ALIGMMENT->RS1
|

[1000

2

|

|

EEEE W

E
(4]

BEN@

O

| plotter ok

Finizh

Note that if you selected the option from the Section View LONG then a number of the fields are already
filled in. For example, View, Name of string to profile and Vertical Exaggeration.

If you selected the option from the main Plot menu, View and Name of string to profile will be blank and
Vertical Exaggeration set to a default value of 1. For this case we will discuss filling in the View field
shortly.

In the Plot parameter file box we want to select the file

C:\12d\11.00\Training\design\getting started basic\longsection_intro.lplotppf.

We can do that by either:
(a) dragging
—————
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C:\12d\11.00\Training\design\getting started basic\longsection_intro.lplotppf

and dropping it into the Plot parameter file ficld which will automatically fill in the name. Then
click LB on [Read].

Or
(b) in the Plot parameter file box, click LB on the folder icon to bring up the Iplotppf Choice box:

"B Section Long Plot PPF Editor [ @ (3]
Plot parameter file || E e - ]
Folder *.Iplotppf |
(= Section Long Plot View to load details from
- Motes
- Plot to models )
& Title black Global variables
- Plot sheet laym Text style [1
- Pagination |
[+]- Boxes - o
i~ Chainage/Stag ection parameters « T
- Uprights | [ Select
[+~ Datum area | (Lib] R
i
Grap.h area Horizontal scale [1000 [User Lib] »
[+ Corridars et . [Browse]
- Bubbles ertical exaggeration |j_ [Erowse reset]
.. Quick herizont | [Browse 12d Synergy]
- Extensive horiz | [12d 5_}‘”’3’9}‘] b
- Quick vertical ¢ i [Rel.atwe]
4. Extensive vertic Sheet size setup [Unicode format]
) ) Sheet sice e It ) [Ansi format] (System codepage)
- Labell?ng p':'!”t |‘ﬂ‘l [UTF-& format] (System codepage)
- Labelling point|  poprer parameters [Explore]
- Hatching cut/f Plott [Delete file]
& Cuts LT s [model [Ernail]
- . - Fil~4 Film rdmemm I T =T T

Then click on [Browse] and browse to the folder C:\12d\11.00\Training\design\getting started basic and
select the file longsection_intro.lplotppf. Finally click LB on [Read]

Plot parameter file | C:\12d\11.00\training\design'\getting started basic\longsection_intro.|plotppf Read| |Write

Reading in the plot ppf file sets up many of the plot parameters so that you don’t have to fill them in. For
example, the Horizontal scale has been set the 500 and the Vertical exaggeration to 2.

In both cases after [Read] is clicked, the next thing to check is the View field.

The ppf did not have a View name in it so the View field has been set to blank.

Select the section view from which the plot is to be generated by clicking LB click on the View icon button
adjacent to the View box near the top of the panel. Select the view LONG.
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- Sec

4.
+.

tion Long Plot View to load details fram
Motes |
i Plot to models Select View (8
: Title block Global variables LONG
Plot sheet layoi| ~ Text style il CROSS
Pagination | [Clear]
[Sameas]

Section parameters

Or the name LONG can be typed into the field and the <Enter> key pressed.

Note: If a value is typed then the user must then press the <Enter> key so that the view information is
automatically loaded into other fields of the panel.

Selecting the view will also automatically set some plot parameters if they don’t already have a value. For
example the Vertical exaggeration field will be changed to that of the selected Section view.

Now we’ll look at the Plotter parameters to define what device the data is plotter to.

Plotter parameters The plot parameter file has already set the

Plotter type |r'r1|:|dEI
Plot file stem |preview long section =

Digits in plot file number |3

Plotter type to model and the Plot stem
name the preview long section

Set the Digits in plot file number to 2.

e

We have enough information to generate the long section plots so new click on Plot.

Because of the length of the alignment and the Pagination settings (we’ll look at those shortly), four
models containing a plot will generated:

preview long section01, preview long section(2, preview long section03 and preview long section(04
The number 01, 02, 03 and 04 have two digits because Digits in plot file number is 2.

We’ll look at the first plot by removing any models from Plan view PREVIEW and then adding on the
model preview long section01. Our view should then look like:
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Plan PREVIEW o &[]

Notice that the plot is a combined Long Section plot, and a Plan plot of the relevant section of the
alignment in the Long section of the plot. This is all controlled by the Plot Parameters.

17.14.1 Looking at Some Long Section Plot Parameters

The long section plot parameters can be edited by moving through the various levels of the PPF editor by
using the tree structure shown on the left of the panel. The tree structure can be expanded by LB click on a
+ symbol (node) to show underlying levels which may consist of various other nodes. To shrink underlying
levels, LB click on the - symbol.

We will have a look at a few of the plot parameters that are available in the Long Section plot.
There are number of ways to find plot parameters.

You can simply examine the tree, and click on the + to expand the nodes looking for the parameters you are
after. For example, looking at the tree you will see the word Plot to models not far below Section Long
Plot.

Clicking on Plot to models will display the Pagination parameters on the right had side of the panel.
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- Section Long Plot

- Motes

- Title block

- Plot sheet layout
- Pagination

- Boxes

- Chainage/Stagge
- Uprights

- Datum area

... Granh area

Options for plotting to models

Clean plot models beforehand |a|wa}f5 clean

£2

do not translate or n E]
1000
| e
|

Translate and merge plot models
Mode

Spacing (mm)

= &

Merge

Parameters may not be so easy to find so another way is to use the Find button.

Click LB on [Find] at the bottom of the PPF editor panel to bring up the PPF Editor Find Parameter
panel. This will find any plot parameter in the panel that you know the full name of, which is rare, but it
also has some regularly used selections built into the choice box for it.

-

. PPF Editor Find Parameter

=

= || &=

Find |plot_name_tests*

=3

Select Choice
Main

Title block
Title block info

For example double click LB on

Pagination or Upright chainages will

go straight to the relevant node in the
tree and display the relevant

parameters on the right had side of the

panel.

Sheet margins
Paginaticn

Plan plotting

Box setup

Box sizes

Box titles

Tins

Offset strings

Super elevation
Volumes

Uprights

Upright chainages
Upright staggering
Graph area
Horizontal geometry
Vertical gecmetry
Point labelling with values
Paint labelling with symbols
Corrider models
Cut/Fill hatching
Cuts annotations
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For more information on some of the nodes go to:

17.14.1.1 Paqination on page 254.

17.14.1.2 Title Info_on page 254.

17.14.1.5 Adding a Plan Plot to the Long Section on page 261.

17.14.1.1 Pagination

If Use pagination is ticked on then the plot fill be broken into a number of pages depending on the length
of the alignment string and the Pagination mode and values for Chainage length and Chainage overlap.
For our long section plot, it was paginated and we ended up with four pages of plots.

[=]- Section Long Plot Paginaticn parameters
" Notes

i~ Plot to models
- Title block
--Plot sheet layo! Chainage length 320

(™ Paginaticn Chainage overlap [0

Use pagination

Pagination mode  |chainage

EE g

fl- Boxes

17.14.1.2 Title Info

Click LB on the Title block node (+ symbol) to expand the next level of the tree to show the nodes User
title info and Symbols.

Click LB on User title info to display its parameters.

[=- Section Long Plot - User title block parameters
 Notes Title file [SLIB\12d title_block_AL tbf
- Plot to models
= Title block Name | Value
i 1 Main Title ROAD DESIGN
i i T Sub titlel LONGITUDINAL SECTIONS
- Symbols "3 Subtitle? RSl

[#- Plot sheet layout
- Pagination

n Drawing Number
5 Sheet

[+- Boxes =
& Revision

- Chainage/Staggering
- Uprights

- Daturn area

- Graph area

- Corridors

- Bubbles

- Quick horizontal geometn

fru]
s )

- Extensive horizontal geom
- Quick vertical geometry
- Extensive vertical geometr

Frm IO s O o B i |
(s . e g |

- Labelling peints with chail Tirne format [%d-%b- %Y %aH: TaM: %S
- Labelling points with syml
Start by 3
- Hatching cut/fill PRl i
- Cuts ) Start drawing number |1
- Paired cuts Drawing number prefiz |

- Primary string name label

Drawing nurmber postfiz |

- Scale labelling
4 3

The parameters on the right of the panel include the User title block parameters.

The Title file name was in the ppf file that was read in and the title file defines line work and text for the
user defined title block.
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The title block file also includes user parameters that are displayed in the grid with the names of the user
text shown in the Name column, and the values the be entered by us will go in the Value column. For
example in the title block file the entry

text "Suser_text<2,Sub title1>"
created the text Sub titlel as row two in the grid.

If valid values are entered into the grid, they will be automatically be substituted into the title block at the
time of plotting.

This panel can be resized by moving the mouse to the extremities of the panel and whilst holding down the
LB near the edge, moving the outline to the required size just like resizing any view. Resize the panel in
both the horizontal and vertical so that it takes up most of the screen. Note Like any panel it can be
minimised by using the standard windows minimise button.

As the default size for the Value column has been set to the width of the column heading, it may be
necessary to resize the column to see all of the text we will be typing in. To do this, move the cursor over
the vertical dividing line of the grid, near the right hand end of the Value column heading. You will see a
resizing arrow appear and you can use it to drag the column out wider. Note that if there is text in the Value
column then double clicking LB whilst this arrow appears will automatically resize the column to be wide
enough to show all the text in the column, including the column title.

Title file <> [SLB\12d title block ALtbf [

MName |‘u’a|ue |
1 Main Title
2| Sub titlel LONGITUDIMAL SECTIONS
"3 Sub title?
n Drawing Mumber
5 Sheet

? Revision

The value LONGITUDINAL SECTIONS was already entered into the grid from the ppf file but this can
be changed and/or new values entered into the grid. We’ll enter some other values to show how they are
substituted into the title box at the time of plotting. LB click in the value filed adjacent to the Main Title 1
name field, then type ROAD DESIGN. Complete the rest of the grid as follows:

MNarme Value
1 Main Title ROAD DESIGM
"2 | Sub titlel LOMGITUDIMAL SECTIONS
3 Sub title2 RSl
n Drawing Mumber
5 Sheet
? Revision A

Note that not all the value fields have to be filled out.

To see what affect this has on the plot, click of the Plot button again.

The plots will be redone and the new page 1 drawn in the PREVIEW view.
Zoom into the bottom right hand corner of the plot and you will see the entered title block information.
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[5] Plan PREVIEW = |[= =

DATUM RL 54.000

HOREZONTAL CLRVES

YERTICAL CURYES

YERTICAL GRADES

LONGITUDINAL SECTIONS

If you Pan to middle of the of the Title Block, you will notice that 12d has automatically calculated the
Horizontal and Vertical scales (the position is given in the title block file) and on the right 12d Model has

automatically calculated the chainage range appearing on each sheet (the position is given in the title block
file).

A1 HORZ SCALE 1:600
A1 VERT SCALE 1:250

A1 HORZ SCALE: 1:5600 DRAWING:
A1VERT SCALE: 1:250 SHEET:

CHAINAGE: CHO 1o CH320
DRAINAGE MODEL: DESIGNER:

DESIGN A.R.I. (years): REVISION: A
PLOT FILE: pitevionr ko scie]

The title block can also contain items such as Drawing numbers (which automatically increment with each
sheet), Job numbers, Company Logos and Plot date.

All of this has happened automatically during the generation of the plot.

In general, the text in the Title block is entered in a panel once per project. It can often be entered for long-
section plots and reused for cross-section and plan plots.
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17.14.1.3 Adding Tins and Services to the Long Section Plot

When 12d Model creates a long section plot, it draws the long section of the primary string but it can also
draw sections through tins and draw the projection of strings that are in the road corridor onto the long
section.

For example, in the long section plot you will notice a section through the tin GROUND and that services
appeared on the long section plot wherever the services were in the road corridor.

section through the tin GROUND

4

ot
gEsﬁ
g |
WxE o
IEE
=

CH 218.31
L6158

strings prOJected onto the long section

SEWER 0225

The models containing the tins to section through and strings in the corridor to project onto the long
section are given in the node

Corridor >Model selection

The models in the Corridor >Model selection grid are automatically taken from the Section view entered
into the View field. So in our job, the models tin GROUND, survey SEWER PIPE and survey WATER
pipe were on Section view LONG. and so they were automatically added as Corridor models.

This list of Corridor models can be edited and added to and/or have entries deleted.

Drawing register - Corndor - Model selection

Symbols Corridor model
-?--Plot.she.etla}rout ~tin GROUND

i Pagination Bl

- Boxes 2 | survey SEWER PIPE
;--ChaiHEQEr'Staggering 3 [survey WATER PIPE

- Uprights
+ Datum area
Graph area
— Carridars

+ Bubbles

Note: for a tin to be sectioned through, a model containing the tin must be added as a Corridor model.

12d Model automatically works out where these services are in the road corridor and projects them onto
the section along the primary string.

If you have a Vertical Exaggeration on the view other than 1, the pipe will appear as an ellipse rather than
a circle.

Note that more of the pipe is displayed than where it cuts the primary string because we have a wide
corridor set for Section view LONG so all of the pipe in the corridor is projected onto the primary string.
In fact, the string only has to be in the corridor and does not even have to cross the primary string.
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This is very useful for finding strings that may not actually cross the primary string but would still be a
problem if there were close by.

The corridor width is set in the node Corridors and is currently 20 world units left and right.

- Plot to models
- Title block
- Plot sheet layout

Pagination

- Boxes
- Chainage/Staggering

Uprights

- Daturn area

Graph area

fCorior]

‘.. Model selection

- Bubbles

Quick horizontal geometry |-

- Extensive horizontal geomet
- Quick vertical geometry

- Extensive vertical geometry
- Labelling points with chaina

Labelling points with symbo

- Hatching cut/fill
- Cuts
- Paired cuts

Primary string name label

- Scale labelling

Plan Plotting

Corridor parameters

Left corridor width (world units) |2.;] ld_;J
Right corridor width (world units)  [2g ll!liJ
Left corridor overlap (world units) |li].01 ld_;J

Right corrider overlap (world units) [g,01

Cherd-arc tolerance (world units) |ﬂ.02

-

strings (no diameter)

- - = 70— — [ipipe string
== ] \ e -
primary string corridar width left -
(designlong sectiomn H
planview

design long secﬁm/—\
s — - -
— .-

S o = - -
o - \ T - — -
tin (natural swface) @\\ L
servicesin
the corridor

secfion view

- %

This means that any string in the corridor 20 world units to the left and the right of the alignment will be
projected back onto the long section and displayed.
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17.14.1.4 Cuts - Automatic Labelling of Crossing Services on Long Sections

In the long section plot you will notice that services were labelled wherever the services crossed the
profiled string, which in our case the road centreline.

ViPRL 67.472

WATER 250
CHA7T7T 41+
OL 6395

=
28
Lo
~8
==
(%]

n
y
L]
%

labelled cuts

The models that contained the services were:

survey SEWER PIPE
survey WATER PIPE

We will now look at what plot parameters control the labelling of these services.

There are parameters to define which models contain the strings are checked for cuts with the primary
string and also Masks (optionally using wild cards) that can be used in a match on the string name so that
only certain strings in the models are labelled.

To view the parameters that control the labelling of the crossing services, go to the Cuts section of the
Long Plot and PPF editor, or click on FInd and select Cuts annotation from the pop-up list.

The node Cuts defines multiple sets of model/mask combinations.

Paginaticn - Cuts - Model/Mame mask parameters The user can select a

ol Bm.ﬂ . er— T Y- wh_ole model or certain
+)- Chainage/Staggering cet & — strings from that model
- Uprights 11 <urvey SEWER PIPE bﬁ/_ spemfyTg a mask_. In
+- Datumn area — — this example, any strings
: 2 survey WATER PIPE |~

... Graph area ] Hrvey A from the survey SEWER
+- Corridors PIPE model and survey
+- Bubbles WATER PIPE will be
... Quick horizontal geometry included in the cuts

+ Extensive horizontal geomet plotting.

+- Quick vertical geometry

+)- Extensive vertical geometry

1 Labelling points with chaina

.- Labelling points with symbag

+)- Hatching cut/fill

Chainage ]

Heights stritngs to label whete they o

i i Diameters .l'/ |J \\

Labels design string jJ ! ——

Symbols

»;f--?aired cuts. planviaw

The children under the Cuts node relate to how the Chainage, Heights, Diameters, Labels and Symbols
information is placed on the plot when a cut is found for a string in a particular selection set.
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Cuts - Chainage parameters

Cuts - Diameter parameters

Use | Position X Y Angle | Colour Size | Textstyle | Pre-text | Post-text | Justification | Decimals
set # (mm) | (mm) | (dms) (mm]

1(1 above cut string height value 0 -2 90 ppf text small . 25 CH middle-right |-2

202 above cut string height value | 0 -2 90 ppf text small . 2.5 CH middle-right | -2

Cuts - Height parameters

Use |Mode Position X Y Angle | Colour Size | Textstyle |Pre-text | Post-text |Justification | Decimals
set & (mm) | (mm) |{dms) (mm)

1(1 use height of cut point | above cut string height value | 3.5 -2 90 ppf text small . 25 1L middle-right |-2

22 use height of cut point | above cut string height value | 3.5 -2 90 ppf text small . 25 oL middle-right |-2

Use | Position X Y Angle | Celour Size | Textstyle |Pre-text | Post-text | Justification |Factor | Decimals
set # {mm) | (mm) |(dmsz) (mm)
11 above cut string height value | -3.5  |-2 90 ppf text small . 2.5 SEWER & middle-right 1000 0
TE above cut string height value | -3.5 -2 0 ppf text small . 2.5 WATER @ middle-right 1000 0
Cuts - Symbol parameters
Use |Mode Symbol | Position X Y Angle | Colour Size
set # {(mm) | (mm) | (dms) {mm)
11 cross (0) above cut string height value 0 ppf services . 15
2|2 crass (0) above cut string height value 0 ppf services . 15

Again 12d Model automatically works out where these services cross the road centreline (in plan) and if

there is a cross then labels it appropriately.

Important Note

The Cuts node only controls the labelling of a cut. The fact that the pipe is drawn is because it is in a

Corridor model. So a cut can be labelled without the pipe being drawn.
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17.14.1.5 Adding a Plan Plot to the Long Section

You will notice that there was a Plan drawing on the top of the Long Section plot. The parameters to add
the Plan plot are set in the Plan Plotting node near the bottom of the Section Long Plot tree.

B Section Long Plot PPF Editor

(o] = |wsd]

Plot parameter file [ TRAINING LONG PLOT Iplotppf

[=- Section Long Plot
.. Motes

.. Plot to models

- Title block

- Plot sheet layout
.. Pagination

-
L =)

[+ Boxes

- Chainage/Staggering
- Uprights

- Datum area

()
{aa)

.. Graph area

[+ Corridors

- Bubbles

- Quick horizontal geometry

()
{aa)

- Extensive horizontal geometry

- Extensive vertical geometry

o OO OO pr O |

H
H- Quick vertical geometry
H
H

- Labelling points with chainage
- Labelling points with symbols
- Hatching cut/fill
- Cuts
- Paired cuts

()
fis)

- Primary string name label
- Scale labelling

™ Plan Plotting

- PPF's to include

rnl
L)

Plan parameters

Use plan plotting
Left margin (mm)

e

Right margin (mm) [30
Top margin (mm) [30
[350
Gap from |eft margin to start chainage (mm) |53,

1_—

Bottorn margin (mm)

F[.-

qr-

Draw border around plan plot
Border colour |ppf box linework [i]
Symbol for start chainage [PTLine
Symbol for end chainage W
Symbol size IT"S—
Symbol colour [ppf symbols @
View to plot [

Notice that Use plan plotting is ticked on and the
View to plot field is set to 1 which is why we had a
plan plot on the top of our long section plot using the
models on Plan view 1.

Finish
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17.14.1.6 Plotting all the Sheets to One Model

Rather than plotting the long section sheets to separate models, to work with some CAD systems it is
easier to have all the sheets plotted to the one model.

There are parameters to do this and they set in the Plot to models node near the top of the Section Long
Plot tree. The Mode in Translate and merge plot models is currently set to

-]- Section Long Plot Opticns for plotting to models
""" Notes Clean plot models beforehand  [always clean (=]
. Translate and merge plot models
+- Title block -
#1- Plot sheet layout Mode do not translate or n | ==
Pagination Spacing (mm) 1000 | Select Choice [x]
; do not translate or merge
+)- Boxes I— g
3 Chainage/Stagge | row-wise translatation
Uprights [l column-wise translation
+ Datum area Merge v

L. faranh area

By changing this to row-wise translation, all the plot sheets will go to the one model with a spacing
between them of 1000 mm.

Note that this parameter will only take affect when the Plotter type is model.

Also note that in the Plot to models node, there is also a field Clean plot models beforehand which is set
to always clean. That is why each time you plot to a model, the original plot data in the model is first
cleaned out.

The other choices for are Clean plot models beforehand are:

Select Choice |2
do not clean
prempt for clean
always clean
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17.14.1.7 Plotting the Long Section as a Black and White PDF

To see this plot as a black and white PDF, click on the Section Long Plot node to go back to the top of the

tree and for Plotter type, select PDF Black.

Select Plotter

=]

Hi12d
B/ PDF
B i Full 5cale
POF black
PDF black string weight
PDF colour
PDF colour string weight
|2l Half Scale
PDF unmapped

Then click on Plot to generate four pages of pdfs.

The first page looks like
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To go back to plotting to a model again, simply reselect model for the Plotter type.
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17.14.2 Writing Out a New Long Section PPF

At any stage of the editing process, the user can write a PPF file in the project with all the information that
the Section Long Plot PPF Editor panel contains so that it can be read in again at a later time. This is
helpful if you want to close the Long plot and PPF editor panel but want to save the changes.

To write a new parameter file to project:

Click LB on the Plot parameter file folder icon and select [Browse]. This will open the folder
STAGE_1.project.

"l Select a file to open =]
3 [ |

oot | <« getting started basic » STAGE1l » STAGE_l.project - |4¢ || Search STAGE_L project 2

Organize = MNew folder 3= = [l i@'

iu 05 () = Mame Date modified

. SRecycleBin
124 Mo items match your search.

J 9.00
, 10,00
| 11.00

J COUrses

|m

training
J design
getting started basic
STAGE1
) STAGE_1.project

| survey Sl m P

File name:  TRAINING LONG SECTION ~ | Files (*lplotgpf) -|

| Open | | Cancel |

Type TRAINING LONG SECTION into the File name field of the Microsoft Select a file to open
dialogue and then click on Open.

Plot parameter file [C:\12d\11.00\training\design\getting started basic\STAGE 1\STAGE_1.project\ TRAINING LONG PLOT.Iplotppf

Then press the Write button at the top of the Section Long Plot PPF Editor panel.

To read an existing PPF file in the project, clicking on the folder icon for the Plot Parameter File field and
the Folder *.Iplotppf choice panel will list them

Folder *.Iplotppf El

TRAINING LONG PLOT.Iplotppf

4 1 3
[ Select
[Lib] 3
[User Lib] 3
[Browse]

[Browse reset]

[Browse 12d Synergy]

[12d Synergy] +
[Relative]

L | M- T R |

Double click on the file name to select it and Read button. This loads the parameters into the grid.
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17.14.3 Changing to a Different Long Plot PPF File

We have generated a set of long section plots using one layout but often another client wants something
completely different. However to change layouts you simply change the Iplot ppf file.

For example, if this time is the Plot parameter file box we select the file

C:\12d\11.00\Training\design\getting started basic\Long Sections.Iplotppf.
and then click LB on Read. Then for View select LONG.

Check that the Plotter type is set to model and Digits in plot file number is 2.

B Section Long Plot PPF Editor

@]
1

Plot parameterfile [ C:\12d411.00\training\design\getting started basic\Long Sections.Iplotppf

[=- Section Long Plot

- Motes

- Plot to models

- Title block

- Plot sheet layout
- Pagination

e
il i

- Bowes

- Chainage/Staggering
.. Uprights

[#- Datum area

e )
Ll )

... Graph area
- Corridors
- Bubbles

e )
Ll )

- Quick vertical geormetry

ey B oy O OO
Ll e ol bl o g

=l
s}

- Hatching cut/fill
. Cuts
- Paired cuts

T[]
(il o}

=l
L}

- Scale labelling
- Plan Plotting

- Quick horizontal geometry
- Extensive horizontal geometry

- Extensive vertical geometry

- Labelling peints with chainage/
.. Labelling points with symbols

- Primary string name label

View to load details from

View
Global variables
Text style

Section parameters

Name of string to profile

Horizontal scale

Vertical exageration

Sheet size setup
Sheet size wd ht (mm)
Plotter parameters
Plotter type
Plot file stern

Digits in plot file number

Chainage range

Read

E
3
m

[LONG

m

[s0

o=

[ALIGMMENT->R51

[500

2

&)

(a1

[«]

[model

|previewlong section

2

B0

.. PPF's to include Use HG and VG to determine min/max chainage &l
4 | 1
[ finished
Then click on Plot and the plot displayed in Plan view Preview is:
Page 265
e = = > 7
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17.14.4 Advanced - Setting Up a More Comprehensive Plan View to Plot

We have kept the data on Plan view 1 fairly simple but in this section we will o through the processes that
you would normally do to have a more realistic plan section of the plot.

First we will create a Supertin of the tins GROUND and DESIGN to create a Supertin (a Super Tin
dynamically combines two or more tins). We will use the Supertin to display fast contours for the design
combined with the ground.

To create a Supertin, select the option

Tins =>Create =>Supertin

‘B Create Super Tin EI (=] @
R SUPER DESIGN |E| Type in SUPER DESIGN for the Super
Tin colour  [orange |:| tin field and if you the press <Enter> the
Tin style I = Model for tin will be automatically filled
L= — | in with tin SUPER DESIGN.
Model fortin  [tin SUPER DESIGM =) o
Exact calculations E Fill in the other panel fields as shown.
T | Mode | Ate |Z| Aside: if Mode and Active are left blank
— then they will default to replace and yes
1 |GROUMD  replace yes |¢| respectively.
E DESIGM | replace |§|
B
=
| choice ok
(Create] [Finish | Help | Click LB on Create.

The Super tin is then created and the Edit Super Tin panel replaces the Create Super Tin panel in case you
want to make any further changes. Click on Finish to remove the Edit Super Tin panel.

Add the model tin SUPER DESIGN to Plan view 1.

Plan1 o -E =]

The Super tin will be magenta
where the tin DESIGN exists
and green elsewhere where ever
tin GOUND exists.
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On the View menu for Plan view 1, select Settings =>Tins =>Contours

‘8 Tin Draw Contours for View EI =] @
View I (=
ST T LS < Fill in the panel fields as shown
Cont inc [0.25 e . . .
Cont ref - Aside: View is be automatically filled in
entr o i as 1 because the option was selected from
Cont colour [shade 16 L] view 1.
Bold inc [1 e
Bold colour  [shade 32 |_|
[ values set
luicts Enish) (Help) Click LB on Set
Plan1 o -E =]

BRER

The Super tin is covering
everything else so we need to
change the model drawing
order on the view to put the
supertin at the back.

You can do this by selecting the
option from the View menu for
Plan view 1,

Models =>Models to back =>
tin SUPER DESIGN

We will also give the Super Alignment RS1 a better style for plotting.

To do this press F6 to bring up the Edit String panel and then select RS1. Note - it is probably easiest to
pick RS1 from the Section view LONG where it is being profiled.

Click on the Properties icon to bring up the

fie, b, L E| OGO 7V Super Alignment Properties panel
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8 Super Alignment Properties &=
=) Basic
- General Label style DESIGN PLOT RHS [ -
- Chainage Major interval |1(]0 @ SdE;CtIChDICE (=]
ault
----aI Minor interval |2|:| [; no labels
- Transition @ :"”_ o
ariZonta
Elzs:.lre [; vertical
i DESIGN PLAIN LHS
o aeEuiE DESIGN PLAIN RHS
=) Advanced DESIGN LHS
- Start DESIGN RHS
~End For Label style, select DESIGN PLOT RHS KERBS LHS
- Design 100 for Major interval and 20 for Minor interval. || TP5 MO TEXT
F'rcn"'lles . R.AIL LHS
.. Equality Then click Set. RAIL RHE
- Pipefculvert DESIGM PLOT LHS

(DESIGN PLOT RHS :

Finally we’ll add the models survey VEG TREE and survey TOPO DRAING CL but take off the model
RS1 Sects.

We now have nine models on the view but the important information is not necessarily visible because
other data may be written on top of it. Although we could move various model to the back or to the front in
the drawing order, the quickest way to prioritise the drawing order is to use the Plan view 1 View Menu
option

View Menu: Models =>Model order

This option allows you to move models up and down in the Visibility Viewing order, and also remove
models from the view.
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8 Model Order "1"

(=] & =)

Model

ALIGNMENT
RS1 Strs

1
2]

3 | survey TOPO DRAIN CL
"4 | survey WATER PIPE

5 | survey SEWER PIPE

"6 | survey ROAD PAVEMENT EDGE
7 | survey ROAD CROWN

g | survey VEG TREE
g [tin SUPER DESIGN

XEPE)

Auto update view
|
)
4

To move models up or down, highlight the
model in he list and then click on the Up
arrow or the Down arrow.

This is a Model Visibility order so the model
ALIGNMENT is to always visible and hence
is drawn last.

So the drawing order is for tin SUPER
DESIGN to be drawn first, then survey VEG
TREE, then survey ROAD CROWN and so
on up the list until ALIGNMENT is drawn
last.

Move the models up and down on your list
until you have the order shown.

Now in the Section Long Plot PPF Editor panel, and select and read in the Plot parameter file
TRAINING LONG PLOT.Iplotppf that we just wrote out.

P Section Long Plot PPF Editor

=] = /s

- Section Leng Plot

Plot parameter file [ TRAIMING LONG PLOT.Iplotppf

View to load details from

- Motes Wiesy | E]
- Plot to models
- Title block Global variables
[ Plot sheet layoi|  Textstyle [Arial
- Pagination Plat symbals |
[+~ Boxes .
& Chainage/Stag Section parameters
- Uprights Mame of string to profile  [AlIGNMENT->RS1 -
[+- Daturn area Muodel of strings to profile |
- Graph area .
Horizontal scale L
- Corridors . . |SUU
- Bubbles Vertical exaggeration 2
.. Quick horizont Start chainage |
[ Extensive horiz: End chainage |
- Quick vertical ¢ :
[+~ EBxtensive vertic Sheet size setup
(- Labelling point Sheet size wd ht (mm) (a1 E]
- Labelling point| pjqye, parameters
- Hatching cut/f
G Cuts Plotter type |PDF colour
[ Paired cuts Plot file stem preview long section.pdf Change the Plotter type to
- Primary string || Digits in plot file number [ PDF colour.
[+ Scale labelling Chai
- Plan Plotting anage range
- PPF'sto includ Use HG and VG to determine min/max chainage [F
<« [m ' And then click on Plot to
[ finished generate the four long section
) pffiles
i
Page 270
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The first and third of the four pages of long section plots are:

= “W‘_“fmmwamq'g“zaauug_,
F ‘144@4”4(1&'[
Mgy, /
%24//1_40&
eownmgeo0 o |\ _ I I 0 || ‘1 1___L
HORIZONTAL CURVES ==
VERTICH. cuRvES -
VERTICA GRADES = —
L P I IS - =S NN N N N - | NN [ = [ = 1 -]
veumse
e EE I A N A R [ [ [ [ [ [ [ [ [
pesion 8 £ . e s Y d e e . P
BURVEY g 8 g 2 =
. . ) X 1. :
Frowceses 2 £ ki g H H 3 i3 g e g i @ B i
CHANAGE .
& E F g 8 E HE H e ) 8 2 & g
RS1- LONGITUDINAL SECTION
A1HORZ SEALE
&1 VERT ecalE 1380
PROJECT NAME ATRCRZECAE  1.%0
J VERT 804 =0
PROJECT NUMBER ATVERTEZALE 1 0 5101520 30 &0 80
ROAD DESIGN ———— 4o cHam
P p—— DRAMAGE UCOEL
DEBIGH AR fyeses)

£
P
H
g
8
-
[
< e Ty
CeTEg e -
T, SRS ~ o AR
T s——-F I NN
:
T O 1 e e
HORIZGNTA GURVES e -
VERTICAL GURVES 3 = = ==
VeRTIGALGRaDEs . y
[ - = [ e T = [« 7« 7 I [ = T = J7 = T I | I
voLumEs
[P~ [ [T [ T = [ [ = T = [ =1 | N I I IR T
= H | £ H i i H i IR L HH i H H H F
amer : R H H i : HH H H id FF HE 5 § H B ;
DESTH & = e zal
mouoean | E 58 H E L § i L EL] 33 i 3 § Y 5
= B 5 B P 9
e E CIE i 8 8 8 Al 2 £ F 5 ol % i i 8 3
RS1 - LONGITUDINAL SECTION
A HORE SEALE 1500
N VERT SoMiE 1250
FROJECT NAME ARRZIGAE 150 e
PROJECT NUMBER: AriERTSoME = D 5101520 30 40 50 =
ROAD DESIGN e ————— TS 12 CHANAGE: CHEN f cHEN
Scale Bar
LONGITUDINAL SECTIONS SRAMAGE MR cesiane
SN AL feans s A
S e s

Notice how the North Arrow in the Title Block has automatically rotated with the Plan Section of the Plot.



12d Model Getting Started and Training Manual

17.15 Plotting Sheets of Cross Sections

In your Section view CROSS, profile any valid cross section from the model of cross sections called
RS1 Sects. that is, from the View Title Area for Section view CROSS, click LB on the Profile button and
click LB on any cyan cross section string you can see in any view. Confirm the selection with MB.

Also add the model tin GROUND, survey WATER PIPE, and survey SEWER PIPE to Section view

CROSS.

Also make sure that the vertical exaggeration of Section view CROSS is set to 2. The large range of cut
and fill in the training data files will reduce the number of sections per sheet if you have the vertical

exaggeration set any larger than 2.

To run the Section X Plot PPF Editor, from the View Button Area for Section view CROSS click LB on

the Printer Icon and select X plot

View Plotting "CROSS" (&)
Plot

Leng plot

X plot

Drainage/Sewer
Melbourne Water

Pipeline

Select X plot

Alternatively you can click on the option Plot =>Plot and PPF editors =>Cross Sections.

i Section X Plot PPF Editor

Plot parameter file |

(o] = |[=]

P TV

View to load details from

-] Section X Plot

- Motes View CROSS

- Plot to models .

G- Title block Global variables

. ¥ section filteri Teut style 1

- Extra X sections

[~ Plot sheet layo .

[+]- Boxes/Centrelir Fad e T

. Graph area Horizontal scale 100

- Corridors Vertical exaggeraticn 2
i Pri del x-sections to plot
ey rimary model x-sections to plo

- Hatching cut/f Model of xsec to plot RS1 Sects
- Cut/Fill area lat
- Cuts ,7
- Paired cuts
- Paired points Boxes/Centre line

- PPF's to includ Label type Boxes

Draw and label the primary string

Sort sections

Folder *xplotppf

a4 LI

[ Select

[Lik]

[User Lib]

[Browse]

[Browse reset]
[Browse 12d Synergy]
[12d Synergy]
[Relative]

[Unicode format]

[Ansi format] (System codepage)

[UTF-& format] (System codepage)

[Explore]

Sheet size setup [Delete filg]

Sheet size wd ht (mm) a1 [Emaill

Plotter parameters

Plotter type [model

Plot file stem |
4 i P |

|p|u:utteru:|k

In the Plot
parameter file box
located at the top of
the panel, LB click
on the folder icon to
bring up the folder
choice box.
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Browse to the folder C:\12d\11.00\Training\design\getting started basic and select the file
xsection_intro.lplotppf. Click LB on Read

Select the Section view CROSS from which the plot is to be generated from by clicking LB on the View
icon button adjacent to the View to load details from box near the top of the panel. and select CROSS.

Note: If a value is typed then the user must then press the <Enter> key to accept the view.

Go to the Title block >User title info node by navigating the tree control as described previously for long
sections and fill in the Value fields for ROAD DESIGN for Main Title, RS1 for Sub title2 and A for

Revision.
[=I- Section X Plot User title block parameters
- Notes Title file [SLIB\12d_title_block_AL tbf
.. Plot to models
- Title block e | Value

| User title info 1 Main Title ROAD DESIGN
Drawing register T Sub fitlel CROSS SECTIONS

.. X section filtering 3| Sub title2 RSl

.. Extra X sections to plot
[#- Plot sheet layout

[#- Boxes/Centreline labels
.. Graph area

- Corridors

.. (Grades

[#- X-section points

- Hatching cut/fill

.. Cut/Fill area labels

- Cuts

- Paired cuts

- Paired points

.. PPF's to include

n Drawing Mumber
5 Sheet

? Revizion

Time format [3od-6b- 36 aH:%M: %65

Start page number [

Start drawing number |1

Drawing number prefic [

Drawing nurmber postfix |=

At any stage of the editing process, the user can write a X Plot PPF file that can be read into a panel at a
later time. This is helpful if you want to close the Section X Plot PPF Editor panel but want to save the
changes. Simply type a new file name into the Plot Parameter File box at the top of the Section X plot
PPF editor and press the enter key.

Plot parameter file | TRAINING X SECTIONSxplotppf Read| [Write

This assigns the relevant file extension. Then press the Write button at the top of the panel.

To read an existing PPF file, the user can choose the file from the Plot Parameter File box, then press the
Read button. This loads any existing parameters into the grid.

To generate a plot, return to the front screen and check that the Plotter type is model then press the Plot
button at the bottom of the panel.
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Plotter parameters
Plotter type

Plot file stem

Digits in plot file number |3

|preview cross section

12d Model calculates that there needs to be multiple sheets to complete the job.

With the supplied Plot file stem of preview cross section and Digits in plot file number of 2, 12d Model
will create three sheets and the models preview cross section01, preview cross section02 and
preview cross section(3.

In Plan view PREVIEW, remove all models on the view and then add on the model
preview cross section01.

Plan PREVIEW

=)o =

R i e

[0CC 0O 0 CCo
[ICCOC 00 [0CCo
(oo oo oot

(e e B

[OC CC O OO0
[CC [0 OO0 O
[0C [0 C o

| —
[l
[
—
| —
[
[
[
[

[
[

=

[
[

[ICCC 00 [0 CIC
[ICCO OO0 [0 O
[[0CC I ¢ oot

B i3 e o W

[ICCOC 0O 00 CIo
[I0CC CC OO0 COrC
[0CC oo o

R 11 e e R

[[CCC OO [0 CIC
[IOCOCCCO0 O
(0o oo o o

[MIC OO0
[ICCOC OO [OCCC
[0 romook

If you zoom in and pan around the plot you will notice that 12d Model starts each sheet by assembling
cross sections in the bottom left corner and working upwards. When it can no longer fit more sections in
that column, it will move to the right and, starting at the bottom of the sheet, work upwards again. When it

fills a sheet, it will automatically go to the next sheet.

All cross sections are presented in increasing chainage order and the Chainage of the x section is shown
underneath the plot of each x section.
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>V

c‘;'\t

Centreline Data
X = 42816.976

Y =37389.603

Z = 67.087

WATER 8250
—+0/8 -10.66
OLB4,04

-

DATUM RL 63.000

DESIGN

66.159
67158
67.261

SURVEY

67.782 66962
67.644 66962
67.624 &7.072

67.849 67.159
67.792 @67.072

OFFSET

-12260 67933 67933
-0.600 67.881
0.000 67.730 6&7.067
7600 67.481

11.263 ©7.261

-7.600
-4.100
-3.500
3.500
4.100

Note the annotation in the boxes area, the labelling of the datum, the X,Y, Z of the centreline, the labelling
of the grades on the x section, the hatching between the design and the ground and the labelling of the
water string where it crosses the road cross section.

Finally, Zoom in at the right hand side of the base of the sheet and observe the Title block text.
The start and end chainages for the sheet and automatically calculated for inclusion in the title block.

OFFSET

DRAWING:

SHEET:

CHAINAGE: CH21.86 fo CH 360
DESIGNER:

REVISICN: A

The other sheets will contain similar sections.
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17.15.1 Plotting the X Sections as a Black and White PDF

To see this plot as a black and white PDF, click on the Section Long Plot node to go back to the top of the
tree and for Plotter type, sclect PDF Black.

Select Plotter

EI12d
B3 PDF

PDF b

|21 Half 5S¢

Then click on Plot to generate three pages

The first page looks like

B I Full Scale

PDF black string weight
PDF colour
PDF colour string weight

ale

PDF unmapped

of pdfs.

\;%2'&:&&%‘,;5—

7

oEmEN
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e |

B

5
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s ot
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p—
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St
o Ef
[— 12
orFeer EEE
CHAINAGE 360
%71&1;&2&2’1&'@7/

N e

CHAINAGE

N7 e

ATVERT SCALE
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cRoz3 2ECTIONE DRAMNAGE MODEL:

ra1 DEsiGN AR s

= i E§ g
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sEzan LR e EERnE - R [
suRVEY 3y §e FHIEEE 8 8§ El
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CHAINAGE 120
PROJECT NAME: ARoRZIGAE | 1:a
PROJECT NUMBER 1ins

To go back to plotting to a model again, simply reselect model for the Plotter type.
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17.15.2 Adding Tins and Services to the Cross Section Plot

When 12d Model creates x section plot, it draws the section of each of the string in the model of x sections
(the primary strings) but for each x section, it can also draw sections through tins and draw the projection
of strings that are in the road corridor onto the x section.

For example, in the x section plots you will notice a section through the tin GROUND and that services
appeared on the x section plot wherever the services were in the x section corridor.

Ceontreline Data
X = 42816.976

Y = 37389.603

Z =67.067

DESIGN

string projected onto the long section

OFFSET

67.159
67.261

67.782 66962
67.644 86962

67.624 G7.072

67.8489 67.159
67.792 67.072

500
500

-7.600

-4.100

0000 67.730 67.067
7600 67.481

11.263 ©7.261

-3,
3.500
4.100

=8.

blow up of pipe in x section corridor

The models containing the tins to section through, and strings in the corridor to project onto the long
section are given in the node

Corridor >Model selection

The models in the Corridor >Model selection grid are automatically taken from the Section view entered
into the View field. So in our job, the models tin GROUND, survey SEWER PIPE and survey WATER
pipe were on Section view CROSS. and so they were automatically added as Corridor models.
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This list of Corridor models can be edited and added to and/or have entries deleted.

= Section X Plot Corridor - Model selection
Elntes il Corridor model
- Plot to models
tin GROUMD
& Title block |
. User title info 2 | survey WATER PIPE
Drawing register 3 [ survey SEWER PIPE

- X section filtering

- Extra X sections to plot
- Plot sheet layout

[+]- Boxes/Centreline labels
- Graph area

= Corridars

.. Grades

Note: for a tin to be sectioned through, a model containing the tin must be added as a Corridor model.

12d Model automatically works out where these services are in the road corridor and projects them onto
the section along the primary string.

If you have a Vertical Exaggeration on the view other than 1, the pipe will appear as an ellipse rather than
a circle.

Note that more of the pipe is displayed than where it cuts the primary string but much less so than in the
Long Section plots (see 17.14.1.3 Adding Tins and Services to the Long Section Plot on

page 257.).

This is because the corridor is set to 20 world units left and right in the long section but only 0.01 world
units left and right for the x section plot.

[=- Section X Plot Corridor parameters
- Notes Left corridor width (world units) [0.m ]
- Plot to models

&1 Title block Right corrider width (werld units)  [p,01

Uzer title info

Left corridor overlap (world units)  [p,01

Drawing register Right corridor overlap (world units) g n1

- X section filtering
.. Extra X sections to plot
G- Plot sheet layout
- Boxes/Centreline labels strings (no diameter)

. Graph area primary string = - = _ _ [| mpesting
X Corrdors (desizn x- seitiTi “ Icwﬁdor_width_leﬂ

L Model selection right_extension

Chord-arc tolerance (world units)  [p02

- Grades left_extension
[+ X-section points - I cotridor_width right

@~ Hatching cut/fill e - - - =07 - - - - —-
.. Cut/Fill area labels y

Cuts plan view
= - Offeet % e ———— zervices in the corridor
i Offsets
Heights design - section
Diameters B _\\x\v —
- Labels Wl
.. Symbals tin (natural swface)

sarfiom wiaw

So only the parts of strings in the corridor 0.01 world units to the left and the right of the x section will be
projected back onto the x section and displayed.

Having such differences between the corridors for the long section and x section plots is very useful
because the long section will show you that there are problems in a wide corridor, and the x-sections will
show you exactly where the problem pipes are in offset and height from the alignment.
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17.15.3 Cuts - Automatic Labelling of Crossing Services on Cross Sections

In the x section plots you will notice that services were labelled wherever the services crossed the x
sections.

QA
é\:

Centreline Data
X = 42816.976

Y =37389.603

Z = 6T.087

DATUM RL 63.000

WATER 2250
—+0/3 -10.66
OLG4.04

-

DESIGN

66.159
67.159
67.261

SURVEY

67.644 66962

67.848 67.159
6r.624 @&7.072

OFFSET

-12.260 67933 67.933
-0.600 67.881
0000 67.730 67.067
7600 67.481

11.253 ©7.261

-7.600
3.500
4100

The models that contained the services were:

survey SEWER PIPE
survey WATER PIPE

We will now look at what plot parameters control the labelling of these services.

As for LOng sections, there are parameters to define which models contain the strings are checked for cuts
with the x-sections and also Masks (optionally using wild cards) that can be used in a match on the string
name so that only certain strings in the models are labelled.

To view the parameters that control the labelling of the crossing services, go to the Cuts section of the
Section X Plot and PPF editor, or click on FInd and select Cuts annotation from the pop-up list.

The node Cuts defines multiple sets of model/mask combinations.
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[=- Section X Plot Cuts - Model/Name mask parameters The user can select a
- Notes Define | Model Narme whple model or certain
- Plot to models setd rmack strings from that model
=- T;itlil bloc-k| . 11 survey SEWER PIPE |+ }[:ﬁ/ spemfylilg a maik.. In
i User title info — 1S example, any strings
Drawing regis 2|2 survey WATER PIPE from the sl:lrvey }S,EWF%R
.. X section filtering PIPE model and survey
- Extra X sections WATER PIPE will be
[+~ Plot sheet layout included in the cuts
[+]- Boxes/Centreline plotting.
- Graph area
= Corridars
‘.. Maodel selectic
- Grades

- £-section points
&~ Hatching cut/fill

- Cut/Fill area label
o . atrinigs to label whete they are
E'" PRUTATT ST cut by the cross section

i Offsets (design x- section) ¥ T—a
Heights | | |
Diarneters 16ft_extension | | rjg}-ﬂ,_extensionl
Labels planview

Symbols
points where strings are

. Ea!re: chst A e————"" cutinplan by the xsection
- Paired points

desi - secti
- PPF'sto include PSR sechon

e

'\\_un |natural swface) section view

4 1 [

The children under the Cuts node relate to how the Offset, Heights, Diameters, Labels and Symbols
information is placed on the plot when a cut is found for a string in a particular selection set.

Cuts - Offset parameters

Use | Position X A Angle | Colour Size | Textstyle | Pre-text | Post-text | Justification | Decimals
et # (mm) | {mm) | (dms) (mm)
1(1 at cut string height |0 2 a0 ppf text small . 25 0/ middle-left -2
2|z at cut string height |0 2 90 ppf text small . 25 0/ middle-left | -2
Cuts - Height parameters

Use | Mode Pasition X ¥ Angle | Colour Size | Textstyle | Pre-text | Post-text | Justification | Decimals
et £ (mm) | (mm) | (dmis) (i)

1|1 use height of cut point | at cut string height | 3.5 2 90 ppf text small . 25 L middle-left | -2

72 use height of cut point | at cut string height | 3.5 2 90 ppf text small . 25 oL middle-left | -2

S

Cuts - Diameter parameters

Use |Position X Y Angle | Colour Size | Textstyle |Pre-text | Post-text | Justification | Factor | Decimals
set F {rmm] | {mm) |{dms) (mm)
11 at cut string height -3.5 2 90 ppf text small . 2.5 SEWER & middle-left |1000 0
2|2 at cut string height -3.5 2 90 ppf text small . 2.5 WATER @ middle-left 1000 0

Cuts - Symbol parameters

Use |Mode Symbaol | Position X ¥ Angle | Colour Size
set & (mm) | {(mm) | (dms) (mm)

1 cross (0] at cut string height 0 ppf services . 15
2 cross (0] at cut string height 0 ppf services . 15

1
2

Again 12d Model automatically works out where these services cross the x section (in plan) and if there is
a cross then labels it appropriately.
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Important Note

The Cuts node only controls the labelling of a cut. The fact that the pipe is drawn is because it is in a
Corridor model. So a cut can be labelled without the pipe being drawn.
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17.15.4 Extending the Natural Surface Beyond the Cross Section

By default the plot of a x section only goes from the beginning of the x section on the left to the end of the
cross section on the right.

It is possible to vary this in two ways.

On the Plot sheet layout node are the Plot width parameters.

= Section ¥ Plot Plot width parameters
- Notes Absclute extensions
- Plot to models . . —
Left extension (world units F
. Title block . " ) 2 =
User title info Right extension (world units) [z nl—;
- Drawing register Align section parameters
- & section filtering . .
Line up centrelines o

- Extra X sections to plot

Margins

- Sub plot gaps

If Absolute extension is not ticked, the width of the section is extended by Left extension units to the left
of the beginning of the x section and Right extension units to the right of the end of the x section. The
section through any tins is and services is done with respect to the extended section as well as cuts. This is
very useful to see what the terrain and services are like outside the width of the x sections.

S

oM
-y

left extensions of 2 /

Centreline Data
X = 42816.976

Y = 37389.603

Z =67.067

DATUM RL 63.000

WATER 0250

+0/5-10.68
OL84,04

right extensions of 2

DESIGN

66.159
67.067
67.159
67.261

SURVEY

67.782 66.962

67.644 66.962
67.624 67.072

67.8349 67.159
67.792 67.072

OFFSET

-12.260 67933 67033
-9.600 &7.881
0000 67.730
7600 67.4381

11.263 67.261

-7.600
-4.100
-3.500
3.500
4.100

If you were to set the LHS extension to 30 world units, you get extremely wide of x section plots.
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Canireline Data
Pt %%@E’Eﬁééﬁ/!ﬂ %
Ll -]
DATUM RL 54.500 Centrine Diata
Kom 47741 TE
DESIGN E R R EE B EE K EE ¥= 7mzmn
- G B/ 8 EE B EE B HE ;:U”";i_nx
- | 61
SURVEY B hBE 81 B EI IE:
B kb v & EE 8 85 E DESIGN
=
= I BB EE 5 7
oFFsET i 55 53 § 8% BE? SURVEY
CHAINAGE 200
OFFSET
‘ﬁg?;’&i:@ii‘ﬁ;z@ <
g 1
Ccantreling Data E=3 Centring Data
Kedmiggme -.l,! K= 4T78007
¥ m TG00 3ag Yo ITIOTA
ZT=@ar.oeT + T I
DATUM RL 53.000 DATLIM RL 62000
DESIGN g8 B &8 CE B EE EEg DESIGN
B E| & EE B Es | 8
o | 2 mm = == = ==
SURVEY B B| 3 EBE B &g § BE SURNEY
T
OFFSET f BB 2% = 5= sz @§@ OFFSET
bl B I 7% o ol w =l al=
CHAINAGE 180
PROJECT NAME: A1 HORZ SCALE: 1:250
PROJECT NUMBER: A1 VERT SCALE 1:125
ROAD DESIGN
CROSS SECTIONS DRAINAGE MODEL:
R51 DESIGN ARL [years)

T T e T

TS0 B T R

If Absolute extension is ticked, the width of the section goes from Left extension units to the left of the 0
offset (where the centreline is) to Right extension units to the right of the 0 offset.

For example, with Absolute extension ticked and a left and right extension of 5, the x section plots would

look like:

Centreline Data

X=42816.976

Y = 37389.603 ' v

Z = 67.067 EZ/ S

DATUM RL 66.000

DESIGN 58 8 8§
58 B 8%
S59 8 5

SURVEY e B 38
sl 5 5k

OFFSET S8 8 88
9 o o <

CHAINAGE 180
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17.16 Plan Plotting Using Plot Frames

Plot frames are a set of tools within 12d Model that permit a series of plan plots to be readily generated
and regenerated as required. The plot frames are superimposed over data in a view and the various frames
plotted. All plots are clipped to size by the plot frames and will contain only the data that is on display in
the plan view being processed. The user decides to plot one or more frames individually or plot a complete
set.

The quickest method for creating a plot with multiple plan views on it is by using the Plot Sheet and that
will be discussed in a following section (See 17.17 Plan Plot Sheet on page 302). The Plot Sheet does
create Plot Frames so it useful to work through this section first.

We now need to assemble the data we want to plot in a view. We will use view Plan view 1 for this
purpose. Make sure that the following models are turned on in view Plan view.

ALIGMMENT

R51 Sects

R51 Strs

survey ROAD CROWN

survey ROAD PAVEMENT EDGE

| Select |

Your view ‘Plan 1’ should look as follows.

Plan1 E=R(ECH =5

We want to create plot frames
that encompass the various
roads in the view. We will
probably need more than one
plot frame. In our case, each
plot frame will represent an A1
sheet.
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17.16.1 Creating Plot Frames

We will create our first plot frame.

User defined plot frames can be placed over the data in the view. These frames show both the sheet size

and plot area borders.

From the Plot Frames menu Plot =>Plot frames=>Create
Navigate to the folder C:\12d\11.00\Training\design\getting started basic and choose the title file Plan

Plot.tbf and the panel will be filled out as follows:

- = ™
“# New Plot Frame Create ‘ E@ﬂ

Title file

F'Iotting l Margin l

Mame [pfalsurvey
Model [pfalsurvey
Colour |red
Scalel: [1000

Sheet size wd ht (mm) [a1
Rotation angle o=

Origin |

Draw viewport border

Draw Frame border

[rted basic\Plan Plot.tbf

0 & R JE W E

e = LDhtrainin esignigetting starte
File = C:\12d\11.00\training'design’.getting dl

[ Create ] [SEmeas] [ Finish ] [ Help ]

General

Then select the Create button.

Plotting Margin |

Left margin {rmm) [31.3633

Right margin (mm) [31.3631

Bottom margin (mm) |ju,ggﬁ4

Top margin (mm) 311603

Click LB on the Origin icon

magenta circle.

appear in the field.

)k

Select a point in the bottom left
of the view as shown by the

Confirm the selection with MB.
The X and Y coordinates should

12d will transform the panel into the New Plot Frame Edit panel so that you can make edits to the plot
frame if there is an error.
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i !
‘@ New Plot Frame Edit Eﬂlg
il

Draw viewport border

Title file Cad2d\11.00% raining'.c

| | g You will notice that the Edit panel is
Plotting l Margin ] very similar to the Create panel.
Mame |pfalsurvey The main difference is that there are
g [pfal buttons to Translate and Rotate an

pratsuriey . existing plot frame.
Colour |red E]
Scalel: [1000
Sheet size wd ht (mm) [a1 E]
Rotation angle 5
Origin [42608.0099 36977.73:
[

Crraw Frarme border

[Translate][ Rotate ][ Finish ][ Help

To see our plot frame, you need to use the + in the view Plan I to turn on model pfalsurvey. Do a Fit on
the view.

Clearly our first guess at the scale
is incorrect. We need to scale down
our plot frame.

In the New Plot Frame Edit panel,
opposite the Scale 1: field, change
the 1000 to 500 and click LB on the
Set button.
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Click LB on Fit to fill
the view.

In the Plot Frame Edit panel, click LB on Rotate. Move the cursor into the view Plan I and notice that
you can rotate the plot frame about it’s insertion point. When you have the cursor positioned appropriately,
click LB and MB to confirm the selection.

Similarly, click LB on the Translate button and move the plot frame in view Plan 1. You will notice that
the rotation angle is maintained as you move the cursor. When you have the cursor positioned
appropriately, click LB and MB to confirm the selection.

The final position of your plot frame pfl should look as shown below.

You are trying to arrange
the sheet to maximise the
amount of information
shown on it i.e. minimise
the number of sheets.
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i b
‘@ New Plot Frame Edit - Elglg

Title file |C:‘«12d‘«ll.00\trainingic
Plotting | Margin |

MName |pfalsurvey
Madel ||:|1=alsur'.rvag..r
Colour |red E]
Scalel: 500
Sheet size wd ht (mm) [a1 E]
Rotation angle 334°40'15.38"

Origin [608.0999 36977.7322

Draw viewport border

O =

Ciraw Frame border

| Curser/Grid position accepted

[Translate][ Rotate ][ Finish ][ Help ]

We will now create the second plot frame.

Click LB on Plot =>Plot frames =>Create again.

o ™
"B New Plot Frame Create h EIEIQ
Title file [ted basic\Plan Plot.tbf

F'Iﬂttlng | Margin |

Mame |pfalsurn.re3,r2
Model |pfal SURVEY
Colour |green
Scalel: |5|:||:|

Sheet size wd ht (mm) |,q1

Fotation angle [34°40'15.38"

50,0999 36977.7322

Crigin 1.

Draw viewport border

o = FREEE«E

Draw Frame border

| "pfalsurvey-=pfalsurvey"” selected

[ Create ] [Sameas] [ Finish ] [ Help ]

Notice that the rotation angle and origin now
have non-zero values.

That finishes the creation and positioning of
our first plot frame.

Click LB on Set and Finish.

The panel will initially come up blank.

Click LB on the Same as button, position the
cursor near any one of the corners of the
pfalsurvey plot frame and click LB to select it.
When it highlights, click MB to confirm the
selection.

Change pfalsurvey to pfalsurvey2
Change the Colour from red to green

Click LB on the Create button.

12d will transform the panel into the New Plot Frame Edit panel
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i ™y
B New Plot Frame EM'E'Q

Title file [C\12d\11.00\training\c
Plotting | Margin I

Mame |pr1 survey2 As befqre, click LB on Rotate. Move the

Model cursor into the view Plan I and rotate the
ode |pfalsurvey plot frame about it’s insertion point. When

Colour [green you have the cursor positioned

Scalel : /500 appropriately, click LB and MB to confirm

the selection.

Sheet size wd ht (mm) |‘ﬁ'1 Then click LB on the Translate button and

move the plot frame in view Plan 1. You
will notice that the rotation angle is
maintained as you move the cursor. When
you have the cursor positioned
appropriately, click LB and MB to confirm
the selection.

Click LB on Set and Finish.

Fotation angle [334°40'15.38"
Qrigin [42608.0999 36977.732 (1.

Draw viewport border

Draw Frame border

o e FEEUEREE

[Translate][ Rotate H Finish ][ Help ]

Repeat for the third plot frame using name pfalsurvey3 and colour blue

By rotating and
translating the
position of the third
plot frame, make the
final result look as
shown.
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17.16.2 Using the Plot Frame Editor

If you ever want to make changes to one of your plot frames and the panel is not currently on display, you
can use the Plot Frame editor to do this.

Click LB on Plot =>Plot frames=>Editor

The New Plot Frame Edit panel as seen earlier will appear on the screen.
Click LB on Pick and then select the existing plot frame that you wish to edit.
click LB to select it. When it highlights, click MB to confirm the selection.
To shut down the New Plot Frame Edit panel, click LB on Finish.

17.16.3 Create Plots Using Plot Frame PPF Editor
Plotting the contents of a plot frame is done using the Plot Frame PPF Editor.

This panel can be brought up in two way:
1. Select the option Plot =>Plot frames =>Plot

This then brings up the Plot frame PPF Editor panel.
or

2. Clicking on the Plot icon on the Plan view:

click LB on Plot icon

This brings up the View Plotting menu and then select Plot frames from it.

View Plotting "1 (i
Quick plot
Quick sheet plot
Plot sheet

Plot frames

LB click on Plot frames

Drainage plan

The Plot frame PPF Editor panel then comes up.

Page 290
= = = L 7 X



Chapter 17 Plotting

@ Plot Frame PPF Editor

:
3

Plot parameter file ] Read

@

[=- Plot Frame Single plot frame

=
(=]
=4
m
4
H

Plot to models

& Title block Model of plot frames

@

View to plot

View to plot |

=]

Plotter parameters

Plotter type [model
Plot file stemn |

Use drawing number as plot file number

B

B

Use frame name as (non-model) plot file number

| plotter ok

This panel has a tree structure, much like the Windows explorer type functionality.

A + symbol in the left of the panel indicates that there are levels below. To access lower levels, simply LB
click on the + symbol to expand the tree.

Expand the tree so there are no more + symbols and every level is shown.
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P i
Plot parameter file | Read| [Write

=~ Plot Frame Single plat frame
- Notes Flot frarme | e
- Plot to models
- Title block Muodel of plot frames
User title info Model of frarmes |
: Erau\:}inlgregister View to plot
L SYMDOIS Wi p|0t | @

Plotter parameters

Plotter type [madel
Plot file stermn |

Eow

Digits in plot file number |

Use drawing number as plot file number

ENE

Use frame name as (non-model) plot file number

| plotter ok

To go from one level to another, simply LB click on the text headings on the tree structure.

For this example, we want to plot more than one Plot frame at once so we will chose the Model of plot
frames method. If we wanted to plot just a single plot frame, we would select the frame using the Single
plot frame selection tool.
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Click LB on the Plot Frame level.
The Model of frames is pfalsurvey.
The Plotter type to select is model, as we want to inspect the plot before sending it to the actual plotter.

Type in preview plan as the plot file stem. The plot stem specified will form the prefix for the plot name.
This is important for plotting of a number of plot frames. For this example we have 3 plot frames so the 3
plot files produced will be "preview plan 1", "preview plan 2" and "preview plan 3".

The fields for the Plot Frame level should look as follows:

‘9 Plot Frame PPF Editor =i,

Plot parameter file | Read| [Write
@ Single plot frame

i Notes |
%
i Plot to models
él--TitIebIock Medel of plot frames
. User title info Model of frames |pfalsurvey

Drawing register

View to plot

.. Symbol
ymbols View to plot [

=)

Plotter parameters

Plotter type |r'r'|nu:|e|
Plot file stem [preview plan
|
Use drawing number as plot file number |
Lse frame name as (non-model) plot file number [

Now click on the Plot to models level and for the choice box Clean plot models beforehand, select
always clean.

W Plot Frame PPF Editor = X3
Plot parameter file | Read| [Write
- Plot Frame Options for plotting to models

- Motes Clean plot models beforehand  [3jways clean E]
i Plot to models
— Translate and merge plot models
= Title block
User title info Mode |dn not translate or mr @
. Drawing register Spacing (mm) [L000
. Symbols Origin X (mm) 0
Origin ¥ {mm) o
Merge ]

Note: this choice will clean out the model preview plan before the plot is generated. If you want the option
to be asked each time a plot is created, select prompt for clean as the choice.
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Click LB on the Title block heading. Tick the Use title file checkbox as follows. This specifies that a Title
file will be used for the plotting.

[=- Plot Frame

Plot to models
L User title info
Drawing register
Symbols

Commen title block parameters

Standard title

[TUse title file

Title line 1 |

Title line 2 |

12d default title block parameters

Text size |5

Text colour lcyan

Models to plot in plotting units

Plot data model 1 |

Plot data model 2 |

Flat data model 3 |

EE =

HE

Q|

Click LB on the User title info heading and select the title file Plan Plot.tbf from the folder
C:\12d\11.00\Training\design\getting started basic.

= Plot Frame

Plot to models
- Title block
User title info
Drrawing register
Symbols

User title block parameters

Title file

Mame

Yalue

1 Description linel
_2 Description line 2
3] Description line 3
_4 Drawing number
_5 Client name
6 Surveyor
_'_-' Drawn
g Field Book

g | Checked

F Date of Survey

E Level Datumn line 1

F Level Datum line 2

11 | Horzontal Datum line 1
f Horizontal Datum line 2

[etting started basic\Plan Plot.tbf

Tirme format |

Start page number |1

Start drawing number |1

Drawing number prefix |

Drawing number postiic |

Once selected, a valid title file will populate the grid with user defined title file aliases. These are prompts
for title box text and once filled out, will be substituted into the title block.
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Fill out the Value part of the grid o suit your requirements - not all the Value fields have to be filled out.

Note: this panel can be resized by moving the mouse to the extremities of the panel and whilst holding
down the LB near the edge, moving the outline to the required size just like resizing any view. Resize the
panel in both the horizontal and vertical so that it takes up most of the screen. Note Like any panel it can be
minimised by using the standard windows minimise button.

- Plot Frame User title block parameters
- Notes Title file [etting started basic\Plan Plot.thf
i Plot to models
& Title block Name Value

Description line 1 DETAIL SURVEY OF
Description line 2 ROAD 1 AREAS
Description line 3 VILLAGE OF RAIWAL
Drawing numkber SUVA-001

... User title info 1
' 2

3

4

5 Client name
6

7

8

9

Drawing register

... Symbals

Surveyor MEE

Dirawn MEB
Field Book FB-332
Checked MEBE

10 Date of Survey /12715

11 Horizontal Datum line 1

E Horizontal Datum line 2

13 | Level Datum line 1

F Level Datum line 2

Tirme format |

Start page number il

Start drawing number |}

Drawing number prefic |

Drawing number postfic |

The Symbols section allows us to add a symbol to a user defined location on the plot, and the symbol can
be automatically rotated in the plot to match the angle of the plot frame.

Click LB on the Symbols heading

[=- Plot Frame Symbol parameters
Notes Symbol Scale mode | Scale | Rotate Rotation | Colour X Y
E Plot to models with plot
- Title block 1|NTHPTS00 | Native scale 500  Ves magenta [JJJJ 100" 500

User title info
Drawing register

In the example above we have selected the symbol NTHPTS00. We select Native scale and then type in
500 for the Scale (Remember the plot frame was set up as 1:500).

To rotate the north arrow with the plot we select Yes for Rotate with plot

The colour for the arrow will be magenta and the north point will be positioned on the plot sheet in plot
units. Type in 100 for the X and 500 for the Y values

This will position the arrow up at the top left of each plot
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To generate a plot, press the Plot button at the bottom of the panel followed by pressing Yes to confirm
cleaning the plot models.

In view Plan PREVIEW, remove all the models on the view and then add the model preview planl.

Plan PREVIEW

[o]l e =]
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17.16.4 Saving the Plot Frame PPF Files

At any stage of the editing process, the user can write a Plot Frame PPF file that can be read into a Plot
Frame PPF Editor panel at a later time.

This is helpful if you want to close the Plot Frame PPF Editor panel but want to save the changes. Simply
type a file name into the Plot parameter file box at the top of the editor and press the enter key. This
assigns the relevant file extension. Then press the Write button at the top of the panel. The write process
will by default put the file produced into the current project folder

At any stage of the editing process, the user can write out the Plot Frame PPF file and it can be read back
into a Plot Frame PPF Editor panel at a later time. This is helpful if you want to close the Plot Frame PPF
Editor panel but want to save the changes.

To write out a Plot Frame PPF file, simply type a file name into the Plot Parameter file box at the top of
the Plot Frame PPF Editor panel and press the <Enter> key. This assigns the relevant file extension. Then
press the Write button at the top of the panel.

r ™

Plot parameter file |examp|e.p|u:utframeppf Read [Writs]

- Plot Frame User title block parameters
-~ Notes Title file [started basic\Plan Plot.tbf
i Plot to models
o). Title block e | Value s
L User title in 1 | Description line 1 DETAIL SURVEY OF
Drawing re _2 Description line 2 ROAD 1 AREAS
Symbols =7 Description line 3 VILLAGE OF RAIWAL
_4 Drawing number SUVA-001
_5 Client name
6 Surveyor MEEB
" 7| Drawn MEB E
" & Field Book FB-332
" 9 Checked NEB
10 Date of Survey 21/12/15

? Horizontal Datum line 1

E Horizontal Datum line 2

E Level Datum line 1l

14 Level Datum line 2

1

Tirme format |

Start page number [1

Start drawing number |1

Drawving nurmber prefix |

B E @ E E

Drawing number postfiz |

Finish

To read an existing Plot Frame PPF file, the user can choose the file from the Plot parameter file box, then
press the Read button. This loads any existing parameters into the grid.



12d Model Getting Started and Training Manual

17.16.5 Plotting Plot Frame Plan Plots

In the previous section we previewed a plot by plotting to models (e.g preview plan 1 etc) and then added
the models containing the plots to the Plan view PREVIEW (one model at a time).

It is highly likely that you will need to change some of your plot parameters and repeat the plot and
preview process several times before your plots are as you want them.

You are now in a position to make changes to your plot parameters and repeat the plot(s).

When you are happy with the plot, you can change the plotter option in the Plot Frame PPf Editor to the
desired plotter. Double click on the appropriate plotter to select.

Press the Plot button the send the plot file to the selected plotter.

il ™

Plot parameter file |E:cample.pll:|tframeppf Read| [Write

- Plot Frame Single plot frame

Motes Plot frarme |

i Plot to models

é--TitIehIDck Model of plot frames
User title in Model of frames |pfal sunvey
Drawing res View to plot
-~ Symbols View to plot [1 [E]

Plotter parameters

Plotter type |pdf_12d

=
Plot file stem [preview plan.pdf

Digits in plot file number |

Use drawing number as plot file number

[
Use frame name as (non-model) plot file number [l

Press the plot button to send the plot file to the selected device.

«[oom /

[ finished /
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-
ﬁ preview planl.pdf - Adobe Reader SRR X |
[File Edit View Window Help %

Tools Sign Comment

e = Jan 16 1716231 2008
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17.16.6 Saving PPF Files in User Lib for Use with Other Projects

For a particular company or organisation, various styles/specifications may have to be consistent for all
plots. If a standard PPF is created for a company this can be saved to the User_lib directory for easy access
for any project.

‘Y Plot Frame PPF Editor = 2|

Plot parameter file | example.plotframeppf [ Ry .
r]Fczllc:ller * plotframeppf @
=~ Plot Frame Single plot frame example plotframeppf

Motes |
Plot to models

- Title block Muodel of plot frames

Model of frames |pfalsurvey

View to plot

View to plot |1

Plotter pararneters ‘| = r

Plotter type |m|:|de| [ Select ]

Plot file stem preview plan || [Lib] b
Ii [User Lib] *

[Browse]

Use drawing number as plot fi [Browse reset]

n-model) plot file nui [Browse 12d Synergy]
[12d Synergy] »

. . [Relative]
If the user wants to save it to the User_Lib e ]

folder for example, click on [User Lib] to [Ansi format] (System codepage)

open that folder [UTF-& format] (System codepage)

[Explore]
[Delete file]
[Emaill

Uze frame name ag

The name for the plot frame file is then typed into the File name field of the Select a file to open panel
and Open then clicked. The path name is written to Plot parameter file field.

1 Plot Frame PPF Editor | Lol -S|

Plot parameter file | C:\12d\11.00\user_lib\lee.plotframeppf [Read)| [Write

[=- Plot Frame Single plot frame
- Motes | %
- Plot to models
- Title block

Model of plot frames
Model of frames |pfalsurvey

Click on Write to save the file to User_Lib.

Then from any project, the plot frame ppf file can be accessed at any time from a Plot Frame PPf Editor
panel by clicking on the Plot parameter file folder button and then walking write on the [User Lib] button
to see the plot frame files in User Lib.
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P Plot Frame PPF Editor

Plot parameterfile |

=) Plot Frame
i Notes
i Plot to models
- Title block

Single plot frame

Plot frame

Meodel of plot frames

Iodel of frarmes

Remd

el [\irital
Folder

“‘.Irame;i

example.plotframeppf

View to plot
View to plot [
Plotter parameters 4 [t >
Plotter type ’T [ Select
Plot file stem i
Digits in plotfile number [~ ] |[UserLib] Folder ‘plutframepp_E

Use drawing number as plot file number

Use frame name as (non-model) plot file nur | [Browse 12d Synergy] _in_user_

[Browse]
[Browse reset]

[12d Synergy]

[Relative]

[Unicode format]

[Ansi format] (Systemn codepage)
[UTF-& format] (System codepage
[Explore]

[Delete file] ] m b
[Email]

—— il [ Select |

Double clicking on a name in the list will then pipe the name into the Plot parameter file field and then the
Write button pressed to read the plot frame ppf file in.

Then for more specific changes, such as the user text (that is substituted into a title file) the new value can
be entered before say a plot is created.

The modified information can then be written back to the original ppf, or saved to a new plot parameter file
either locally, in User_Lib, or to another folder.
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17.17 Plan Plot Sheet

The Plot Sheet options is a set of tools within 12d Model that permit a series of plot frames on plan views
to be readily composed on the one sheet of paper, and a plot generated and regenerated as required.

The Plot Sheet menu is
Plot =>Plot sheet

and walking right displays the menu

Plot Sheet [E]
Create

Edit ]
Plot »
Delete

We will briefly describe creating a Plot Sheet, and plotting the created Plot Sheet. More information on
Plot Sheets can be found in the 12d Model Reference manual.

We will use the same data and the same Plan view 1 that was used for Plot Frames. So on Plan view 1,
make sure that only the following models are turned on:

ALIGMMENT

R51 Sects

R51 Strs

survey ROAD CROWN

survey ROAD PAVEMEMT EDGE

| Select

and your view Plan 1 should look as follows.

Plan1 [ [-E ) ]

We want to create a Plot Sheet
that has two frames of
information from Plan view 1.

To fit them on a A1 sheet, we
will use a scale of 1:1000 for
both.
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17.17.1 Creating a Plot Sheet
We will first create a Plot Sheet.

Select Plot =>Plot sheet =>Create to bring up the panel Create Plot Sheet File panel.

o =

P Create Plot Sheet File = B[S

Plot Sheet File |
|

y

Type in the name Plot sheet example and press the Create button. This brings up the Create/Edit Plot
Sheet panel.

Plot Sheet File Plot_sheet_sxample Read
= |

create frame
define title block edit frame

delete frame

define plot sheet size IR RSOl

utilities
rotate plot frame

Plot Sheet Drawing Area

or
Plot Sheet Area

Plotter type [pdf 12d
PDFfile |
[ File read!

We’ll first define the title block we wish to use.
Click on the Define title block button to bring up the
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' ™

=-Plot Frame Welcome to the PPF Editor

G- Title block

Finish

This is similar to the Plot Frame node on the Plot Frame PPF Editor for a plot frame (See 17.16.3 Create
Plots Using Plot Frame PPF Editor on page 290).

As before, for the node Title block, tick on Use title file,

= Plot Frame Commen title block parameters

[ Notes Standard title [{Use title file
—- Title block -
.. User title info Title line 1 |
Drawing register Title line 2 |
- Symbols 12d default title block pararmeters

and in the node Title block > User title info, for Title file field select the title file Plan Plot.tbf from the
folder C:\12d\11.00\Training\design\getting started basic.

You can then fill in some of the Title block information.
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- Plot Frame User title block parameters
Notes Title file started basiciPlan P |IJ
=- Title block
Mame |‘u‘a|ue -
.. Drawing register _j_ Description linel DETAIL SURVEY
.. Symbols 2 | Description line 2 ROAD1 AREAS

s Description line 3
_4 Drawing number

5 Client name

[ 6 Surveyor MEB =
_? Drawn MEB

" & Field Book

" g Checked

E Date of Survey

? Horizontal Datum linel

E Haorizontal Datum line 2 b

E Level Datum line 1

1

4 | 1 | r

Click on Set and then Finish, and then the panel will be removed and the title block drawn on the Create/
Edit Plot Sheet panel.

The Sheet Size will be automatically set to that given in the selected title block, and the Create/Edit Plot
Sheet panel will be resized with an aspect ratio to match the page size defined in the title block file.
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[ creserea s
Plot Sheet File Plot_sheet_example Read|
=l "

create frame

Plotter type |pdf_]_2d
PDFfile |

| Paper resized!

We will now define two frames on the Plot Sheet and then specify what information will be plotted in them
from Plan view 1.

Click on the Create Frame icon and then select two points on the plot sheet area to define the area on the
plot sheet that the frame will cover. After the second point is accepted, the Frame Create panel is
displayed
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i F C te
‘fl Frame Crea :

Frame name |Framel

Frame colour [eyan

Scale 1: [1000

Rotation p=

Make center of frame the origin?

World coordinate |

View to draw |

Draw viewport

Click on Make centre of frame the origin?, and then the icon on the end of the World Coordinate field.

Then pick a coordinate from Plan view 1 near the centre of the bottom right intersection, and then click the
Set button. A Plot Frame will then be automatically created with the name Frame 1 and added onto Plan
view 1. The inner border of the plot frame indicates the area that will be drawn in Frame 1 on the Plot
Sheet.

[ Plan1 =m ol =
%




12d Model Getting Started and Training Manual

Click on the Create Frame icon again and then select two points on the plot sheet area to define the area
on the plot sheet that the second frame will cover. Notice that guide lines to enable you to align the corners
of the new frame with respect to existing frames are automatically displayed.

o) B g & O X R

create frame

ide lines when creating a new frame

When the second point of the second frame is accepted, the Frame Create panel is displayed.
Click on Make centre of frame the origin?, and then the icon at the end of the World Coordinate field.

Then pick a coordinate from Plan view 1 near the centre of the top right intersection, and then click the Set
button. A second plot Frame will then be automatically created with the name Frame 2 and added onto
Plan view 1.

(3] Plan1 =2 EoR
B %X )R E
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17.17.2 Using the Plot Sheet Edit Icons

Tl

=

sl

5 & © X @ ®

/ / delete frame

edit frame translate plot frame  rotate plot frame utilities

The Edit frame icon is used to edit frames on the Plot Sheet.
After selecting a frame on the Plot Sheet, resize grips and translate frame grips are displayed for the
frame and used the modify the frame itself. If the frame size is changed in anyway, this will also
automatically modify the drawing area for the plot frame associated with the sheet frame

resize grips

translate frame grip

HEINENENE

The Translate plot frame and rotate plot frame icons are used to translate/rotate the associated plot frame
on the Plan View itself. After the icons are clicked, the plot frame on the Plan View is selected and then
translated for rotated. This modifies what is drawn inside the frame on the Plot Sheet but not the position
of the frame on the Plot Sheet.

The Delete icon is used to delete frames on the Plot Sheet.

The Utilities icon brings up the Plot Sheet Utilities panel which is used to change settings and defaults
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used for the plot sheet
»f. Plot Sheet Utilities =] =
Background colour |gre}r1|:|5
Highlight colour |off yellow
Frarne default colour |c:,rar|

Default draw area width 700

Frame assist on?

Auto bring view to top?

s sEE0EE

Display drawing area 7

The information in the plot sheet can be saved away to the file given in the Plot sheet file ficld by clicking
on the Write button at the top-right of the Create/Edit Plot Sheet panel.

An existing plot sheet file can be read in by filling in the name in the Plot sheet file field and clicking on
the Read button at the top-right of the Create/Edit Plot Sheet panel.

Page 310
= = = L 7 X



Chapter 17 Plotting

17.17.3 Creating a Plot for the Plot Sheet
Only pdf plots can be created for a plot sheet.

To create a plot, simply fill in the name for the pdf file in the PDF file field, and then click on the Plot
button.

Plot Sheet File [plot_sheet_eample Read
v &

Frame 1 Frame 2

Plotter type [pdf 12d
PDF file |plot_sheet_example.pdf
[ File <plot_sheet_example.pdf> will be created

Finish)

The created pdf is then displayed.
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E slot_sheet_exal

File Edit View Window Help

3
T

oo
= -
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